Installing Pacman or Octopi after installing of Garuda

Hello,
I just installed Garuda and tried to install other Software-Apps.
But the Button ' Add/Remove Software' in the Garuda-Welcome screen doesn't work.
So please where I can find Pacman or Octopi?

Regards
Rallebiker

Hi there, welcome to the forum.
The suggested method for installing software in Garuda is via pacman, from the command line.
Learn more here and here.
You probably were thinking to pamac, but we believe that it can create troubles in many cases.
And to update the system,

garuda-update

As for the issue with Add/remove software, please provide your garuda-inxi as requested in the topic template.

3 Likes

First of all, anyway, update your system as suggested above. Octopi had an issue a few days ago, fixed with a "rebuild", for which it didn't start as per your issue.

2 Likes

Thank you, but in case to work on commandline means that I would know the name of the package.

You can search with

pacman -Ss <name>

Or you could consider eg pacseek

sudo pacman -Syu pacseek

Anyway Octopi is fine for searching.
Have you tried

garuda-update

And reboot?

3 Likes

Sorry but I don't understand your community software.
Can't use 'quote' ans 'code'.

:: Paketdatenbanken werden synchronisiert …
 garuda ist aktuell
 core ist aktuell
 extra ist aktuell
 community               7,2 MiB  14,4 MiB/s 00:01 [----------------------] 100%
 multilib ist aktuell
 chaotic-aur ist aktuell

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Paketdatenbanken werden synchronisiert …
 garuda                 95,9 KiB   184 KiB/s 00:01 [----------------------] 100%
 core                  157,7 KiB  1314 KiB/s 00:00 [----------------------] 100%
 extra                1754,2 KiB  6,85 MiB/s 00:00 [----------------------] 100%
 community               7,2 MiB  16,3 MiB/s 00:00 [----------------------] 100%
 multilib              170,1 KiB  1417 KiB/s 00:00 [----------------------] 100%
 chaotic-aur          2029,5 KiB  3,89 MiB/s 00:01 [----------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
 there is nothing to do

Checking for plugin updates
Nothing to install / update

System updated! 🐧
garuda-inxi
System:
  Kernel: 5.15.78-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=8c18065f-324f-4827-860a-7a87f7ad3c7c rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20KD001MMD v: ThinkPad A275
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20KD001MMD serial: <superuser required> UEFI: LENOVO
    v: R0NET46W (1.24 ) date: 04/13/2021
Battery:
  ID-1: BAT0 charge: 14.7 Wh (79.5%) condition: 18.5/23.2 Wh (79.9%)
    volts: 12.0 min: 11.1 model: SANYO 45N1773 type: Li-ion serial: <filter>
    status: not charging cycles: 20
  ID-2: BAT1 charge: 18.8 Wh (87.9%) condition: 21.4/23.5 Wh (91.1%)
    volts: 11.9 min: 11.4 model: LGC 45N1127 type: Li-ion serial: <filter>
    status: discharging cycles: 42
CPU:
  Info: model: AMD PRO A12-8830B R7 10 COMPUTE CORES 4C+6G bits: 64
    type: MT MCP arch: Excavator level: v3 note: check built: 2015
    process: GF 28nm family: 0x15 (21) model-id: 0x65 (101) stepping: 1
    microcode: 0x600611A
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 320 KiB
    desc: d-4x32 KiB; i-2x96 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 1291 high: 1297 min/max: 1300/2500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1296 2: 1283
    3: 1297 4: 1289 bogomips: 19964
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] vendor: Lenovo driver: amdgpu
    v: kernel arch: GCN-3 code: Volcanic Islands process: TSMC 28nm
    built: 2014-19 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:01.0
    chip-ID: 1002:9874 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.3:3 chip-ID: 04f2:b5ab class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x226d built: 2015
    res: 1920x1080 hz: 60 dpi: 177 gamma: 1.2 size: 276x155mm (10.87x6.1")
    diag: 317mm (12.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
  Sound API: ALSA v: k5.15.78-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 1400 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0f0 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24fd
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-1.4.2:6 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 49.41 GiB (10.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFS512GD9TNG-L5B0B size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 80750C10 temp: 29.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 15.77 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.5 MiB (27.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 15.77 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 15.77 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 15.77 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.19 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (RPM): fan-1: 4300
Info:
  Processes: 248 Uptime: 2m wakeups: 2 Memory: 7.19 GiB used: 1.56 GiB (21.8%)
  Init: systemd v: 252 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 Packages: pm: pacman pkgs: 1455 libs: 382
  tools: octopi,pamac,paru Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-15
  Last full system update: 2022-11-16
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

Octopi (Add/Remove software) works fine here (I'm on Dr460nized), from Latte-dock, from Application Launcher, etc.
Does it start from terminal?

/usr/bin/octopi

You can post your

garuda-inxi

by editing one of your posts.

3 Likes

Thanks for providing your garuda-inxi.
I've restored the topic and moved it to the xfce category.
Could you please check if octopi can be launched from the terminal or the menu?
You do have these already:

1 Like

Maybe this could help:

Thanks for help to all.
Octopi , Pamac and Pacseek (with yay) are working very well now.

Will try to learn nicely formatted posts here.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.