Installing ndiswrapper-dkms fails

I want to try ndiswrapper because but internet is unavailable every 20mins (but wifi doesn't disconnect). I also have to click connect and disconnect multiple times before getting wifi connected while the loading status is shown in taskbar or else it keeps loading for a long time.

Might it be related to this issue - Doesn't build with Linux 5.8 · Issue #6 · pgiri/ndiswrapper · GitHub ?

  Kernel: 5.15.54-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=bef56164-5782-4129-94fa-5969dc499b60 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
  Console: pty pts/0 wm: xfwm v: 4.16.1 DM: LightDM v: 1.30.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: <filter> Chassis: type: 10 serial: N/A
  Mobo: HP model: 81EC v: 61.59 serial: <filter> UEFI: Insyde v: F.46
    date: 11/16/2018
  ID-1: BAT1 charge: 0.9 Wh (100.0%) condition: 0.9/32.1 Wh (2.7%)
    volts: 16.5 min: 14.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5-6200U socket: U3E1 bits: 64 type: MT MCP
    arch: Skylake gen: core 6 built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 500 min/max: 400/2800 base/boost: 2200/8300 scaling:
    driver: intel_pstate governor: powersave volts: 0.8 V ext-clock: 100 MHz
    cores: 1: 500 2: 500 3: 500 4: 500 bogomips: 19200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen9 process: Intel 14n built: 2015-16 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:1916 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile]
    vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu
    arch: GCN 1 process: TSMC 28nm built: 2011-20 pcie: gen: 3 speed: 8 GT/s
    lanes: 4 link-max: lanes: 8 bus-ID: 01:00.0 chip-ID: 1002:6660
    class-ID: 0380
  Device-3: Chicony HP TrueVision HD type: USB driver: uvcvideo
    bus-ID: 1-5:4 chip-ID: 04f2:b56c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting,radeon alternate: fbdev,intel,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0687 built: 2015 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.54-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.55 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Broadcom BCM43142 802.11b/g/n vendor: Hewlett-Packard
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:4365 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: enp0s20f0u2 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Samsung Galaxy series misc. (tethering mode) type: USB
    driver: rndis_host v: kernel bus-ID: 1-2:10 chip-ID: 04e8:6863
    class-ID: 0a00 serial: <filter>
  Device-2: Broadcom BCM43142A0 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 1-4:3 chip-ID: 0a5c:216d class-ID: fe01 serial: <filter>
  Report: ID: hci0 rfk-id: 8 state: down bt-service: enabled,running
    rfk-block: hardware: no software: no address: <filter>
  Local Storage: total: 931.51 GiB used: 48.79 GiB (5.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100M
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1U scheme: GPT
  ID-1: / raw-size: 96.68 GiB size: 96.68 GiB (100.00%)
    used: 48.73 GiB (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
    maj-min: 8:7
  ID-2: /boot/efi raw-size: 102 MiB size: 96 MiB (94.12%)
    used: 56.3 MiB (58.6%) fs: vfat block-size: 512 B dev: /dev/sda2
    maj-min: 8:2
  ID-3: /home raw-size: 96.68 GiB size: 96.68 GiB (100.00%)
    used: 48.73 GiB (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
    maj-min: 8:7
  ID-4: /var/log raw-size: 96.68 GiB size: 96.68 GiB (100.00%)
    used: 48.73 GiB (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
    maj-min: 8:7
  ID-5: /var/tmp raw-size: 96.68 GiB size: 96.68 GiB (100.00%)
    used: 48.73 GiB (50.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
    maj-min: 8:7
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.6 GiB used: 1.28 GiB (35.6%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 41.0 C pch: 39.0 C mobo: N/A gpu: radeon
    temp: 39.0 C
  Fan Speeds (RPM): N/A
  Processes: 243 Uptime: 17h 58m wakeups: 39 Memory: 3.6 GiB
  used: 2.22 GiB (61.7%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1276
  lib: 333 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.19
Garuda (2.6.5-1):
  System install date:     2022-04-04
  Last full system update: 2022-07-14
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager

  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:        

Edit: broadcom :sneezing_face:

I think you should focus on

not on ndiswrapper.
Your inxi tells that you use wl driver but bcma is also available. Can you blacklist wl, reboot and try wi fi again?

1 Like

Ndiswrapper is an extremely old method of installing wifi drivers. It has been out of common usage for a decade. This is not a method that should be used with Linux anymore.

You are likely suffering from interrupts due to "wifi power saving". Search the forum with the terms within quotation marks and you will be likely to find your solution.

Also be sure your bios is up to date and test several alternate kernels.

I would also disable MAC Address randomization.

Also, be sure to check your lease time in your router's settings and be sure that it is set to at least a full day, then restart your router.

I now notice your install date was back in April. You did not mention if this issue has been present since you first installed, or if this problem began recently. This is very important information we need to know to diagnose a cause effectively.

Ha ha, Broadcom.


It was there since first install but I resolved to usb tethering for a long time. I will try the recommendations and update. Also the wifi is nearly perfect when I connect to the hotspot on mobile. But I want it work with the D-Link modem at home. Other than mobile hotspot, I tried two different D-Link modems and the problems persists.

Edit: I tried everything given here Realtek RTL8822CE Wifi - limited connectivity - #5 by tbg except changing kernel