Installing and playing windows games

I tried to install street outlaws 2 winner takes all, i can get wine to install and run it but it wont load, it crashes. I tried to use playonlinux but i had the same outcome. i think i'm doing something wrong. game opens and says fatal error after about 10 seconds.

any help or ideas would be appreciated.

Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=453092bf-16eb-4fa2-9643-a0e413678109
rw [email protected] quiet
cryptdevice=UUID=42bc0ad4-90a9-4f07-8a4c-78f17bd64474:luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474
root=/dev/mapper/luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-bd92b9d8-d6a0-4438-9c6e-a327dabdb6fc loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Pavilion Laptop 15-eh0xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 87C5 v: 35.24 serial: <superuser required> UEFI: AMI v: F.12 date: 03/04/2021
Battery:   ID-1: BAT0 charge: 37.2 Wh (100.0%) condition: 37.2/37.2 Wh (100.0%) volts: 12.8 min: 11.3
model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full cycles: 334
CPU:       Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L1: 384 KiB L2: 3 MiB
L3: 8 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28446
Speed: 3477 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 1: 3477 2: 3453
3: 3400 4: 1577 5: 2529 6: 1397
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1921x2160 s-dpi: 96 s-size: 506x570mm (19.9x22.4") s-diag: 762mm (30")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5") diag: 184mm (7.2")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.6-zen2-1-zen LLVM 13.0.0) v: 4.6 Mesa 21.2.5
direct render: Yes
Audio:     Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x bus-ID: 04:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 281.12 GiB (58.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ512HALU-000H1 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS4NFXV temp: 25.9 C scheme: GPT
Partition: ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 281.12 GiB (60.1%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 720 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 281.12 GiB (60.1%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474
ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 281.12 GiB (60.1%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474
ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 281.12 GiB (60.1%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-42bc0ad4-90a9-4f07-8a4c-78f17bd64474
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.19 GiB used: 847 MiB (11.5%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
maj-min: 254:1 mapped: luks-bd92b9d8-d6a0-4438-9c6e-a327dabdb6fc
Sensors:   System Temperatures: cpu: 62.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 294 Uptime: 5h 33m wakeups: 1277 Memory: 7.2 GiB used: 4.03 GiB (56.0%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
pacman: 1744 lib: 514 Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole
inxi: 3.3.09

Did you try using lutris to run this game? or another way is maybe try adding it to steam as a non-steam game and in properties there is a section called compatibility, and you can force it to use different versions of proton. I personally haven't used playonlinux(besides that everytime I tried it I was faced with it never working to do what I wanted it to do) in years, lutris or steam are how I get most games to work that aren't native or aren't steam games to begin with. Also what platform did you get this game from?

1 Like

There is no report yet in protondb.com for that game. We cannot verify if that game is supported under Proton.

Screenshot_6

Also, I would like to point out they want more graphics card and ram than your system currently has, so you may not get a good experience with it even if you do get it to run at all.

2 Likes

Yeah gaming on a laptop is a bad experience in the first place but that games requirements are pretty high. The APU in your machine is maybe equiv of a GTX 1030 or 1050. (Given the system specs list only nVidia cards for reference.)

2 Likes

i didnt even look at specs thinking a game like this was not high spec...my mistake i overlooked this..ill delete the thread.

As a last note also remember your using an APU i.e. your system memory is also your VRAM. The game doesn't even say WHICH 1060 (maybe it means the 3Gb model maybe the 6Gb. The core is the game will probably nuke all your memory post haste and that's probably what gave the sudden crashes and probably started a bit of swapping for the system processing once the GPU was like MY MEMORY!

3 Likes

i plan to get 32 gb of ram for this sometime soon, i would assume my pagefile would have filled and sufficed but my logs say the game only used a little over a gb of ram before it crashed,,,

Well that's promising. IF/when you get that extra RAM (if you haven't refunded the game) you can try again. I might need all the settings on low but it might be OK. Plus Proton is always being updated for this stuff. Which is also to say don't use Lutris and POL if the game "comes" with Proton, proton will work best (if at all). I mean your CPU is up to snuff for sure. It's the APU that's kinda meh.

It's kinda sad how a lot of the current APU's are only like Vega 64 level. Like hell yeah it will run a mean spreadsheet but jeeze...pretty lack luster. Don't get me wrong, the nVidia mobile models are hella weak and missleading too but lordy.

For example I just built my roommate a machine with a Ryzen 5700G. The APU is as I said basically 1030/1050 level so it can't even match or replace her OLD GPU from like 7 years ago! So basically APU runs side screens old GPU runs main gaming screen.

1 Like

AMD will never release Aerith APU until the Steam Deck is officially everywhere. As basically when that APU is in the DiY market, everyone can make their own HackinDeck, as SteamOS 3.0 will also be publicly released. That in itself will cannibalize the sales of the Steam Deck.

Aerith is the code-name for the AMD APU with built-in RDNA-2 graphics.

1 Like

Unless the APU comes with eDRAM or HBM the performance will always be lackluster because of the inadequate memory performance.
Making that worthwhile means having a rather large chip, which means quite a lot of power for the GPU portion which'd leave the CPU portion weak whilst still pumping out a substantial amount of heat.

APUs should remain a budget gaming option but primarily "accelerating" the CPU for compute and simply providing video decode/encode/output.

Like I said, it runs a mean spreadsheet :wink:

I know it's "marketing" but it's painful seeing "gaming" laptops. That's like saying I have a fridge stove! Which is also "gaming" slapped on the name or model or not gaming on any laptop is a bad time.

1 Like

The performance of the gpu in this apu is equivalent to a 4850 with a new feature set. running most modern games on medium or low 1080 should be a viable option. but i do need to get more memory .

4850 is what 12 years old heh. I have a 4750 which was the worlds fastest when it came out. While the APU will support modern shaders and DX it's really just not up to most modern games. Indie games maybe but full on Triple A 3D games you're gunna have a bad time.

Like this "marketing" (read LIES).

spoiler

It's a bottom feeder GPU from 2010 being sold in a "gaming" machine in 2021

Yeah like how the RTX3060 (Q not Q) is more like a GTX1050 with ray tracing you can't use because it's a 1050 :wink: But yeah that's kinda how I feel about all APU despite being a desktop build. CPU from 2021, GPU more like 1990.

This should be the least optimized game ever. Minimum 16 GB RAM. What is this flight simulator?

1 Like

lol right? Pretty insane for a driving game.

Yeah I agree. My system isn’t even up to snuff with a gtx 970. I was just trying to help diagnose the OPs problem without spending $40 to test it my self. And noticed that high of requirements.

My machine would run it fairly easily but I wouldn't care. Those requirements are insane. Driving game is really EZ mode for so much. I mean a lot of objects can only be 2 sided drastically decreasing render, LOD and just everything involved. Predictable and limited draw distances and very minimal divergence from player view. I mean come on! Those devs are drunk! Those spec make Tarkov look like it would run on a gameboy.

1 Like