Installer failed to create partion

Hey garuda support i need help as soon as possible , i followed the steps of https://youtu.be/qst6Z84yyvi and everything went fine till 12:15 i was unable to do tht so i went with replace partition and i went through all the steps but at the installation a dialogue box popped up saying failed to create partition

i went back on my system i did the partition about 2 times 1st for 100gb from drive and 50gb for the 2nd time from drive d i am really help less right now pls help me

The link to the video you followed is not working. My first comment would be, don't follow random videos off YouTube to install Garuda. I would also need to ask:

What file systems did you format the partitions.?

How old was this video?

Was it Garuda specific?

Was it btrfs specific?

I'm only on my cell so I can't read the picture you posted. Never post a picture unless no other method is available. Textual outputs are always the expected way of posting system information on Linux support forums.

Please read the Garuda Wiki regarding reporting bugs. Then post your system specs with the inxi command.

my file partition supported NTFS
the video is about 2 weeks old
i am installing KDE dr460nized version
yes the installation was btrfs specific

What do you mean with this exactly?
Do you already have another linux system installed?
If so, provide more info from terminal commands.
Reporting bugs | Garuda Linux wiki
How to search for solutions the right way | Garuda Linux wiki

1 Like

NTFS is a Windows file system format, you cannot install Garuda to an NTFS partition. I suggest you follow the installation steps listed on the Garuda Wiki. I will not provide you with instructions on how to install a dual boot with Windows as this is simply a recipe for problems.

Awaiting your system specs.

Also please post:

sudo blkid -o list
1 Like

let me describe the whole thing so ,

i have windows 10 installed on my C drive already and i installed garuda kde dragonized versions ISO file and used rufus to dual boot by creating a partion on my D drive whivh supported NTFS system and when i restarted my PC i booted with the usb stick in which i had installed garuda then when the installation setup poped up i continued the process with replace disk partition option and the intsalltion failed dialogue box came up saying

The installer failed to create partition on disk "WDC WD5000BEVT-60A0RT0"
======================================================================
create a new partition (48.3GiB , btrfs) on /dev/sda
======================================================================
======================================================================
job :create a new partition on device /dev/sda
=======================================================================
=======================================================================
command :sfdisk --force --append /dev/sda (how can i run the command when i am unable to open the console)
======================================================================
failed to add partition "New Partition" to device ' dev/sda". failed to add partition failed to add partition "New Partition" to device ' dev/sda".

umm
system specs : 4gb ram , intel core i3 (2012) windows 10 , HP g62 notebook pc

Have you disabled SecureBoot from BIOS and FastBoot in Windows?

no i havent

There you are.
Don't do random things to your system and then ask for help on your faults, BEFORE you have read enough on what you are doing.

3 Likes

alright thanks for ur great help ill chek wiki first then

I'm going to give you one more chance to provide the terminal outputs that two moderators have requested from you.

Read the wiki section on reporting bugs and post your inxi output as referenced on the wiki and the blkid output I requested.

Refusing to do so will result in your thread being temporarily locked until you edit your initial post to include this information.

This must be done before you can install Garuda. Did you follow some Ubuntu video tutorial or something, because almost every other distro requires these to be disable before you can successfully install.

2 Likes
╭─garuda at garuda-dr460nized in ⌁
╰─λ sudo blkid -o list
device     fs_type label    mount point    UUID
-----------------------------------------------------------------------------
/dev/zram0 swap             [SWAP]         51c139aa-e8a0-4619-b823-8ec50269e9e5
/dev/zram1 swap             [SWAP]         fdbbf635-20f7-4d04-9bfe-93bb0689f3d2
/dev/zram2 swap             [SWAP]         0a1c2890-33b1-4b91-b835-978a5a8fad9b
/dev/zram3 swap             [SWAP]         fca087fd-c0e8-421a-b410-45c5346d83c0
/dev/sda1  ntfs    System Reserved (not mounted) DAD6DBCED6DBA8D1
/dev/sda2  ntfs             (not mounted)  0C2EF3682EF3496A
/dev/sda3  ntfs             (not mounted)  4AA24159A2414B21
/dev/sda4  ntfs             (not mounted)  769AF9F09AF9ACAD
/dev/loop0 squashfs         /run/miso/sfs/livefs 
/dev/loop1 squashfs         /run/miso/sfs/mhwdfs 
/dev/loop2 squashfs         /run/miso/sfs/desktopfs 
/dev/loop3 squashfs         /run/miso/sfs/rootfs 
/dev/sdb1  iso9660 GARUDA_DR460NIZED_SOARING_ (in use) 2021-01-07-08-03-43-00
/dev/sdb2  vfat    MISO_EFI (in use)       EDF5-95D0

Please follow the Garuda Wiki not random YouTube videos for install info. I really don't think you should be dual booting. You obviously haven't done enough research on this yet.

To post terminal outputs properly you need to put three ~ symbols before and after your code. This is explained on the Wiki regarding how to report bugs.

I will edit your post. Check how I formatted it for you to see how it's done.

2 Likes

Are you intending to wipe Windows from your system?

4 Likes

I already have Windows 10 installed on my C drive and I installed an ISO file with garuda kde dragonized versions and used rufus to create a partition on my D drive that supports the NTFS system.

It does not work like that. If you want to install Garuda on the D drive, you will need to disconnect the C drive.
In UEFI, make sure that "Secure Boot" is set to "disabled". You may have to assign a password for this. You can leave "Fast Boot" to "enabled".

Blockquote

So far I have always read differently but try makes wise.

I have always activated Fast Boot, no matter which distro I install.
The next time I boot up, I'll disable it and see what changes.

1 Like

After booting several times - 2 times disable, 2 times enable, I couldn't find any difference.
So it doesn't seem to matter which setting you prefer.

Because your hardware does not have a problem, it doesn't mean it's a general feature for all HW.
There are unlimited reports from users of various distros, that suggest that setting blocks them from installing Linux. Some say that after installing Linux, they could boot again, even after re-enabling fastboot. A lot say the opposite.
It depends on the vendor UEFI application. :wink:

2 Likes