Installation Fails Due to Bootloader Error

Hello! I've been trying to install Garuda Gnome without success multiple times. I've tried both booting with open source drivers and NVIDIA drivers; both times get me the same error. I've tried two different laptops with a decent difference in hardware (one high end, the other mid). I'm not sure if it's something I'm doing wrong, but if it is, could you maybe explain the why behind the what for me so I can learn? Inxi is posted below:

Result of garuda-inxi from live iso:

  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_GNOME_TALON quiet
    systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
    i915.modeset=1 radeon.modeset=1
  Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX516PM_FX516PM
    v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: FX516PM v: 1.0 serial: <filter> UEFI: American
    Megatrends LLC. v: FX516PM.322 date: 08/27/2021
  ID-1: BAT0 charge: 52.2 Wh (84.6%) condition: 61.7/76.0 Wh (81.1%)
    volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: charging cycles: 75
  Info: model: 11th Gen Intel Core i7-11370H socket: U3E1 bits: 64
    type: MT MCP arch: Tiger Lake gen: core 11 level: v4 note: check
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8C (140)
    stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2739 high: 3300 min/max: 400/4800 base/boost: 3300/4800
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 3300 2: 3300 3: 1128 4: 3300 5: 986 6: 3300
    7: 3300 8: 3300 bogomips: 52838
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-10)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 ports:
    active: none empty: HDMI-A-2 bus-ID: 0000:01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Display: server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting,nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: Najing CEC Panda 0x004d built: 2019
    res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:2e:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno2 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:3 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 593.04 GiB used: 6.34 GiB (1.1%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLQ512HBLU-00B00 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: FXM7201Q temp: 33.9 C scheme: GPT
  SMART: yes health: PASSED on: 96d 8h cycles: 935 read-units: 28,002,406
    [14.3 TB] written-units: 40,388,442 [20.6 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SMI (STMicroelectronics)
    model: USB DISK size: 116.1 GiB block-size: physical: 512 B logical: 512 B
    type: N/A serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.32 GiB used: 290.2 MiB (1.9%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 290 Uptime: 23m wakeups: 2324 Memory: 15.32 GiB used: 3.45 GiB
  (22.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1134 libs: 314
  tools: pamac,paru Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-12-05
  Last full system update: 2022-12-04 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service

What is the error?

Make sure secure boot is disabled.

How big is the EFI partition? Make sure Windows has left enough space, or the partition is not full for some other reason.


It's been returning an error code: 1

My secure boot is for sure off.

I figured out the issue! I'm using a separate partition from the Windows for my EFI partition. :slight_smile: but.... My partition of 850MiB was too small... Lol once I increases the size up to 1,050MiB, it ended up installing just fine!

So the bootloader is failing when I choose open source drivers.
The NVIDIA drivers option installed, but then would freeze when loading the ram and kernel upon first reboot after install.

The error says:
"The bootloader could not be installed. The installation command

grub-install --target=x86_64 --efi-directory=/boot/EFI --bootloader-id=Garuda --force
returned error code 1."

Chroot into the installation and run this command instead:

grub-install --target=x86_64 --efi-directory=/boot/EFI --bootloader-id=Garuda --force --no-nvram --removable

Thanks for the help, I'll give this a try and report back!
First, I'm googling how to chroot into the installation. :joy:

Okay, well that's weird. I did a reinstall (just to be sure), and this time increased the EFI partition to 1250 MiB instead of 1050MiB, and this time the installation went through just fine. I guess it needs over a gig for the EFI? I rebooted to make sure everything was good, and it booted just fine into the new installation. I guess it just needed more space! It's just odd that the NVIDIA installed to the EFI partition that was 1050 just fine, but the open source needed 1250?


zram0       254:0    0  13,5G  0 disk [SWAP]
nvme0n1     259:0    0 953,9G  0 disk
├─nvme0n1p1 259:1    0   260M  0 part /boot/efi

I never need more than 260 Mb


Then I'm not sure why it failed 4 different times on two different laptops, but then suddenly installed just fine, and the only change I made was increasing the EFI to 1250MiB... The important thing is that it's working now. I appreciate this community! The helpfulness (even tough love that I see and experience) is the reason I always keep coming back to Garuda (and the sick distros too!) no matter how much I distro hop! Love the distros, love the community here!


I don't believe I've heard others refer to our methodology here as "tough love" before. We prefer to refer to it as "teaching a person to fish". :wink:

Nice job deducing a fix.

1 Like

I suppose "tough love" is just how it feels. Lol I know you all try to help and it truly is a different I've found between Garuda and other distro forums. Love this distro and love all the work the team members put in. You all are genuinely appreciated.

1 Like

Wow, it is very unusual to need such a large EFI partition. Have you looked to see what is being stored on it? I would try to leave anything Windows-related alone, but check to see if normal user files have been saved to this disk by mistake.

I have a 1 gig EFI partition I set up for a multiboot machine that has 18 separate 80-gig partitions (each for a separate Linux installation, they all share the EFI partition) and even with all 18 installations up I have never come close to filling up the full gig.

:point_up: This is very reasonable. Most systems will use even less, even dual-booting setups.


Well, whenever I installed, I had unformatted space there, and I created the EFI partition (FAT32, mounted as /boot/efi and labeled as boot), and then I created the normal btrfs partition mounted at /. Nothing from Windows should be on there since I created the partition at install, and nothing user-wise is on there as I formatted it as FAT32 and mounted it for /boot/efi only. I'll have to go in and check a little bit later since I'm currently on a work conference call. It's odd. The only other distro I've seen that requires 1GB+ were Fedora based distros. I'm sure it's something I'm doing wrong.

With UEFI installations, no distro should require that much, and IMO the partition size was not the real problem, but a coincidence, or a secondary trigger.
The most certain thing is that your laptop vendor UEFI implementation is bad (the lightest description I have...).

Rebooting creates different HW/firmware conditions.
The phase of the moon is known to produce such issues, as well. :stuck_out_tongue_winking_eye:

Have a nice day! :sunflower:


Yeah... I've heard ASUS is terrible with Linux compatibility... It was a gift so you can't beat free haha.

Thank you again all for the help, and I hope you have a great day as well! :sunny:


Sun spots as well. :rofl:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.