Incomplete system shutdown

Hi to everybody,
I am using Garuda Linux dr460nized since few days (my first linux experience) and I like it a lot, but I encountered an issue.
If I try to shutdown the system, it freezes and does not completely shutdown even after many (12) hours. The monitor, the keyboard and the mouse are still connected, fans continuate to rotate, monitor displays black screen with no messages.
Here is the otput of journalctl -rb -1 of a session, experiencing the incomplete shutdown:

Journal WITH issue

Since I noticed a possible issue with NetworkManager.service, I tried to turn off bluetooth before shutdown the system. This time, the shutdown is completed in few seconds with no issues.
Here is the otput of journalctl -rb -1 of a session, not experiencing issues:

Journal NO issue

However, when I boot again the system I cannot turn on bluetooth, settings menu shows no options available (I am a new user, so I cannot post a screenshot).
Here is the output of systemctl status bluetooth:

○ bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: inactive (dead)
Condition: start condition failed at Fri 2021-06-18 19:06:49 CEST; 53min ago
└─ ConditionPathIsDirectory=/sys/class/bluetooth was not met
Docs: man:bluetoothd(8)

giu 18 19:06:49 andrea-vaio systemd[1]: Condition check resulted in Bluetooth service being skipped.

In order to enable bluetooth I have to run the command rfkill unblock bluetooth.

How can I solve the issue with the incomplete shutdown? Is it due to bluetooth as I suspect?

Maybe important info: as soon as Garuda Linux installed, it did not connect to my soundbar with bluetooth. In order to connect it successfully, I had to downgrade Bluez to 5.50-7.

Here my system data:

System:    Kernel: 5.12.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=067d6a1b-1bdf-49e0-b577-9243ee1d4f17 rw 
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=da348988-5302-4a90-9a55-269f9ffaed69 loglevel=3 nouveau.modeset=0 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Laptop System: Sony product: SVS1511C5E v: C60AUFMB serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: Sony model: VAIO serial: <filter> UEFI: Insyde v: R0142C5 date: 05/17/2012 
Battery:   ID-1: BAT1 charge: 11.8 Wh (100.0%) condition: 11.8/52.2 Wh (22.7%) volts: 12.4 min: 11.1 model: Sony Corporation 
type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: Intel Core i7-3520M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
stepping: 9 microcode: 21 cache: L2: 4 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 23146 
Speed: 2348 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 2348 2: 1221 3: 1875 4: 3392 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Sony driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GK107M [GeForce GT 640M LE] vendor: Sony driver: N/A alternate: nouveau bus-ID: 01:00.0
chip-ID: 10de:0fd3 class-ID: 0300
Device-3: Foxconn / Hon Hai USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-1.3:3 chip-ID: 0489:d601
class-ID: 0e02
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: LVDS1 res: 1920x1080 hz: 60 dpi: 139 size: 350x190mm (13.8x7.5") diag: 398mm (15.7")
OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.1.2 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Sony driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.12.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.30 running: no
Network:   Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: 6000 bus-ID: 02:00.0 chip-ID: 8086:088e
class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Sony driver: r8169 v: kernel port: 3000
bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth: Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB driver: btusb v: 0.8 bus-ID: 1-1.2:4
chip-ID: 8087:07da class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 15.62 GiB (7.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s rotation: SSD serial: <filter> rev: B1D2 scheme: GPT
Partition: ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 14.02 GiB (28.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 153.07 GiB size: 153.07 GiB (100.00%) used: 1.6 GiB (1.0%) fs: btrfs dev: /dev/sda3
maj-min: 8:3
ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%) used: 14.02 GiB (28.0%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%) used: 14.02 GiB (28.0%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4 maj-min: 8:4
ID-2: swap-2 type: zram size: 1.92 GiB used: 138 MiB (7.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.92 GiB used: 135.9 MiB (6.9%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.92 GiB used: 137.3 MiB (7.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.92 GiB used: 135.3 MiB (6.9%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 268 Uptime: 57m wakeups: 1 Memory: 7.67 GiB used: 3.18 GiB (41.5%) Init: systemd v: 248 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1242 lib: 294 Shell: fish v: 3.2.2 running-in: konsole
inxi: 3.3.04

Do you dual boot with Windows?

Info

Read

please
and post

inxi -Fza

as text!

and
:slight_smile:

BTW, you can post here text files up to 32,000 chars.
For bigger ones, you can use our PrivateBin https://bin.garudalinux.org/

Maybe no one likes to download files from unknown sources, no offence, it's much better than trying to upload pictures here that contain a short error text in the terminal.
:slight_smile:

3 Likes

Thank you for the useful links.
I updated my post with links to PrivateBin containing terminal longer outputs. I also added my system info at the bottom of the post.
I do not dual boot with Windows: my installation is stand alone.

1 Like

But the logs show that BT is stopping successfully.
I suggest you turn WiFi off, or stop NetworkManager.service before shutdown.

The issue seems to start from nm-dispatcher, but it is not certain.
Maybe @tbg knows more about this adapter

Also confirm your system packages are fully updated.

2 Likes

Have you tried with other kernels?

4 Likes

Kernel is often the culprit in these cases. Test alternate kernels for improvement.

Search "Test alternate kernels" on the forum for the most recommended ones to try.

Another likely cause of this type of problem is a bios that is not up to date.

You might also want to test alternate versions of Intel firmware for your adapter.

Do you have powersaving disabled for your wifi adapter?

If you cannot fix your problem via other standard methods a shutdown service and a startup service for your bluetooth, and/or wifi or network manager, would probably allow you to work around your issue.

6 Likes

Hi bro, have you tried this way?
1:) Open Terminal :wink:
2:) sudo pacman -S bluez bluez-utils :slight_smile:
3:) sudo systemctl start bluetooth :slight_smile:
4:) sudo systemctl enable bluetooth :+1:
If It Doesn't Fix Again, If You're Using Gnome, Switch To KDE. If You're Using KDE, Use Gnome Brother, I Wish You A Good Forum :slight_smile: :+1:

2 Likes

Lütfen, yalnızca dil alanının dışında İngilizce kullanın.
Please, use only English outside the language area.

2 Likes

Such a wonderful saying! I'll keep it as a sticky note on my desktop and add it to fish_greeting and Tabliss's message!

3 Likes

Also confirm your system packages are fully updated.

Yes, all my packages, but Bluez, are updated.

Have you tried with other kernels?

Kernel is often the culprit in these cases. Test alternate kernels for improvement.
Search "Test alternate kernels" on the forum for the most recommended ones to try.

I installed linux-lts kernel and set it by default. Done some shutdown and reboot test and I get issues no more: the system successfully shutdowns completely. :smiley:
Also bluetooth and wi-fi work fine. :smiley:

Thank you so much for your help and time!

2 Likes

Turkic's languages cannot be translated 1: 1 into English.
This can lead to misunderstandings.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.