I want to Slide Show Wallpaper in Garuda Qtile

i want make "Variety" work with WM as it works with only DE.
when i launch Variety and apply wallpaper i get "Destop Manager Not Active Error" So i run "pcmanfm --desktop" then it works but I want to make it work without it
(also i am using variety for slideshow wallpaper if there are any alternatives i will do it.
I can use Nitrogen or Feh but they will not slideshow wallpaper)
i am not posting garuda-inxi 'cause i don't think it would be required.

Try adding
run variety &
to
~/.config/qtile/scripts/autostart.sh

PS:

Please try to stick to the rules in the future, if they are there there is a reason. And it is a form of respect for those who set them.

1 Like

okay

that won't work as it requires a destop manager to run unlike nitrogen and feh.

i have added "pcmanfm --destop" command in the auto run script to make Variety work.
i looking for alternate wallpaper slideshow. like feh and nitrogen but they don't slide show

also i want to switch because


like here it completely use the whole workspace to work

which seems like a waste so i want something like nitrogen or feh to have slideshow wallpaper that changes wallpaper for like every 5-6 minutes

Maybe try with feh like here:

1 Like

Sorry but that will not work and i tried that again now but it still doesn't work.
i know the reason why because qtile is a WM and variety works on a DE and i have ready solved that problem by putting pcmanfm --destop in the auto start script.
the problem with 'pcmanfm --destop' is it makes the workplace ugle and wastes a workplace.


the workplace looks like this which wastes a workplace.

So i just need a slide show wallpaper replacement for Variety. Like Nitrogen or Feh that can Slide Show Wallpaper.

Maybe i should change the title to "how to slideshow wallpaper in Garuda Qtile"
Sorry

Hi @nimizu ,
I reset your post history, the formatting of the garuda-inxi output was not correct. For some unknown reason, this post cannot be edited otherwise by the moderators.

Here, with the correct formatting, does not take up so much space :slight_smile:

System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b6243109-eaa1-4cb7-98ad-47f3da449a9b rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=e1d71fae-43bb-411a-9b02-6303b3848b2d loglevel=3 ibt=off
Desktop: Qtile v: 0.22.1 wm: LG3D vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: INTEL model: H61 serial:
UEFI: American Megatrends v: 4.6.5 date: 03/05/2019
CPU:
Info: model: Intel Core i3-2120 bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1760 high: 2254 min/max: 1600/3300 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1596 2: 1596 3: 1596
4: 2254 bogomips: 26340
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GF119 [GeForce GT 610] driver: nvidia v: 390.157
alternate: nouveau,nvidia_drm non-free: series: 390.xx+ status: legacy-active
(EOL~late 2022) arch: Fermi code: GF1xx process: 40/28nm built: 2010-16
pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:104a class-ID: 0300
Display: x11 server: [X.Org](http://X.Org) v: 21.1.5 compositor: Picom v: git-c4107
driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x261mm (19.02x10.28")
s-diag: 549mm (21.61")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
size: 479x260mm (18.86x10.24") diag: 545mm (21.46") modes: N/A
API: OpenGL Message: Unable to show GL data. Required tool glxinfo
missing.
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e08 class-ID: 0403
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac:
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-1.2:4 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Drives:
Local Storage: total: 1.93 TiB used: 410.89 GiB (20.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: GALAX model: GAMER L TA1D0120A
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: SSD serial: rev: 61.3 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: rev: HP35
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD15SMRW-11YNDS1 size: 1.36 TiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 5400 serial: rev: 1020
Partition:
ID-1: / raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 12.55 GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 12.55 GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 12.55 GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 12.55 GiB (12.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.72 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 58.0 C mobo: N/A gpu: nvidia temp: 60 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:
Processes: 212 Uptime: 18m wakeups: 0 Memory: 7.72 GiB
used: 2.73 GiB (35.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1122
libs: 314 tools: pamac,paru Shell: fish v: 3.5.1 running-in: alacritty
inxi: 3.3.24
Garuda (2.6.10-1):
System install date: 2022-12-18
Last full system update: 2022-12-19
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: No/Undetected
Snapshots: Snapper
Failed units:
1 Like

Maybe i should repost it

Umm... Sorry i am unable to delete it or edit my post something is wrong with my post


This one I can edit :grin: SGS

Yeah, some forum software faults.
The inxi is there, so, no problem.

BTW, I also use a WM, and see my desktop for a few seconds at most.
Why do you need a slideshow there :wink: ?

1 Like

Disclaimer: I'm not using QTile and I don't really know.

That said, is this of any use?
python - Change wallpaper every 10 minutes on Qtile - Unix & Linux Stack Exchange

2 Likes

To see my waifu collection lol :grin:

2 Likes

yep a bit, is there any command within feh or nitrogen to do the same.
when i was using arch with qtile i didn't use login manager and add nitrogen --set-zoom-fill --random /home/nihu/Pictures/k/ --save & this line to .xinitrc but it only sets wallpaper if i relogin, power on or reboot.
i need something that periodically launches this command

i think i found the solution at Wallpaper Slideshow With Nitrogen - Ubuntu Openbox

it needs some 'cron service' to be enabled

but i get the error

sudo systemctl start cron
Failed to start cron.service: Unit cron.service not found

After the last comment, I was also thinking of some "old school" job of that kind.
The current alternative to cron would be a systemd timer, but I think it's overkill for this task.
A simple python script like the one above can do, it should also be relatively easy to adapt to your needs in case it's not exactly what you are looking for.

Now that I think of it, azote. I think that is used on Sway, I seen the name before.

1 Like

thankyou all for the help
thnx :smile:

Scrap that, it looks like there's no slideshow in azote.

2 Likes

Install cronie?

I found no settings for slideshow in azote, used in Garuda i3wm. Like I said, noone need a slideshow in wm's :grin:

2 Likes

Personally, I agree. Mine is that noisy gray stuff, since last year.

2 Likes