I made a big mistake switching to Garuda Draganized

I was using Linux mint and attracted by Garuda Draganized version by its look. But after I switched to Garuda Draganized, I realized I made a big mistake. I am going to list out some of the problems.

  1. Slack application login is not working no matter what browser I use. I tried Brave, Chrome, Vivaldi. Slack application redirects to browser when I click on login and I continue to login on the browser tab and at the end, it redirects me to slack app, but slack app not working after that too. I don't think its browser related problem as I tried multiple browsers.
  2. I am using vivaldi browser for my daily browsing. When I open slack website on vivaldi, it continuesly crashes after few minutes. I never seen one website can bring down my entire browser application in any other OS. I tried disabling psd, installign vivaldi for all users, nothing worked.

I am not a quick judger. I tried to stick around with Garuda Linux for some days now. But it really wants to go away from me.

I am using multiple applications like pycharm community ide, zoom, youtube app, virtual box, authy, google authenticator, discord, whatsapp app, google chat app, etc.. I haven't tried any of these apps in garuda linux yet and I don't want to. Because I am really not sure how much bugs are you hiding in those apps in Garuda linux. I have no other choices other than switching to another OS now. I am a big fan of Linux for my productivity based works and Garuda Linux disappointed me a lot.

I don't want to troubleshoot anything now. Because I just wanted these apps to work out of the box in linux distro and it worked in that way in all other linux distros except Garuda linux. I just want you to know these problems are really existing in your Garuda linux.

System:
Kernel: 5.19.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=e2ff12dc-7315-403a-90ad-1155edbabe97 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=eef3fb26-927e-46e1-a9fa-7ed1145f1433 loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B550M DS3H AC
serial: <superuser required> UEFI: American Megatrends LLC. v: F14e
date: 10/13/2021
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 2515 high: 3640 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
3: 3103 4: 2876 5: 3640 6: 2200 7: 2962 8: 2200 9: 2200 10: 2200 11: 2200
12: 2200 bogomips: 88633
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU106 [GeForce GTX 1650] vendor: ASUSTeK driver: nvidia
v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
(as of 2022-07) arch: Turing code: TUxxx process: TSMC 12nm
built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 09:00.0 chip-ID: 10de:1f0a class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
s-diag: 693mm (27.28")
Monitor-1: DP-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.54x13.23")
diag: 686mm (27.01") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA
515.65.01 direct render: Yes
Audio:
Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.19.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-9:2 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.36 TiB used: 15.98 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
temp: 38.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00BBHA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 69.7 GiB size: 69.7 GiB (100.00%) used: 15.78 GiB (22.6%)
fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot raw-size: 1024 MiB size: 1024 MiB (100.00%) used: 201 MiB
(19.6%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /boot/efi raw-size: 310.9 MiB size: 310.3 MiB (99.80%) used: 608
KiB (0.2%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /home raw-size: 69.7 GiB size: 69.7 GiB (100.00%) used: 15.78 GiB
(22.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/log raw-size: 69.7 GiB size: 69.7 GiB (100.00%) used: 15.78
GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-6: /var/tmp raw-size: 69.7 GiB size: 69.7 GiB (100.00%) used: 15.78
GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p8 maj-min: 259:8
Sensors:
System Temperatures: cpu: 50.8 C mobo: N/A gpu: nvidia temp: 43 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 26%
Info:
Processes: 314 Uptime: 19m wakeups: 0 Memory: 15.53 GiB used: 2.44 GiB
(15.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1238 lib: 305 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.7-1):
System install date:     2022-09-14
Last full system update: 2022-09-14
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

So as it seems all your problems are slack-related. You have, thereby, encountered one application that causes trouble, did not even troubleshoot or ask for help and now switch the OS entirely because you

Well yeah, but you know... it's Linux, and Arch-based at that, so maybe tinkering might be sometimes essential?

Obviously this is not the distro for you, but the whole thread seems a little... wasted. ^^

8 Likes

Proprietary software

circle2020

4 Likes

Literally none of those packages are created, updated, or anyhow preconfigured in Garuda.
We have nothing to deal with them, especially because most of them are proprietary.
There are thousands of users now happily using Garuda, I really don't get the sense of this that sounds more an attack rather than a feedback, considering also:

7 Likes

Slack has problem with kde

Use gnome desktop

1 Like

We surely hide them on purpose to annoy our users! :smiling_face_with_tear::crazy_face:

6 Likes

Good stuff.

OK then.

9 Likes