I Installed Windows to dual-boot and now garuda isn't in the boot menu

I installed windows to dual boot with garuda, I have garuda on a 120GB SSD and windows on a 150GB partition on a different HDD disk, note that garuda was there first then I installed windows.
after installing windows I can't find the garuda option in the boot menu, and my bios setup utility is "Hewlett-Packard" which doesn't have an option to manually add a boot entry, so what should I do?

So the rumors are true. This does still happen.

Normally the BIOS allows you to point to the designed boot entry and just changing this setting should get you back to Garuda. You say you can't "add" an entry, but isn't there already an entry you can select in there?

A few notes:

  • Garuda does not officially support dual boot so you will get limeted support.
  • If you need Windows, installing in a VM is easier to maintain.
  • Nezt time you wish to dualboot, install Windows first, then Linux.

If the above tutorial fails, send the output of

sudo efibootmgr
sudo fdisk -l
6 Likes

no it's only windows boot management

It's been a while, but I seem to recall being able to fix this from my BIOS. Your options could be different, but you should be able to edit the "boot priority." Instead of finding/adding a Garuda entry, Is it possible to move just your straight up SSD above the "Windows Boot Manager" entry? Alternatively, somewhere early in your startup you should be able to get to somewhere that allows you to select a temporary startup device, which should list all the existing boot entries as well as your drives. Should be the same as however you booted the USB to install Garuda, but if you're not sure look for the documentation on your specific computer for how to do this. Booting directly from the drive where GRUB is installed should let you at least boot Garuda if your GRUB is still intact, if not Windows (at least until you add a Windows entry to GRUB).

If your GRUB is borked, the chroot option mentioned above is probably the route to take.

3 Likes

worked like a charm, but every time windows opens it overrides the grub again, so the solution was to run this command from an Administrator cmd in windows bcdedit /set {bootmgr} path \EFI\Garuda\grubx64.efi which made grub the default, then inside the garuda Linux I ran these two commands:

sudo os-prober
sudo update-grub

and now I can access windows from the grub menu, or Linux just loads normally

5 Likes

I installed Garuda on different NVME-drive and installed boot-loader to that same drive.
So, basically I choose which OS to load, from BIOS boot "chooser".
So Windows doesn't mess with Garuda's bootloader.

In my mind, a good way to dodge most of the problems with "real" dualboot...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.