I am having trouble editing my search engines into brave

╭─[email protected] in ~
╰─λ garuda-inxi
System:
Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=da432848-ea5f-4121-b934-38474f7fbead rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: TOSHIBA product: TECRA Z40-C v: PT463U-08J02S
serial: <superuser required> Chassis: type: 10 v: Version 1.0
serial: <superuser required>
Mobo: TOSHIBA model: TECRA Z40-C v: Version A0
serial: <superuser required> UEFI-[Legacy]: TOSHIBA v: Version 6.80
date: 11/21/2018
Battery:
ID-1: BAT1 charge: 46.2 Wh (100.0%) condition: 46.2/59.2 Wh (78.0%)
volts: 14.5 min: 14.5 model: G71C000GB510 type: Li-ion serial: N/A
status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 685 high: 700 min/max: 400/3000 scaling:
driver: intel_pstate governor: powersave cores: 1: 640 2: 700 3: 700 4: 700
bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Toshiba driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x14b7 built: 2014 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 520 (SKL
GT2) direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Toshiba
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Intel Ethernet I219-LM vendor: Toshiba driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-8:5 chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 18.46 GiB (7.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNTY256HDHP-00000
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 100Q scheme: MBR
Partition:
ID-1: / raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 18.46 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 18.46 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 18.46 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 18.46 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 40.0 C pch: 37.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 192 Uptime: 27m wakeups: 8 Memory: 7.67 GiB
used: 1.93 GiB (25.2%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1282
libs: 320 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-18
Last full system update: 2022-11-23 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            [email protected]:toshiba::kbd_backlight.service

It will not let me put the url of the search engines I want here. The picture shows it's whited out where the url is supposed to go. If you can help me thank you!

Please read How to write a nicely formatted post in Discourse/Forum

Maybe that list is only meant to change your default search engine or the shortcuts of the various engines.
You could try adding a new site search below, where you can and have to enter the URL, and if necessary remove the relevant entry in the list above (if you have cloned one of them).

2 Likes

I know for a fact I'm in the right place because I have appropriate step by step instructions from swisscows search engine of how to install it in brave. do you think it's a computer glitch?

In fact it say to Add (the list below the one you showed, which is menant to Edit). The list I mentioned above.

1 Like

So I downloaded chromium because brave is built off of chromium and I have a lot of experience on chromium and it's doing the same exact thing as brave right now so I guess I will have to wait for the bugs to go. Thanks filo!

Are you sure it is a bug? I'm not a Brave or Chromium user, just trying to help...
The guide mentions the Add button on the bottom right of this screen, not the Edit (pencil icons). The Add button seems to work for me.

3 Likes

I use that too sometimes where it says add on the bottom of the screen but, it's a shortcut to be typed into brave and is something entirely different than the list of search engines above it on your picture there. My issue is that I am supposed to be able to edit my search engines with the digital pencil there. when I try it will not let me change the url at all.

1 Like

I have found where it says to make swisscows default and it will not let me click. Hmmm... :face_with_monocle:

I was able to somehow take an inactive shortcut and make it my default page. I was then able to edit and put my search engine in and save it. Thanks for your help filo.

1 Like