Hyprland Live USB session won't load

Hi, Just tried to give hyprland a spin on my workstation (ZEN4 7950x, RTX 3090) but can’t get the live usb to boot.

I have tried the normal bios compatibility settings:

  • safe mode disabled
  • integrated graphics disabled
  • resizable bar disabled

I have ventoy 1.0.96 with the following ISOs loaded (Checksums verified on ventoy boot):

  • garuda-hyprland-linux-zen-231008.iso
  • garuda-dr460nized-linux-zen-231008.iso
  • garuda-sway-linux-zen-230922.iso
  • garuda-i3-linux-zen-230922.iso

When I boot hyprland with either proprietary drivers or free drivers it gets stuck on:

Starting systemd-udevd version 254.5-1-arch

Dr460nized and i3 boot fine, and sway also works with the free drivers but get’s stuck at the same point with the proprietary drivers.

I also tried balena etcher to burn to a different USB but same result.
Any ideas?

Similar issues:

In the moment, Hyprland can be start with free driver if you use Nvidia GPU.
On the black screen, you can use TTY3 to login. Then hyprstart in terminal, enter, show you the hyprland login page.

Remove garuda-hyprland-settings, install hyprland-nvidia-git, use Hyprland Wiki page for the needed env.

Apart from that read

Thanks for the tips.

Unfortunately I never got to the black screen. The system locked up before Garuda booted. It is similar to the issues I linked. Could not reach TTY3 at all.

Anyway I disabled PCIe slot and installed garuda via the iGPU. Then I reversed it (disabled igpu and enabled nvidia gpu). This is were the fun began. Spent a few hours trying different combinations of everything (hyprland-nvidia, wlroots-nvidia, git vs non-git), following the hyprland wiki and suggestion in this forum on the hyprland discussion.

I finally got it working and then did a fresh install from iso again to get the following relatively simple steps for a working nvidia install:

  1. Install nvidia-dkms drivers with package garuda-nvidia-config

  2. Follow instructions in this section of the hyprland/Nvidia wiki page. This involves

    • Adding nvidia_drm.modeset=1 to the end of GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub, then run # grub-mkconfig -o /boot/grub/grub.cfg

    • Adding some env vars to hyprland.config. I only added 2
      • env = LIBVA_DRIVER_NAME,nvidia

I haven’t noticed any difference with running nvidia patched variants of hyprland/wlroots, other than the friction of the dependency conflicts it causes with the garuda-hyprland-settings

Overall verdict:
You guys have done a fantastic job! Hyprland is amazing! Nvidia sucks!
Scaling for highDPI displays causes a lot of blurry text for xwayland applications.
Some apps won’t launch due to nvidia-drm issues and forcing them to run without GPU acceleration seems to be the only option.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.