Hyprland install failed

Not asking for help, just posting for awareness.
On my AMD system, running the newly released ISO for installation, hyprland doesn’t launch (neither for install nor after install). Might want to check on that. It runs fine if I manually launch it.
Also, the keybinding for the install program doesn’t seem to work (but again it worked when I manually launched it from a terminal).

It worked for me.
Also M$+I worked for me.
What exactly do you mean by manually?
sudo -E calamares -D8 ?
You can’t boot to grub with live ISO?
I’m a little confused how you did it :slight_smile:

1 Like

ISO boots, I switched to an alt terminal, logged in, and launched hyprland after waiting for at least ten minutes to make sure nothing was going to happen after login at the greeter.
As to the install, I looked at the .config files, saw what the binding was suppossed to be, opened a terminal and launched calamares to perform the install.
I just downloaded the ISO about two hours ago…based on links on the Garuda homepage, so it should be the most current?
Maybe my download was corrupted…dunno…just thought I’d report my experiences. The foundation seemed correct and functional though (ie Linux/Wayland/HyprLand), just setup issues it would seem.

1 Like

As always, garuda-inxi :wink: ,

After login garuda/garuda, hyprstart or Hyprland?

But it work now for you?

Seems you will be our next beta tester :smiley: :slight_smile:
Of course, Hyprland is nice but not perfect like old DE’s like Xfce.

deepl said
You’ve reached your free usage limit. You can use the free version of DeepL again in 24 hours or try DeepL Pro to translate now and get premium features.

So I will never use deepl again.
Of course, I stop my promotion for deepl too.


Yes, I didn’t include the hardware info (other than to say I’m NOT Nvidia) as I don’t think it’s pertinent. However, I can reboot to that installation and report if you would really like.
I didn’t really take time to find out why…I just performed the installation, and hoped the installed system would work properly (which it didn’t, in that it behaved exactly as the install ISO had).
Fixing the installed system should not be an issue for me. If you like, I can detail what I end up changing to make the GUI auto-launch correctly (which probably will also identify the failing aspect) tomorrow. I really am surprised that it works for you, if you installed off the SAME ISO.

1 Like

That would be very helpful, thank you. :slight_smile:
It was difficult for me to install it on Nvidia (desktop) and in the end I don’t know what was the decisive factor in it now running perfectly.
It’s probably due to different hardware even with the same product name.
There are no problems on notebooks with Intel or AMD without Nvidia GPU.

Then there are some with nvidia gpu (Ankur) that also run perfectly. :rofl:
In my country we say about
Nichts genaues weiß man nicht :slight_smile:

That’s why the whole thing runs under "Advanced Users Only”.
By the way, if flameshot or spectacle worked on my computers/monitor resolutions, I would switch from i3 to Hyprland.

It has a lot of potential. :slight_smile:

Yes, I first looked at HyprLand late last year or early this and was quite impressed. That’s why I wanted to see how you guys had themed it (my weakest point-imagination, and I tentatively like how the spin was setup). I might give it a shot at being the ‘daily driver’.
Once I get some caffeine in my bloodstream (couple hours), I’ll boot over and see what it looks like.

1 Like

Ok, I updated last night before shutting down…and umm this morning, everything works fine (both the GUI startup and the calamares key bind).
Maybe I was delusional? I dunno…but wow…ok, forget it all…it works (now). I’m almost tempted to try the ISO again…but maybe not that tempted?

Well, now on to adding apps and configuring things a slight bit. Overall, I like it :slight_smile: Thank you!


Mostly because of old hardware, almost 7 years old
But still beated the benchmark test of one of my friend’s brand new laptop :grin:

1 Like

3 posts were split to a new topic: Hyprland and Nvida GPU

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.