Hyprland and Nvida GPU

That worked here, using the “install” icon did not.
Inxi from the live ISO during install.

In Garuda Welcome app?
Right, that’s why I wrote
Use modkey + I to install Garuda Hyprland. :slight_smile:

Weird thing, I got to install it (so the live USB ran fine), but now that it’s installed, when I try to login it blanks the screen and sends me back to login


Inxi after install

No welcome app showed up booting from the USB

Journalctl for the live USB

Which Icon? :slight_smile:
Please, post garuda-inxi here not in termbin.

I move it, the other thread was solved.

Hyprland and Nvidia have problems, sometimes.
Please read

From app drawer.

I’m writing from my tablet, since my notebook is otherwise unavailable for GUI usage =|

I see…

Will do, thanks.

In the mean time… Does that mean that even if I’m booting using the proprietary drivers option, the live USB isn’t using it? Because on the live USB I can login, and do stuff. I just can’t login here because I don’t have my password manager there.

But I did notice that the live USB won’t show my other 2 monitors, it’ll only use the laptop’s display.

One other doubt… Is there any way to access what was in my secondary HDD back when I had the dragonized edition installed? I tried mounting, but mount refuses to…

All right, new install round ended up, time to reboot and read to see if I get it working.

OH! right, mod+i works too bring up the installer!

Maybe we must edit the download page, and write over Hyprland a second time

Advanced Users Only :warning:

Change owner

I can’t help for special hardware configs :slight_smile: , xrandr or arandr.

Hyprland and I are in Beta mode :slight_smile:
Don’t spend too much time on it if it doesn’t work for you and your hardware.

Just use Xfce :wink:

The suggestion I am gonna make might not be necessary anymore but I heard that for users with nvidia GPU they have a hyprland-nvidia package and the hyprland ISO uses hyprland-git by default. So how about chrooting into the system and changing the hyprland-git package with hyprland-nvidia package? You can read the archwiki about it for more info.

chaotic-aur/hyprland-nvidia 0.31.0-2
A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)

Btw, hyprland-git package is a dependency of garuda-hyprland-settings package so a pacman -Rd might be required to remove it and install hyprland-nvidia version.

1 Like

Actually never used that one. Better experience than the dr460nized?

Tried that, sorry I forgot to mention, it didn’t work. I get a (sorry if it’s not the exact translation, my system is in ptbr, not English) invalid filesystem kind of error.

Yeah I noticed that, but couldn’t uninstall even with -Rd.

Damn, I really thought I had enough Linux-fu to use an advanced distro, but it looks like I’m just still a newbie :rofl:

1 Like

have you tried with -Rdd ?

-d, --nodeps
Skips dependency version checks. Package names are still checked. Normally, pacman will always
check a package’s dependency fields to ensure that all dependencies are installed and there are
no package conflicts in the system. Specify this option twice to skip all dependency checks.

Or what exactly happened? what prevented the uninstallation?

1 Like

Like me.

I also got it installed on a computer with Nvidia, but I’m not a good teacher and I can’t say which settings were effective in the end effect.

1 Like

I like this attitude. My main knowledge and field of experience is actually with network security, too many gatekeepers thinking they’re rockstars talking shit.

No, I hadn’t. Did not, and pacman seems to have died on step 6, syncing all file systems… :thinking: Complete crash, everything stopped, had to do a hard reset. But seems like it uninstalled… Installing the Hyprland-Nvidia now… Done. Rebooting… Still getting thrown back to login screen when I log in.

I was so looking forward to learning how to deal with this new interface, I really liked the experience on the live USB.

Well, it was worth a shot. Burning dr460nized on the USB to move on.

If you really want to you can still boot to sway edition of garuda and then switch to hyprland using the hyprland guide we have on forum. It seems to work for a few people. Just keep in mind a few things have changed since the guide was made, for more info see this,

The guide,

What’s changed,

Is there a place with the comparison of the different editions? What this sway edition has that’s different? I understand the dragonized gaming has the launchers I like easily at hand…

I’ll take a look at it!

The short answer is no, you can look for change-logs of different ISO’s meticulously compiled and maintained by nico aka dr460f1r3 but I believe that’s not what you are looking for.

I will try to compile it down as much as I can for you. Someone please point out any erroneous statements I might make here.

All garuda editions have the same helpful garuda GUI apps that make workflow easy (eg, garuda assistant, gamer, boot options, etc…). The only difference with the gaming edition is that it has a lot of stuff like wine, launchers etc preinstalled. This is not necessarily a good thing though as evidenced here some packages were actually blocking people from booting into the live ISO environment. Critical bug: Gaming edition installer has boot-blocking package conflict

The difference between the different garuda editions boils down to the window managers that they are using.

i3, Sway, and hyprland are tiling window managers and each meant to successively replace the other.

From sway’s website

Sway is a tiling Wayland compositor and a drop-in replacement for the i3 window manager for X11. It works with your existing i3 configuration and supports most of i3’s features, plus a few extras.

From what I have read online on some reddit thread a while ago. It seems hyprland was developed as a sort of spiritual successor to sway since sway as a project achieved what it set out to do, its as good as it will ever get. Thus it’s hyprland’s job to expand more on that. Hyprland has got almost everything sway has.

Ah found the reddit thread I was talking about Reddit - Dive into anything

Similarly KDE, gnome, XFCE and LXqT are different from each other. This is what I understand about these wm’s from surfing around the community so you can look these up individually to know more as well,

KDE = has a lot of apps, bloat~y for some but overall has almost everything a regular user might want out of his desktop plus highly customizable. Other than this the apps developed by team KDE are not locked down by platform and can be accessible anywhere. So if you are a part of KDE ecosystem that means if you change your system to GNOME or M$ someday you can still use your fav apps there.

GNOME = I am not sure about this one but basically less bloat~y but very locked down. Customizing gnome is a mess and very hard thing to do. On top of that devs don’t care about plugin support for the customizations that you have. So every new gnome release means almost all your plugins and themes break.

Xfce = very light weight, mostly used by systems with very limited resources or old hardware.

I am in dark about Lxqt so please look it up.


ok, so basically, there are WM “flavors” and the gaming distro with stuff preloaded. I didn’t knew the other flavors also had the Gamer assistant. I remember finding Heroic awesome, but ended up not playing anything in it so far in the 6+ months I’ve been using Garuda.

Gnome and KDE I know from long time… I don’t think I ever used a tiling WM before… I really liked the new experience (although I felt lost like hell before figuring out how to resize) on the Hyprland live USB. Specially the status bar!

I’ll take a look at Sway then =)

WAIT. Do I have to know any mystic crafting recipe for using it with nvidia, before getting started? o.o

Simple, .config/waybar/config


sorry, I meant for Sway!

gods, I see now that this came out confusing as hell. I loved the Hyprland USB live status bar, but I want to know if there’s any special needs for using the Sway edition of Garuda =p

hm. one thing just hit me - do I need to format dragonized gaming to put sway, or could I just put it over? :thinking:

Sway USB live won’t reach GUI here. I saw a red line about nvidia proprietary something something but it was too fast to read. Also couldn’t change terminals, as the computer wasn’t responding to anything. Had to hard reset it…

I was searching about Sway and nVidia and found out that ArcoLinux managed to run Sway on it