HUGE scaling issue on Nvidia and KDE environment

Hello.
I am using NVIDIA gpu (1650 SUPER), and i'm having the same problem in live cd as in installed environment. The problem is in the scaling option that in the settings doesn't make any changes, and the scale is too large to be usable (i'm getting this problem only on garuda, using manjaro was ok)

here is the screenshot: Desktop-001 — ImgBB

garuda-inxi:
System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64
compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0b94ce5d-d009-4332-bc02-3fada2edb47c rw
[email protected] quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=85344af1-a402-4e3a-9a67-f0d7d08c8d75
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3
info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: PRIME B560M-K v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends
v: 1203 date: 10/27/2021
CPU:
Info: model: Intel Core i5-10400F bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: 0xA5 (165)
stepping: 3 microcode: 0xEC
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12
smt: enabled cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB
desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 4206 high: 4295 min/max: 800/4300
scaling: driver: intel_pstate governor: performance
cores: 1: 4053 2: 4288 3: 4201 4: 4148 5: 4206 6: 4200
7: 4295 8: 4290 9: 4203 10: 4193 11: 4203 12: 4202
bogomips: 69597
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1
sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers
and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER]
vendor: ASUSTeK driver: nvidia v: 510.68.02
alternate: nouveau,nvidia_drm pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:2187 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland
v: 22.1.1 compositor: kwin_x11 driver: X: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 304
s-size: 321x90mm (12.64x3.54") s-diag: 333mm (13.13")
Monitor-1: DP-1 pos: primary,left res: 1920x1080
hz: 60 dpi: 305 size: 160x90mm (6.3x3.54")
diag: 184mm (7.23") modes: N/A
Monitor-2: DVI-D-0 pos: primary,right res: 1920x1080
dpi: 102 size: 480x270mm (18.9x10.63")
diag: 551mm (21.68") modes: N/A
OpenGL:
renderer: NVIDIA GeForce GTX 1650 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
Audio:
Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:f0c8
class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio
vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:1aeb class-ID: 0403
Device-3: BEHRINGER GmbH UMC202HD 192k type: USB
driver: snd-usb-audio bus-ID: 1-4:2 chip-ID: 1397:0507
class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen
running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK
driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
chip-ID: 8086:15fa class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: TP-Link TL-WN722N v2/v3 [Realtek RTL8188EUS]
type: USB driver: r8188eu bus-ID: 1-14:5
chip-ID: 2357:010c class-ID: 0000 serial: <filter>
IF: wlp0s20f0u14 state: up mac: <filter>
Drives:
Local Storage: total: 2.95 TiB used: 22.52 GiB (0.7%)
SMART Message: Unable to run smartctl. Root privileges
required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial
model: CT480BX500SSD1 size: 447.13 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 041 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate
model: ST2000DM008-2FR102 size: 1.82 TiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001
scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial
model: CT120BX300SSD1 size: 111.79 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 010 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD6400AAKS-22A7B2 size: 596.17 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 3B01 scheme: MBR
Partition:
ID-1: / raw-size: 91.71 GiB size: 91.71 GiB (100.00%)
used: 22.52 GiB (24.6%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
ID-2: /boot/efi raw-size: 300 MiB
size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 91.71 GiB
size: 91.71 GiB (100.00%) used: 22.52 GiB (24.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-4: /var/log raw-size: 91.71 GiB
size: 91.71 GiB (100.00%) used: 22.52 GiB (24.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-5: /var/tmp raw-size: 91.71 GiB
size: 91.71 GiB (100.00%) used: 22.52 GiB (24.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
Kernel: swappiness: 133 (default 60)
cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8 GiB
used: 0 KiB (0.0%) priority: -2 dev: /dev/sda6
maj-min: 8:6
ID-2: swap-2 type: zram size: 15.48 GiB
used: 2.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia
temp: 37 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 24%
Info:
Processes: 301 Uptime: 6m wakeups: 0 Memory: 15.48 GiB
used: 3.35 GiB (21.6%) Init: systemd v: 250
tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
Packages: pacman: 1823 lib: 520 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-04
Last full system update: 2022-05-04
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

I was using a GTX 1650 (not SUPER) and never had such issue, in fact scaling was a lot better than on my current AMD and did not require any adaptation (my AMD does)

However I seem to see in your inxi that your DPI is set to 304!

If that is true, it's probably too high. I normally find myself between 96 and 125, depending on the card, for a true 4k monitor. I'm not a pro on that thing but I find it suspicious and it would be the 1st thing I'd try to change.

How does your SDDM login screen look like? Is it scaling ok or too big?

4 Likes

Holy!
Both of my monitors are FULL HD
And in the system settings - both are set to FULL HD.
I don't even know why garuda is getting this resolution and this dpi.
Can you provide me the commands to change it, please?

Upd!
Sddm has the same sick scale resolution

You have 3840x1080 (thta's QHD, like a 49in monitor), FULL HD is 1920x1080 and 4K is 3840x2160.

Since SDDM is too big, you have to edit the file I think it's /etc/sddm.conf

You need to add the DPI in the X11 Server section. I have the EXACT details on my machine but I won't have access for another 5 to 8h. :frowning:
I'll see if I can access a backup file faster. Or maybe someone will jump in before, it's a very easy change though and gives excellent control over scaling.

4 Likes

That's a problem
Both of my monitors are full hd (in the fact), i dunno where the hell garuda has taken 4k
(Both of them are set to FULL HD in the garuda monitor settings)

Ok you have 2 monitors? I'm only seeing one in your inxi, but I'm not an inxi expert either.

There is no 4K resolution in your inxi.

Maybe it's a problem related to the video drivers installed then. When you load the Live ISO, you choose OPEN SOURCE drivers or the other option?

1 Like

Open source drivers doesn't even boot me the system, xd.
Propietary.
So, what means "screen-1"?...

1 Like

Oh wait. Yes, SCREEN-1 and MONITOR-1 are 2 different things. SCREEN-1 is the way Xorg talks about its screen, a display screen, that doesn't mean the physical monitor.

I see your 2 resolutions are different. You do have a 1920x1080 MONITOR, but the screen is stretched up to 3840.

I never worked with multiple monitors so I can't help here.

But take a look here How to set the DPI via sddm.conf? / Applications & Desktop Environments / Arch Linux Forums
1s post. You have to add the line ServerArguments=-nolisten tcp -dpi 94 in the X11 section of sddm.conf.

You can set the number to something different.
See if you can scale properly by changing this.
I believe you only need to LOG OFF and not reboot to test your changes.

2 Likes

Okay, now i see the problem more clearly.
The problem still the same when I'm using the single one monitor so, multiple monitors - not the problem.

I'll try to make this when I'm going to be at home (50 minutes)

1 Like

Okay
I turned off my second monitor
Now the SCREEN-1 scaled to FULL HD and 305 dpi
MONITOR-1 - the same
So, i have to change the dpi, right?

Give it a try, yes.
It's super fast/easy to change it and revert changes if need be, so it's worth seeing how it will behave then.

1 Like

Can you say me the command, pls? (I never did it before)

Try sudo micro /etc/sddm.conf

That should open up the file.

Actually, let's do it simplier. Plz send the output of bat /etc/sddm.conf

1 Like
bat /etc/sddm.conf
───────┬─────────────────────────────────────────────────────
│ File: /etc/sddm.conf
│ Size: 28 B
───────┼─────────────────────────────────────────────────────
1   │ [Autologin]
2   │ Session=plasma
3   │
───────┴────────────────

That's all?
Wow there's nothing in there, mine is a lot longer by default, but that happens.

Hum I wonder if there is another sddm.conf somewhere else.

So sudo micro /etc/sddm.conf and add on Line 4 the following:

[X11]
ServerArguments=-nolisten tcp -dpi 96

CTRL-S to save the file, CTRL-Q to quit.
Log Off.
Take a look at how SDDM renders.

6 Likes

Wow
SDDM looks alright. That's a progress!:joy:

1 Like

So, yeah
the problem was on the DPI scale.
But, know i'm having another annoying problem that is breaking my system at all :smiley:

i don't have interface on my second monitor and that's a very sick situation...
i don't even can close firefox without using my first monitor :joy:

Yes that is certainly related to multiple monitors setup, again in sddm.conf or in Xorg.conf (or personal config) there certainly is a way to fix this.

Here though is where I cannot help :frowning:
If I were you, I'd google a lot for multiple monitor issues like yours and I'm sure you'll find something. I don't think it needs to be Arch related, I believe it works the same in Debian.

Maybe you need to blacklist nouveau driver, but I don't know, it's just a guess.

There are people here who know more on these setups than me.

1 Like

okay, and i have one last question
is there a way to make functionally my audio interface? (umc202hd)
i don't see any linux driver on official site, and i'm not getting any sound on headphones (also, garuda-inxi is seeing my audio interface)