HP LaserJet Pro MFP M426fdw throwing errors

Hi there,

I have a LaserJet Pro MFP M426fdw. This printer used to work perfectly when I was a Manjaro Gnome user, but for reasons I don't understand, I can't seem to get it working in Garuda Gnome. Whenever I print a document, the printer outputs a page reading:

URP Error
Subsystem: Parser
Error: Internal Overflow or Insufficient Memory
File name: urp_urf_processor.c
Line number: 743

In Gnome's Setting panel, I can see that the printer is showing as: "HP LaserJet MFP M426fdw, driverless" (is the fact that it doesn't show as "Pro" relevant?). I've tried removing and reinstalling the printer, but that doesn't seem to have an effect.

What else should I be trying?

How is the printer connected and thru which protocol?

The only result I found with that error message is Error: Internal Overflow or Insufficient Memory - HP Support Community - 5815740 (though that is another model and on MacOS), there's no reply from the original poster, anyway the advice there is to use JetDirect.

Although not about an HP, there may be something useful here: Setting up a network printer

P.S. inxi would not hurt.


The printer is connected over wifi.

Here's my inxi:

CPU: 12-core AMD Ryzen 9 5900X (-MT MCP-) speed/min/max: 3289/2200/4950 MHz
Kernel: 6.2.13-zen-1-zen x86_64 Up: 1d 2h 24m Mem: 18274.1/32005.6 MiB (57.1%)
Storage: 465.76 GiB (51.6% used) Procs: 516 Shell: fish inxi: 3.3.26


Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:


Refusing to post the output of the required "garuda-inxi" on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki's, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum's search engine and on the web. For in depth information on how to search for answers to Linux issues effectively, read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

1 Like

Your model should be fully supported by hplip.
Have you tried reinstalling it with the relevant tool?


╭─[email protected] in ~ took 527ms
╰─λ garuda-inxi
Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=542d3ca9-5005-47ad-85d9-21e20ee155e6 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: GNOME v: 43.5 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.0
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: System76 model: Thelio Mira v: thelio-mira-r2
serial: UEFI: American Megatrends v: 4403
date: 04/27/2022
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 2361 high: 2878 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2532 2: 2434
3: 2200 4: 2872 5: 2200 6: 2597 7: 2200 8: 2194 9: 2197 10: 2200 11: 2196
12: 2196 13: 2200 14: 2200 15: 2872 16: 2603 17: 2878 18: 2690 19: 2200
20: 2194 21: 2216 22: 2200 23: 2194 24: 2200 bogomips: 177260
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor: PNY
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 0a:00.0
chip-ID: 10de:2216 class-ID: 0300
Device-2: HD WEBCAM type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-1:7
chip-ID: 1d6c:0103 class-ID: 0102 serial:
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: gnome-shell driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :1 screens: 1
Screen-1: 0 s-res: 6000x1440 s-dpi: 96 s-size: 1588x381mm (62.52x15.00")
s-diag: 1633mm (64.29")
Monitor-1: DP-0 pos: bottom-l res: 2560x1080 hz: 60 dpi: 79
size: 820x350mm (32.28x13.78") diag: 892mm (35.1") modes: N/A
Monitor-2: HDMI-0 pos: primary,top-right res: 3440x1440 hz: 50 dpi: 109
size: 800x335mm (31.5x13.19") diag: 867mm (34.15") modes: N/A
API: OpenGL Message: Unable to show GL data. Required tool glxinfo
Device-1: NVIDIA GA102 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel bus-ID: 5-1:7 chip-ID: 1d6c:0103 pcie:
gen: 1 class-ID: 0102 speed: 2.5 GT/s serial: lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 0a:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: HD WEBCAM type: USB driver: snd-usb-audio,uvcvideo
Device-4: Razer USA Seiren Mini type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-4:4 chip-ID: 1532:0531
class-ID: 0300 serial:
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp4s0 state: up mac:
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: down mac:
Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-6:3 chip-ID: 0e8d:0608 class-ID: e001 serial:
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Local Storage: total: 465.76 GiB used: 240.54 GiB (51.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: rev: 3B2QGXA7 temp: 37.9 C scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 240.54 GiB (51.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 240.54 GiB (51.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 240.54 GiB (51.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 240.54 GiB (51.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 46.8 C mobo: N/A gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 517 Uptime: 1d 2h 47m wakeups: 1 Memory: 31.26 GiB
used: 16.69 GiB (53.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1716
libs: 525 tools: pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: gnome-terminal inxi: 3.3.26
Garuda (2.6.16-1):
System install date: 2022-07-03
Last full system update: 2023-04-30
Is partially upgraded: No
Relevant software: snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot: No/Undetected
Failed units:

1 Like

Reinstalling the printer with: hp-setup -u

This worked and solved the issue. Thank you so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.