How to properly change the accent color on KDE version?

I'd like to change Garuda's default pink/purple accent color.

I think since KDE 5.23, there was an option added in settings to easily change the accent color. I've tried that option, but only the selection accent color changes, pretty much all applications following the system/qt/gtk+ styling still have the pink/purple accent color.

I'd like to know which part of the system has been hard coded with this color and change it somehow (without messing with the default, still would like to fall back to default if I don't like my mess).


PS: No offence to devs, I do like the saturated pink color scheme, just would like to try something new :stuck_out_tongue:

╰─λ inxi -Faz
System:
Kernel: 5.15.7-arch1-g14-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg="+p"
acpi.dyndbg="file drivers/acpi/x86/s2idle.c +p"
BOOT_IMAGE=/@/boot/vmlinuz-linux-g14
root=UUID=edc8611c-d94e-4567-85f8-02b07c91fda3 rw [email protected]
quiet
cryptdevice=UUID=98382a7e-5fd2-4dca-b6e6-6aca242b8ece:luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
root=/dev/mapper/luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: GA401II.219 date: 12/30/2020
Battery:
ID-1: BAT0 charge: 58.5 Wh (79.1%) condition: 74.0/76.0 Wh (97.4%)
volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging
Device-1: hid-dc:2c:26:05:66:0e-battery model: Keychron K2 serial: N/A
charge: N/A status: Discharging
Device-2: hidpp_battery_0
model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 2602 high: 3427 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2481 2: 1497
3: 3427 4: 2756 5: 2616 6: 3063 7: 2554 8: 3133 9: 1788 10: 2739 11: 2644
12: 2537 bogomips: 71894
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
bus-ID: 04:00.0 chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 158
size: 309x174mm (12.2x6.9") diag: 355mm (14")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 04:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.7-arch1-g14-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 5-4:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 113.49 GiB (11.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
temp: 26.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 113.49 GiB (11.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 113.49 GiB (11.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 113.49 GiB (11.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 113.49 GiB (11.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-98382a7e-5fd2-4dca-b6e6-6aca242b8ece
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.11 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
Fan Speeds (RPM): cpu: 2600
Info:
Processes: 394 Uptime: 24m wakeups: 6 Memory: 15.12 GiB
used: 3.43 GiB (22.7%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1460 lib: 357 Shell: fish
v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

The hands on method is to copy the theme, then use a color picker to identify the colors and elements you want to change. Each color in the theme has a specific color code. Once you have identified the colors you want to replace, then decide on the colors you want to replace them with (identified by its unique color code). Then use Kate or another text editor to do a search and replace operation on the theme file. Substitute the color codes you dislike with the new colors you want to use. A bit of work, but its not that hard to do.

3 Likes
3 Likes

wow,seems interesting :slight_smile:

Wow! How'd I miss that tutorial, SGS? I have to try it. :smiley:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.