How to install Grub bootloader to newly created EFI partition for existing Garuda linux

I had a dual-boot setup with Windows 11 and Garuda Linux Dr460nized version previously. Windows bootloader and Garuda's grub were installed on the same EFI partition. So when I was doing a clean reinstall by cleaning everything except for the Garuda Linux root partition, I also deleted the EFI partition where Garuda's GRUB was installed. I thought I could reinstall GRUB in case anything goes wrong through the Garuda live boot repair tool which usually worked in cases of boot override by Windows (but this time it didn't work at all).

After deleting the previous EFI partition, I created a new EFI partition of filesystem FAT32 with flags boot and esp. My Garuda's root folder is still there and hopefully, the data is all safe. But how could I reinstall Grub for my Linux in that EFI partition? I attempted to reinstall GRUB using Garuda's live boot repair tool but it didn't work saying couldn't mount /boot/efi. Does that boot repair tool only work when there is grub installed previously?

Anyway, guys, I need your help here. I want to install Grub to the EFI partition so that I can access my Linux and its data. How can I do that? Is there a way by using Garuda's live iso? I tried to search for this but there weren't proper instructions for my specific scenario and there were some commands like chroot, mount, etc. which I couldn't really follow properly due to different contexts. So please help me get back my Garuda Linux. Thank you!

Hi there, welcome to the forum.
Try this:

It should be very easy to follow. You just need to know the names of the Garuda partition and the ESP partition.


Thanks a lot! That forum helped me solve the problem and I am now back on my Garuda Linux. During my search, I found an even more detailed guide to using chroot and reinstalling the bootloader. I leave it here in case anybody needs it in the future.

1 Like

I mark it solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.