How to install Canon i-Sensys MF3010

Hi, I' m a new Garuda Linux user , simply i want to install Canon i-sensys MF3010 printer i didn't find this model in the list and i have all the packages installed

Have you searched the forum for this model? This thread:

indicates an AUR package may be needed.

Which list?

Which packages?

7 Likes

List of Canon printer models in 'printer setting' there is all the models but this one

All the packages of Canon printer that exist in CUPS including the one you mentioned

Have you tried installing from AUR the following?
https://aur.archlinux.org/packages/cnrdrvcups-lb
or
https://aur.archlinux.org/packages/cndrvcups-lb
The latter is the one mentined in the linked thread, where it generated a dependency problem.
The former seems to be slightly older but without that dependency, and the maintainer says that the latter is deprecated...

2 Likes

It works i found the model of the printer (MF3010) but it still doesn't print , and i cannot connect to localhost for CUPS Web it says 'failed to connect to server', i don't know if this is the problem for not printing ?

Maybe you could try to give a look at the relevant wiki page:
https://wiki.archlinux.org/title/CUPS#Web_interface
and relevant troubleshooting page:
https://wiki.archlinux.org/title/CUPS/Troubleshooting

3 Likes

I tried this :

CUPS stops working

The chances are that a new configuration file is needed for the new version to work properly. Messages such as "404 - page not found" may result from trying to manage CUPS via localhost:631, for example.

To use the new configuration, copy /etc/cups/cupsd.conf.default to /etc/cups/cupsd.conf (backup the old configuration if needed) and restart CUPS to employ the new settings. -------> it works :+1:t2:

and this:

Unable to add printer or message "print in progress" but nothing happens

In GNOME Printer settings for example, you could find troubles adding your printer, even though you have installed the drivers. You can try installing system-config-printer and executing it via terminal, and adding the printer from there (for instance using LPD/LPR queue 'PASSTHRU'). ------> It didn't work tne printer still not printing .

1 Like

Is it a WiFi printer? Sometimes it is easiest to add a printer by IP address. You can check what IP address is assigned to your printer in the DHCP section of your router's admin console, or sometimes the printer itself will tell you. Then add printer through the network option and punch in the IP address.

1 Like

No it's not a wifi printer i tried the last solution because I have the same problem 'print in progress ' but nothing happened .
Is the problem with the USB port? BTW the mouse is working and the printer is detected.

Now, the Print job stuck at "Rendering completed" status , what should i do?

Did you get it working, and then it stopped? Or have we not gotten it working yet?

This might be a long shot, but since it is a USB printer you need to make sure the cups daemon has read & write access to the device. I'm not sure if it is possible to do this outside of some terminal commands, but it's not that bad if you want to give it a shot.

First get the bus and device number of your printer from lsusb:

lsusb
Bus <BUSID> Device <DEVID>: ID <VENDOR>:<PRINTERID> Canon i-sensys MF3010

Then check the ownership in devfs:

sudo ls -l /dev/bus/usb/*BUSID*/*DEVID*

Either the group "lp" or the user "cups" needs read and write access to the USB printer for it to work properly. The cups daemon sort of counts as both, so either one will do. If the permission above looks wrong, change the group and permission like this:

sudo chgrp lp /dev/bus/usb/*BUSID*/*DEVID*
sudo chmod 664 /dev/bus/usb/*BUSID*/*DEVID*

Then check the printer again.

If that is your issue, you can make a persistent change that gets triggered every time you plug in your printer with a udev rule, see here.

1 Like

This is what i got :

lsusb
Bus 001 Device 087: ID 04a9:2759 Canon, Inc. MF3010
sudo ls -l /dev/bus/usb/001/087
[sudo] password for chaimaa:
crw-rw-r--+ 1 root lp 189, 86 مارس   20 23:06 /dev/bus/usb/001/087

is it correct ?

Yes actually, that looks fine.

What DE are you using?

Where did you end up getting the driver?

By this, do you mean that you checked the box to install the printer packages with the Garuda setup assistant after installation?

1 Like

YES , and i installed UFR II packages from CUPS , all of them .

Is this where you got the driver?

How exactly does the model described on the driver match your printer model?

What desktop environment are you using? KDE?

1 Like

It is described as 'MF3010' and mine is named 'i-sensys MF3010'

Yes , KDE Plasma Version .

It does look like the manufacturer offers a Linux driver for this device on their website. It may be exactly the same as what you have already, I have no idea.

https://driverscollection.com/?H=i-SENSYS%20MF3010&By=Canon&SS=Linux%20x86_64

Are you adding the printer through the KDE settings manager? If so, try the system version (you never know). Alt+F2 and search "printer" or similar to bring it up.

4 Likes

Thank you it is working :clap:t2:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.