How to get Wayland working on kde edition with nvidia?

Hello Garuda users.

garuda-inxi

Installed Packages

wayland , wayland-protocols , wayland-utils,eglwayland,kwayland,kwayland-server,xorg-xwayland,qt5-wayland, qt6-wayland,lib32-wayland

And Rebooted still SDDM dont show any option for login in Wayland session but it shows for weston

Is Wayland force disabled on kde-nvidia garuda ?
If not how to enable it ?

As far as the KDE+Wayland is concerned, I think you're missing plasma-wayland-session.
See e.g. (but there are many topics about it in the forum)

As regards the nVidia aspect, I can't help, but I doubt there is a one-fit-all solution (if a real solution exists at all).

3 Likes

They dont show while creating new topic
Also is reply button broken for forum if user uses firefox ?
i rtap reply button but msgs go without tagging

You can and have to use the filters. E.g.:
https://forum.garudalinux.org/search?q=kde%20wayland%20status:solved%20order:latest
Then you can remove "solved", add nVidia, but that is a starting point.

No, I'm using Firefox exactly in this moment (edit: with uBlock origin active for this site)

1 Like

Please create alphabetical list of sections that have solved post like

  1. Alsa
    2)Nvidia
    3)Wayland
    like it is in arch wiki but instead of articles they point out to solved posts
    that would simplify the navigation so much
    thanks

I think uBlock origin is blocking too much on garuda (28 requests = 1%) is blocked

This is out of the scope of this issue and, in my opinion, users should simply learn to use the forum search features. We cannot accomadate any possible request with solved posts! :slight_smile:

3 Likes

image

Seems you block JavaScript.

image

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.