How to connect to IRC? Is it still broken?

okay so we had an issue with IRC a while back reported here, IRC from Garuda start page is broken? and it kinda died down after a while since the maintainer never replied. So is the issue still unresolved? I try launching the IRC chat from start page get here,

click on connect and it take me here,

I have tried to send several,

/connect which just returns a different error each time. The first time it was “disconnected from the network, and will not reconnect. Use /connect to reconnect again” or smth about “password refused” I am like what password…? after a few repeats I closed the webpage and retried and this time a different error came as shown above.

I tried,

/msg NickSrv REGISTER <pass> <email>

and that doesn’t work either it says you need to be connected to the channel to do this. Same with


how exactly am I supposed to access the IRC? how do I connect to this? clicking on the help links on the webpage take me to theLounge help page which is not at all helpful… Really how to use this I am stuck…

  Kernel: 6.6.7-1-clear arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-clear
    root=UUID=e0a08d20-208f-444a-a6f0-281ffd8a1e1b rw rootflags=subvol=@
    quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests
    initcall_debug intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check
    noreplace-smp page_alloc.shuffle=1 rcupdate.rcu_expedited=1
    rootfstype=btrfs tsc=reliable rw
    resume=UUID=1824b554-dd46-4e14-a85d-6aafd14791a7 loglevel=3
    acpi_backlight=video nvidia-drm.modeset=1 ibt=off
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Convertible System: LENOVO product: 81X1 v: IdeaPad Flex 5 14IIL05
    serial: <superuser required> Chassis: type: 31 v: IdeaPad Flex 5 14IIL05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN
    serial: <superuser required> UEFI: LENOVO v: ECCN41WW date: 06/27/2022
  ID-1: BAT0 charge: 38.7 Wh (95.6%) condition: 40.5/52.6 Wh (76.8%)
    power: 14.4 W volts: 13.0 min: 11.5 model: Sunwoda L19D3PD6 type: Li-poly
    serial: <filter> status: charging cycles: 2113
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xC2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 510 high: 1285 min/max: 400/3900 scaling:
    driver: intel_pstate governor: performance cores: 1: 400 2: 400 3: 400
    4: 1285 5: 400 6: 400 7: 400 8: 400 bogomips: 23961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a52
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX330] vendor: Lenovo driver: nvidia
    v: 545.29.06 alternate: nvidiafb,nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d16
    class-ID: 0302
  Device-3: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2 chip-ID: 5986:212a
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: Hyprland driver: X: loaded: modesetting,nvidia unloaded: nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1406 built: 2019 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 scale: 1.199219 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  API: Vulkan v: 1.3.274 layers: 12 device: 0 type: integrated-gpu
    name: Intel Iris Plus Graphics (ICL GT2) driver: mesa intel
    v: 23.3.1-arch1.1 device-ID: 8086:8a52 surfaces: xcb,xlib,wayland
    device: 1 type: discrete-gpu name: NVIDIA GeForce MX330 driver: nvidia
    v: 545.29.06 device-ID: 10de:1d16 surfaces: xcb,xlib,wayland device: 2
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.1-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  API: ALSA v: k6.6.7-1-clear status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:5 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 6 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0000
  Local Storage: total: 476.94 GiB used: 50.33 GiB (10.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZALQ512HALU-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 3L1QFXV7 temp: 38.9 C scheme: GPT
  ID-1: / raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
    used: 50.33 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
    used: 50.33 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
    used: 50.33 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
    used: 50.33 GiB (10.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.29 GiB used: 512 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc max-streams: 8 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.82 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 57.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 304 Uptime: 8h 24m wakeups: 2 Memory: total: 16 GiB note: est.
  available: 15.29 GiB used: 6.88 GiB (45.0%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1352 libs: 408 tools: paru Shell: fish v: 3.6.4
  running-in: foot inxi: 3.3.31
Garuda (2.6.21-1):
  System install date:     2023-11-11
  Last full system update: 2023-12-23
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            systemd-vconsole-setup.service 

Hmm… yeah this IRC thing is a bit of a rabbit-hole, after some investigation.
I had a nick registered for quite a while but took a fat break from IRC, so now my nick is unregistered. I can connect to irc-nerds fine with weechat, but since my nick is no longer registered, I can’t chat in the Garuda channel. The kicker is that the irc-nerds email service also doesn’t seem to be working, so I can’t register my nick again.

I think this is why the web service is broken: the webchat lets you join as an unregistered user, but unregistered users can’t chat in #garuda… what’s strange is that because you don’t have a valid password on the Garuda webchat, it kicks you off the IRC-nERDs network as a whole. :thinking:
If you join the regular irc-nerds webchat (, you can connect to their default channel and stuff just fine, so it’s a channel configuration problem in addition to the email confirmation stuff.

(Also, I tried to join with my actual IRC credentials and it still said I had an invalid password, which might have to do with the nick getting unregistered…)


I’ve tracked this here: IRC web client misconfiguration (#8) · Issues · Garuda Linux 🦅 / Infrastructure Nix · GitLab

We need @sorcerer420 to provide some more information, but he seems to be quite busy as of late :saluting_face:


Nice :smiley:
I tried again after getting confirmed by sorcerer themselves (God bless), and now the error is:

Closing Link: [] (CGI:IRC -- Invalid password) (irc)

That doesn’t happen using the main IRC-nERDs webchat, so it’s not just an issue of not having a registered nick.

Ok it seems I can access garuda irc using webchat. :grin:. I basically clicked on the website and changed the channel to #Garuda. along with a nick I wanted and username I wanted and my real name. Once done I was instantly in the garuda IRC channel. :exploding_head:

Then I went ahead and did the nickserv. It seems nickserv has issues with gmail accounts for some reason. Well anyway I used my proton mail account. Got the mail instructions for claiming my nick instantly and joined the channel and can communicate now.

Now I have setup myself with irssi. Command line chatting for the win!! :grin:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.