How to allways see the close/minimize/maximize buttons

How to allways see the close/minimize/maximize buttons?
Im new to Arch-Linux and KDE and i hate that the close/maximize/minimize buttons are not visible when the window is maximized. I want it to be allways there.

OS: Garuda Linux

No KDE expert (!) - but look for a setting for titlebars being hidden when the window is maximized... There must be some KDE docs somewhere! :grin:

2 Likes

Are they hidden or are they just moved into the top panel on the left side?

4 Likes

Do you mean on your separate monitors? If so you need to add the appropriate panel to each monitor if I'm not mistaken.

2 Likes

They get pushed above the top of the window when a program is maximized. I believe it's a setting in KDE that is selected by one of the devs before the ISO is created. I asked a bit ago about the samething. Let me look through my post here to see what solution I was actually offered and worked.

EDIT:

Just went through my topics and nothing, so it wasn't here I asked about the setting. I'll go through the system settings and see what I changed.

Here is what happens for me on the dr460nized edition.

Not maximized:

Maximized:
image

Is this something different than what others are seeing?

2 Likes

When I installed Garuda when I would maximize a program or a window the close, maximize, minimize buttons would be hidden. Thought I asked here how to change that behavior, but looks like I asked somewhere else.

Could this (post and thread) help?

1 Like

I'm not seeing that top screen in system settings.

Sorry, I'm not on the system today...
What if you enter "window buttons" in the application menu search field?
Edit: I noticed only now that the first screen is available "If you have the window buttons extension running"

1 Like

Knew when I got the fix I should of made a note on it locally so I have it for myself and others.

This issue is answered multiple times in the forum.
Default Garuda dragonized (forgive my bad spelling :stuck_out_tongue_winking_eye: ) configuration uses Latte dock/panels instead of default Plasma panels (no Plasma panel exists by default).
There is a Latte Top Panel, that includes a plasmoid called Window Buttons, which (by default) is visible when there is an active maximized window, showing a clone of the respective window buttons, while it is hidden when the active window is Unmaximized.
This requires a kWin setting in $HOME/.config/kwinrc

[Windows]
BorderlessMaximizedWindows=true

If you want to not use this feature, you can (preferably) disable it in Latte Configuration settings, by un-ticking the relevant checkbox and re-login.
To configure how the "Window Buttons" behave, use Latte (Top) panel Edit mode and select this plasmoid settings to edit, or delete it if you don't need it.

I guess I should post this in #faq-and-tutorials :grinning_face_with_smiling_eyes:

7 Likes

Thanks deleting it was exactly what I did. Info save now.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.