How do I make data directory to read and write so i can write on it

I want to transfer files to my /run/media/johnlamuel/Data/ directory cause it has more storage but when i try to transfer files a pop up saying "Could not write to /run/media/johnlamuel/Data/ screenshot_1.png."

I already tried doing chmod and mounting and unmounting but it still doesn't work

╭─[email protected] in ~  
╰─λ inxi -Fza
System:
Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen  
root=UUID=62aa587f-5047-4514-8fd1-0d539d5c469e rw [email protected] quiet
splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1  
dm: SDDM Distro: Garuda Linux base: Arch Linux  
Machine:
Type: Laptop System: Acer product: Aspire A314-35 v: V1.09 serial: <filter>  
Mobo: JSL model: Rosemary_JL v: V1.09 serial: <filter> UEFI: INSYDE v: 1.09  
date: 06/22/2021  
Battery:
ID-1: BAT1 charge: 41.6 Wh (100.0%) condition: 41.6/41.6 Wh (100.0%)  
volts: 12.6 min: 11.2 model: LGC AP19B8K type: Li-ion serial: <filter>  
status: Full  
CPU:
Info: Quad Core model: Intel Pentium Silver N6000 bits: 64 type: MCP  
arch: Tremont family: 6 model-id: 9C (156) stepping: 0 microcode: 1D cache:  
L2: 4 MiB  
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8908  
Speed: 3126 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3126 2: 1900  
3: 1895 4: 2284  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass  
mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1  
mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:
Device-1: Intel JasperLake [UHD Graphics] vendor: Acer Incorporated ALI  
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4e71 class-ID: 0300  
Device-2: Quanta VGA WebCam type: USB driver: N/A bus-ID: 1-4:2  
chip-ID: 0408:a031 class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")  
s-diag: 414mm (16.3")  
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7")  
diag: 354mm (13.9")  
OpenGL: renderer: Mesa Intel UHD Graphics (JSL) v: 4.6 Mesa 21.2.3  
direct render: Yes  
Audio:
Device-1: Intel vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel  
alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:4dc8  
class-ID: 0403  
Device-2: Intel USB PnP Sound Device type: USB  
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:11 chip-ID: 8086:0808  
class-ID: 0300  
Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.38 running: yes  
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet  
vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000  
bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp1s0 state: down mac: <filter>  
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus-ID: 02:00.0
chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
v: 0.8 bus-ID: 1-8:3 chip-ID: 04ca:3015 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 75.95 GiB (7.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM128GD3JX016N
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 41020C20 temp: 53.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: 2J scheme: GPT
Partition:
ID-1: / raw-size: 118.99 GiB size: 118.99 GiB (100.00%)
used: 34.39 GiB (28.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%)
fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.99 GiB size: 118.99 GiB (100.00%)
used: 34.39 GiB (28.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 118.99 GiB size: 118.99 GiB (100.00%)
used: 34.39 GiB (28.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 118.99 GiB size: 118.99 GiB (100.00%)
used: 34.39 GiB (28.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 596 MiB (7.7%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 260 Uptime: 3h 24m wakeups: 1 Memory: 7.6 GiB
used: 3.3 GiB (43.4%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1762 lib: 505 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06
╭─[email protected] in ~ 
╰─λ lsblk -f
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                         
└─sda1
ntfs         Data  6446759B46756F24                        890G     4% /run/media/johnlamuel/Data
zram0
[SWAP]
nvme0n1
│
├─nvme0n1p1
│    vfat   FAT32 NO_LABEL
│                       F1EE-BF8B                             255.4M     0% /boot/efi
└─nvme0n1p2
btrfs              62aa587f-5047-4514-8fd1-0d539d5c469e   83.7G    29% /var/tmp
/var/cache
/var/log
/srv
/home
/root
/

Hi there, welcome!
Is this a NTFS partition?
If so, you'll need ntfs-3g.
https://wiki.archlinux.org/title/NTFS-3G
Otherwise, check also the ownership
https://wiki.archlinux.org/title/File_permissions_and_attributes#Changing_ownership

4 Likes

Read

please
and post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

3 Likes

Not sure if this is a typo or not, but you need to chown the drive not chmod. Once you take ownership of the drive things should work properly.

Welcome to the forum.

3 Likes

How do I know if im using NFTS partition?

lsblk -f

in terminal.

Again

We are not a forum to teach the basics of Linux.
We are happy to help, but also require initiative from Garuda Linux users.

1 Like

im really sorry im new

Open a terminal, enter that command and paste the results here, with
~~~
before and after the text block (for formatting reasons)

So, it looks like it is ntfs.
So, you should install:
sudo pacman -S ntfs-3g
and try again mounting and copying

Aight im gonna give up on this problem for now lol... in the process of trying to fix this i somehow accidentally deleted linux... ill probably come back to this some other time, but not very soon... im gonna go learn a little bit more about linux and then may be try to fix this once more... Thank you every one you've all been helpful... see you all soon

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.