How do i install drivers?

Hello, i am using an amd cpu/gpu and i'm trying to install drivers for them but i can't figure out how.

First, please post output of ìnxi -Fxxxa and we can take it from there :slight_smile:

2 Likes

What does not work?

Read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

2 Likes

AMD Hardware drivers are built into the kernel so you don't need to bother. However you should run a system update. pacman -Syu .

3 Likes
System:    Kernel: 5.11.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=52ea6d73-29e3-47a6-b493-641c84b65a31 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING PRO CARBON WIFI (MS-7B93) v: 1.0 
serial: <filter> UEFI: American Megatrends v: 1.60 date: 01/14/2020 
CPU:       Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
model-id: 71 (113) stepping: N/A microcode: 8701013 cache: L2: 4 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 115194 
Speed: 3600 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3600 2: 3602 
3: 3925 4: 3600 5: 3601 6: 3598 7: 3592 8: 3444 9: 4280 10: 4096 11: 3439 12: 4291 13: 4097 
14: 3476 15: 3600 16: 4012 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] vendor: ASUSTeK 
driver: amdgpu v: kernel bus-ID: 2f:00.0 chip-ID: 1002:731f class-ID: 0300 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") s-diag: 777mm (30.6") 
Monitor-1: DisplayPort-1 res: 2560x1440 hz: 165 dpi: 109 size: 597x336mm (23.5x13.2") 
diag: 685mm (27") 
OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0 5.11.13-zen1-1-zen LLVM 11.1.0) 
v: 4.6 Mesa 21.0.2 direct render: Yes 
Audio:     Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus-ID: 2f:00.1 
chip-ID: 1002:ab38 class-ID: 0403 
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403 
Device-3: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-2:3 
chip-ID: 0c45:636d class-ID: 0102 serial: <filter> 
Device-4: Corsair CORSAIR VOID ELITE Wireless Gaming Dongle type: USB 
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:5 chip-ID: 1b1c:0a51 class-ID: 0300 
Sound Server-1: ALSA v: k5.11.13-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: kernel port: d000 
bus-ID: 26:00.0 chip-ID: 8086:1539 class-ID: 0200 
IF: enp38s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 bus-ID: 28:00.0 
chip-ID: 8086:2723 class-ID: 0280 
IF: wlo1 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 8087:0029 
class-ID: e001 
Report: ID: hci0 state: up address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 11.87 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: <filter> rev: 2B2QEXE7 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 11.87 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 11.87 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 11.87 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 11.87 GiB (1.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1000.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1000.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1000.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1000.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 51.2 C mobo: N/A gpu: amdgpu temp: 59.0 C mem: 62.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 346 Uptime: 23m wakeups: 0 Memory: 15.64 GiB used: 2.74 GiB (17.5%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1282 lib: 335
Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.03

As @Khsh01 said the drivers are inbuilt to the kernel.

You can see this in the output you posted -

image

As advised, run an update with pacman -Syu , then reboot and you should be good to go.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.