How do I get my default profile picture back

I decided today that I wanted to change my profile picture, for some reason. Even though the one I had was perfectly fine and actually worked well with my theme.
I actually don’t know WHY I wanted to change it. Either I forgot why, or I just wanted to change it to actually get away from the default. For some reason.
Now I want the profile picture I used before, back. How do I get it back? (and no, snapshots dont work.)

garuda-inxi:

System:
Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cd554b12-50c1-4d21-8dc3-75e81b1e0163 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
intel_iommu=on iommu=pt ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: HP product: HP ZBook 17 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 80D6 v: KBC Version 10.75 serial: <superuser required>
part-nu: 1MY26EC#ABA uuid: <superuser required> UEFI: HP v: N81 Ver. 01.45
date: 01/06/2020
Battery:
ID-1: BAT0 charge: 39.5 Wh (56.3%) condition: 70.1/70.1 Wh (100.0%)
volts: 11.0 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: discharging
CPU:
Info: model: Intel Core i5-6440HQ bits: 64 type: MCP arch: Skylake-S
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x5E (94) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2724 high: 3497 min/max: 800/3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 3300 3: 3497
4: 3300 bogomips: 20799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:191b class-ID: 0300
Device-2: NVIDIA GM204GLM [Quadro M3000M] vendor: Hewlett-Packard
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s ports: active: none empty: DP-4,DP-5,DP-6
bus-ID: 01:00.0 chip-ID: 10de:13fa class-ID: 0300
Device-3: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-7:2 chip-ID: 05c8:0383 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1738 built: 2015 res: 1920x1080
hz: 60 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.6-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 530 (SKL GT2)
device-ID: 8086:191b memory: 15.14 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: integrated-gpu
name: Intel HD Graphics 530 (SKL GT2) driver: mesa intel v: 24.0.6-arch1.2
device-ID: 8086:191b surfaces: xcb,xlib device: 1 type: discrete-gpu
name: Quadro M3000M driver: nvidia v: 550.78 device-ID: 10de:13fa
surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256
bits) driver: mesa llvmpipe v: 24.0.6-arch1.2 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-12:4 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
Local Storage: total: 1.14 TiB used: 451.58 GiB (38.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: THNSN5256GPUK
NVMe TOSHIBA 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 5KDA4103 temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3T0 scheme: GPT
Partition:
ID-1: / raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 73.72 GiB (31.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 262.7 MiB (51.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 377.6 GiB (40.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 73.72 GiB (31.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 237.97 GiB size: 237.97 GiB (100.00%)
used: 73.72 GiB (31.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C pch: 45.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB available: 15.5 GiB used: 4.47 GiB (28.8%)
Processes: 253 Power: uptime: 31m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 2390 pm: dpkg pkgs: 0 pm: pacman pkgs: 2347 libs: 592
tools: octopi,paru,yay pm: flatpak pkgs: 43 Compilers: clang: 17.0.6
gcc: 14.1.1 Shell: garuda-inxi default: Bash v: 5.2.26 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-07-21
Last full system update: 2024-05-08
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut(custom) nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            filtron.service morty.service

My guess would be this file is stored in your user config–that is to say, restoring a snapshot would work, but you would need to set up a Snapper config for the home subvolume first.

As it is, it sounds like one file has been replaced with another; you will have to grab the picture from your personal backups or from wherever you originally got it from.

1 Like

If it was that one picture was replaced with another, there would have to be multiple pictures, because the text and outlines cycle through colours.

When I tried going back to the earliest possible snapshot that worked, even though I saw my default pfp when I restored to it, it was the same.

That could be because of the fact that I seemingly skipped a step, and then thought that it worked when going to said snapshot.

When I get back home, where I have my USB, I’ll try to do it like told to me.
For now though, I’ll have to wait a day or so to do it.

I am afraid I do not following your meaning. It sounds possible that you mean something completely different by “profile picture” than what I was thinking.

Can you be more specific about the picture which has been changed? Perhaps you can add a screenshot.

Was it the pic that came with the os? like a garuda one or was it one you got from somewhere else. The original one.

the original.
specifically the garuda one.

I think it should be in /usr/share/icons/garuda/

Nope. Not there…

It was the default Garuda one. The one that came with my OS. Already set for me when I first installed Garuda.

BTW.

I checked out the live iso in case mine was personally different. It only shows it as a letter a person silhouette so whatever your account name is it will choose the first letter from there you can pick one of the colours. It was yellow in the ISO. Other than that I’m not really sure.

Yup. That’s it! It seems to change colours every time it fetches the pfp. Last I remember the colours between the User Switcher and the User Page in Settings can even be inconsistent! That’s exactly what I’m trying to get back.

That is, assuming it’s not different in the Live ISO. I’ll download the ISO and check.

Yup. It’s the exact same one. That’s the profile picture I want to restore.
It worked SO WELL that I mistook it for being transparent.

depending on your theme or the icons, i cant remember it will look a bit different but you can pick it here. just click on the user then the users icon

That doesn’t seem to be the correct one…
So if my theme is different the profile picture will be different too?
If that’s the case, doesn’t that mean that I’d have to use the default theme first, then select the icon, and then put everything back?

I already have the Dragonized global theme on so it must be the icons if it’s different.

Alrighty. After testing, changing the icons actually DOES make the profile picture, when selecting, different.

However after going through every icon pack I had, none of them seem to bring the default icon back.

1 Like

maybe breeze but yea i’m not to sure if anything i would check the icons pacs in the user folder see if you can find the person silhouette or maybe at this point duckduckgo one perhaps

None of the above seem to have worked.
I can’t even find the icon packs in the user folder…
Finding the default icon via searching just doesn’t work…
And I’ve already used Manjaro. If the icon was there, I would have remembered.
Going to the directory where KDE says their avatars are, when hovering over them, doesn’t allow me to see the Letter PFP, the Person PFP, or the Default PFP.
I’m probably just gonna have to live with the consequences of my actions.
Not even the normal letter profile pictures show up when searched.

Just use this

or make a drawing including colors of “your” icon/avatar/picture, because I don’t understand what you mean exactly.

Checked it at my side. Looking at @elite screenshot - the original icon looks like the “Z” account there, but if you select any of the options on the right, you cannot go back to the red “Z” style. Trying the “E” or the marked “purple person in the frame” will not bring back the original.

This is the User Switcher with the default pfp in the LiveISO:
image

This is the default pfp in the Users Menu in Settings:
Screenshot_20240513_163111

See how they’re both different?
I’ve come to the conclusion that it’s not a image, because of this. And the fact that it changes colours every time you see it. Or it uses many different images, for multiple different scenarioes.

Now then. This is what I tried to make to be as close as possible to said profile picture.

The fake default that I had created has different behaviour.

This is how it appears in the User List in the Users Menu:
image

And this is how it appears in the User Switcher:

image