Hindi Font Error

while typing "श्र" it writes ("श्" "र"), "त्र" as " त्र "

even on google and other platforms it shows 'श् र' and it's frustrating

other letters, words works fine eg "क्ष" "ज्ञ"



Kernel: 6.3.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2c37d75b-3af3-47e8-a620-b8242fbbf24d rw rootflags=subvol=@
quiet rd.luks.uuid=5e5eebd1-746d-4a1a-80f4-d60934414fa2 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-6039496f-13b5-40a5-97de-37e08ba2855f loglevel=3
Desktop: sway v: 1.8.1 info: waybar vt: 1 dm: N/A Distro: Garuda Linux
base: Arch Linux
Type: Desktop Mobo: INTEL model: H61 serial:
UEFI: American Megatrends v: 4.6.5 date: 04/08/2022
Info: model: Intel Core i3-2120 bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 3300 min/max: 1600/3300 scaling: driver: intel_cpufreq
governor: performance cores: 1: 3300 2: 3300 3: 3300 4: 3300 bogomips: 26341
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: NVIDIA GF119 [GeForce GT 610] driver: nouveau v: kernel non-free:
series: 390.xx+ status: legacy-active (EOL~late 2022) arch: Fermi
code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s
lanes: 8 link-max: lanes: 16 ports: active: HDMI-A-1 empty: DVI-I-1,VGA-1
bus-ID: 01:00.0 chip-ID: 10de:104a class-ID: 0300 temp: 48.0 C
Display: wayland server: Xwayland v: 23.1.2 compositor: sway v: 1.8.1
driver: gpu: nouveau display-ID: 1
Monitor-1: HDMI-A-1 model: Acer EK220Q serial: built: 2022
res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2 scale: 1
size: 479x260mm (18.86x10.24") diag: 545mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Message: No known Wayland EGL/GBM data sources. API: EGL/GBM
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e08 class-ID: 0403
API: ALSA v: k6.3.7-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.2:3
chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Local Storage: total: 1.93 TiB used: 603.62 GiB (30.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: GALAX model: GAMER L TA1D0120A
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 61.3 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: fw-rev: HP35 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD15SMRW-11YNDS1 size: 1.36 TiB block-size: physical: 512 B
logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0
tech: HDD rpm: 5400 serial: fw-rev: 1020 scheme: GPT
ID-1: / raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 18.79 GiB (18.3%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-5e5eebd1-746d-4a1a-80f4-d60934414fa2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 18.79 GiB (18.3%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-5e5eebd1-746d-4a1a-80f4-d60934414fa2
ID-4: /var/log raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 18.79 GiB (18.3%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-5e5eebd1-746d-4a1a-80f4-d60934414fa2
ID-5: /var/tmp raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 18.79 GiB (18.3%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-5e5eebd1-746d-4a1a-80f4-d60934414fa2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 254:1
mapped: luks-6039496f-13b5-40a5-97de-37e08ba2855f
ID-2: swap-2 type: zram size: 7.71 GiB used: 239.8 MiB (3.0%)

   priority: 100 dev: /dev/zram0
   System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 48.0 C
   Fan Speeds (RPM): N/A
   Processes: 350 Uptime: 9m wakeups: 0 Memory: available: 7.71 GiB
   used: 1.84 GiB (23.9%) Init: systemd v: 253 default: graphical
   tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1500
   libs: 397 tools: gnome-software,pamac,paru pm: flatpak pkgs: 0 Shell: fish
   v: 3.6.1 running-in: terminator inxi: 3.3.27
   Garuda (2.6.16-1):
   System install date: 2023-05-31
   Last full system update: 2023-06-12
   Is partially upgraded: No
   Relevant software: snapper NetworkManager dracut
   Windows dual boot: No/Undetected
   Failed units:

Terminal, LibreOffice, Text editor?


everywhere, firefox, libreoffice, terminal (in terminal it becomes chaotic)
i figured out its font error as when i type in libreoffice it shows free sans and it writes (श् र) but when i select it and change it to akshar light it properly shows the right character

So it is not a Sway problem.

fc-cache -fv

Check your fonts and post issue to the font devs, please :slight_smile:


no it still didn't worked, how can i change the font.
from arch wiki i have downloaded multiple fonts to fix it but didn't work how to change the typing font (currently it's freesans i think)


i am bit lost, please help me what should i do here

no matter what I do, it is not working

Text would have been better than picture for this.

Try not using the filename there (TiroDevanagariSankrit-regular.ttf), do fc-list and find out (example: for /usr/share/fonts/TTF/DejaVuSans.ttf: DejaVu Sans:style=Book use DejaVu Sans).
Likely, Tiro Devanagari Sankrit or maybe TiroDevanagariSankrit.

You said Akshar Light is good, try that one too.


Its not working :smiling_face_with_tear:

maybe the font for it can be changed from here but i can't find it

in terminal.

If anyone here on the forum knows, they will be in touch.

In the meantime, use the time to try things out for yourself and don’t spam the forum by uploading unnecessary images. Especially if you have posted them before.

Have you tested if the problem exists with other DE’s as well (live ISO)?


I don't think so, that's the input method but I don't see font settings there.
The Sway theme config does not necessarily apply for other applications, many have their own config or get it from some of the GTK and Qt config files.


tried noting changed
the problem didn't existed on Garuda qtile
sorry i thought it had become the diffrent error so created the new topic sorry

that might be the case i can't find the config file of "input changer"
when i tried diffrent font in sway config file it didn't change the libreoffice still says free sans on "hindi input"
so the font for input comes from "input changer"
but if that was the case then we should be able to the character in the firefox firedragons docs websites
the problem might be in the global fonts

Terminal is Alacritty?
That has its config in ~/.config/alacritty/alacritty.yml, the font should be towards the end, on mine:

    family: JetbrainsMonoNL
    style: Regular
  size: 9

Others not sure, Firedragon (like Firefox) has its own settings from the menu, libreoffice I'm not sure but look for something like "template" that is used for new documents (unless you mean its user interface, that will likely be in the menu too).

1 Like

terminal is terminator
and yeah firefox doesn't show most of the symbols but firedragon shows every symbols
and in libre office i meant that when i am on colemak it's fonts auto changes to libretion serif but i start typing in hindi it auto changes into free sans

i found this

and this


but my stupid @$$ can't understand it

1 Like

Good find. Yes, that ~/.config/fontconfig/conf.d/ looks like it should work.
Which part you need help with?

1 Like

i don’t know why but arch linux forms goes over my head sorry

cd: The directory '/home/nihu/.config/fontconfig/conf.d/' does not exist

cd: The directory '/home/nihu/.config/fontconfig/' does not exist

You may need to create the directory: mkdir -p ~/.config/fontconfig/conf.d

1 Like