Hibernation/suspend not working after update

Dear Garuda staff and members,

I have been experiencing an issue since my last update on 2023-12-09.

The hibernation/suspend function is not working after the update, although it used to work consistently before.

It appears to initiate the hibernation process and turn off the computer successfully.
However, upon turning the computer back on, it is unable to return from hibernation; instead, it starts a new session and does not load my last session from the swap, and the swap partition empty!?

I have tested the sleep and shutdown functions, and both work as expected.

In Manjaro KDE hibernation works.
I tried already the Garuda LTS kernel. Same issue.

Could you please advise on what steps I should take to restore the hibernation functionality?

Thank you in advance for your assistance.

Best regards,

  Kernel: 6.6.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6c2e46d1-f010-4685-9e08-05bcb70ab7ed rw rootflags=subvol=@
    apparmor=1 security=apparmor quiet udev.log_priority=3
    resume=UUID=822b0420-2fff-4f14-9b22-9c0b6c166b2e ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2802
    date: 10/21/2020
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4613 high: 4648 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4641 2: 4640
    3: 4342 4: 4618 5: 4641 6: 4648 7: 4638 8: 4632 9: 4639 10: 4641 11: 4641
    12: 4641 bogomips: 88632
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Vega 10 XL/XT [Radeon RX 56/64] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1 empty: DP-1, DP-2,
    DVI-D-1, HDMI-A-2 bus-ID: 0d:00.0 chip-ID: 1002:687f class-ID: 0300
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.83x15.00")
    s-diag: 987mm (38.84")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung S34J55x
    serial: <filter> built: 2020 res: 3440x1440 hz: 50 dpi: 110 gamma: 1.2
    size: 797x333mm (31.38x13.11") diag: 864mm (34") modes: max: 3440x1440
    min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX Vega (vega10 LLVM
    16.0.6 DRM 3.54 6.6.6-zen1-1-zen) device-ID: 1002:687f memory: 7.81 GiB
    unified: no
  API: Vulkan v: 1.3.269 layers: 13 device: 0 type: discrete-gpu name: AMD
    Radeon RX Vega (RADV VEGA10) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:687f surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: AMD Vega 10 HDMI Audio [Radeon 56/64] driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0d:00.1
    chip-ID: 1002:aaf8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.6.6-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 07:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: tun0 state: down mac: N/A
  IF-ID-2: tun1 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  IF-ID-3: virbr0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6:6 chip-ID: 8087:0029
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 15.92 TiB used: 4.58 TiB (28.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Crucial model: CT500P2SSD8
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P2CR033 temp: 42.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 1B4QFXO7 temp: 49.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD50EZRZ-00GZ5B1 size: 4.55 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5700 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA300
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: ABB0 scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DL003-9VT166
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5900 serial: <filter> fw-rev: CC32 scheme: MBR
  ID-6: /dev/sdd maj-min: 8:48 vendor: Western Digital
    model: WD60EZAZ-00SF3B0 size: 5.46 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-1: / raw-size: 200 GiB size: 200 GiB (100.00%) used: 40.44 GiB (20.2%)
    fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p4 maj-min: 259:4
  ID-3: /home raw-size: 631.01 GiB size: 631.01 GiB (100.00%)
    used: 258.63 GiB (41.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 200 GiB size: 200 GiB (100.00%)
    used: 40.44 GiB (20.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 200 GiB size: 200 GiB (100.00%)
    used: 40.44 GiB (20.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 46.95 GiB used: 465.2 MiB (1.0%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 100 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme1n1p1 maj-min: 259:1
  System Temperatures: cpu: 48.9 C mobo: 41.0 C gpu: amdgpu temp: 51.0 C
    mem: 50.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 3
  Processes: 469 Uptime: 56m wakeups: 0 Memory: total: 48 GiB
  available: 46.95 GiB used: 12.25 GiB (26.1%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 2498 pm: pacman pkgs: 2470 libs: 607 tools: octopi,paru
  pm: flatpak pkgs: 28 Shell: fish v: 3.6.4 default: Bash v: 5.2.21
  running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2023-04-06
  Last full system update: 2023-12-11
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            clamav-clamonacc.service 

sudo swapon -s

Filename                                Type            Size            Used            Priority
/dev/zram0                              partition       49229820        0               100
/dev/nvme1n1p1                          partition       104857596       0               -2

lsblk -f | grep swap

|-nvme1n1p1 swap   1                     822b0420-2fff-4f14-9b22-9c0b6c166b2e                [SWAP]
|-nvme0n1p2 swap   1                     1afc2205-a394-4d98-a501-3f28c602a8b0

cat /sys/power/mem_sleep

File: /sys/power/mem_sleep
s2idle [deep]


UUID=822b0420-2fff-4f14-9b22-9c0b6c166b2e none           swap    defaults,noatime   0 0


GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor quiet udev.log_priority=3 resume=UUID=822b0420-2fff-4f14-9b22-9c0b6c166b2e"

dracut --list-modules /boot/initramfs-linux.img | grep resume

dracut: Executing: /usr/bin/dracut --list-modules /boot/initramfs-linux.img


#SuspendState=mem standby freeze
#HybridSleepMode=suspend platform shutdown

File: /etc/mkinitcpio.conf

HOOKS=(base udev autodetect modconf block resume filesystems usbinput fsck)

sudo grub-mkconfig -o /boot/grub/grub.cfg

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-amd
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-amd.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-amd-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Manjaro Linux (23.1.0) on /dev/nvme0n1p3
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-12-11 18:17:31 | @/.snapshots/1202/snapshot | post | outguess-png-git                    |
Found snapshot: 2023-12-11 18:17:30 | @/.snapshots/1201/snapshot | pre  | pacman --upgrade --noconfirm -- /home/joe/.cache/paru/clone/outguess-png |
Found snapshot: 2023-12-11 18:17:21 | @/.snapshots/1200/snapshot | post | plymouth-git                        |
Found snapshot: 2023-12-11 18:17:20 | @/.snapshots/1199/snapshot | pre  | pacman --sync -y -y -u --           |
Found snapshot: 2023-12-11 18:14:54 | @/.snapshots/1198/snapshot | post | aom bluez bluez-cups bluez-hid2hci bluez-libs bluez-plugins bluez-utils  |
Found snapshot: 2023-12-11 18:14:14 | @/.snapshots/1197/snapshot | pre  | pacman -Su                          |
Found snapshot: 2023-12-09 21:36:57 | @/.snapshots/1196/snapshot | post | dunst                               |
Found snapshot: 2023-12-09 21:36:56 | @/.snapshots/1195/snapshot | pre  | pacman --remove -- dunst            |
Found snapshot: 2023-12-09 21:31:52 | @/.snapshots/1194/snapshot | post | chaotic-kf5-dummy                   |
Found snapshot: 2023-12-09 21:31:51 | @/.snapshots/1193/snapshot | pre  | pacman --sync -- knotifyconfig      |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.QVWJLK97zX .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.

sudo dracut-rebuild

:: Building initramfs for linux-lts (6.1.66-1-lts)
:: Building fallback initramfs for linux-lts (6.1.66-1-lts)
:: Building initramfs for linux-amd (6.6.5-AMD)
:: Building fallback initramfs for linux-amd (6.6.5-AMD)
:: Building initramfs for linux-zen (6.6.6-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.6.6-zen1-1-zen)
1 Like

Hi @JoeSz, try adding this new systemd-hibernate-resume.service service file to your dracut config:

add_dracutmodules+=" resume "
install_items+=" /usr/lib/systemd/system/systemd-hibernate-resume.service "

Then rebuild the initramfs with sudo dracut-rebuild.

This worked for another user in this thread: Can't hibernate after udpate and systemd-vconsole-setup fails - #2 by BluishHumility

Source: [systemd 255rc2] hibernation with dracut / [testing] Repo Forum / Arch Linux Forums


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.