Help with graphic drivers

Hi everyone.
I’m pretty new to Linux especially Arch Linux.
After trying with a second clean install I always face the same issues:

  • external monitor not working;
  • "unknown device name " in display controller (both for integrated AMD gpu and dedicated NVIDIA gpu);
  • no audio coming from laptop speakers while it works through headphones (I guess it’s better to create a new topic for this one).

Here is my garuda-inxi result:

Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=32b6b372-9bb2-4c50-a3f3-cf82a6bdcec4 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Strix G713PV_G713PV v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: G713PV v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: G713PV.327 date: 08/23/2023
ID-1: BAT0 charge: 82.9 Wh (98.0%) condition: 84.6/90.0 Wh (94.0%)
power: 7.5 W volts: 17.4 min: 15.9 model: AS3GWAF3KC GA50358 type: Unknown
serial: <filter> status: charging
Info: model: AMD Ryzen 9 7845HX with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 4 gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 2276 high: 5040 min/max: 400/5298 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 3343 3: 400
4: 5012 5: 3309 6: 4979 7: 400 8: 3627 9: 4516 10: 400 11: 400 12: 5040
13: 2487 14: 400 15: 400 16: 400 17: 400 18: 400 19: 5026 20: 400 21: 3892
22: 3584 23: 400 24: 5016 bogomips: 143724
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
bus-ID: 01:00.0 chip-ID: 10de:28e0 class-ID: 0300
Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,DP-3
bus-ID: 09:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 68.0 C
Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 13d3:5458
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting dri: radeonsi
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: eDP-1 model: BOE Display NE173QHM-NZ2 built: 2022
res: 2560x1440 hz: 240 dpi: 171 gamma: 1.2 size: 381x214mm (15x8.43")
diag: 437mm (17.2") ratio: 16:9 modes: max: 2560x1440 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 1 drv: radeonsi device: 2 drv: swrast surfaceless:
drv: nvidia x11: drv: radeonsi inactive: gbm,wayland
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics
(raphael_mendocino LLVM 16.0.6 DRM 3.54 6.6.2-zen1-1-zen)
device-ID: 1002:164e memory: 500 MiB unified: no
API: Vulkan v: 1.3.269 layers: 8 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
v: 23.2.1-arch1.2 device-ID: 1002:164e surfaces: xcb,xlib device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 4060 Laptop GPU driver: nvidia
v: 545.29.06 device-ID: 10de:28e0 surfaces: xcb,xlib device: 2 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_rpl_pci_acp6x v: kernel alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 09:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:3 chip-ID: 0489:e0f6
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.84 TiB used: 19 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Micron model: 2400 MTFDKBA1T0QFM
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V3MA003 temp: 30.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR021 temp: 33.9 C
scheme: GPT
ID-1: / raw-size: 476.54 GiB size: 476.54 GiB (100.00%)
used: 12.75 GiB (2.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:7
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 58.8 MiB (61.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 476.54 GiB size: 476.54 GiB (100.00%)
used: 12.75 GiB (2.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:7
ID-4: /var/log raw-size: 476.54 GiB size: 476.54 GiB (100.00%)
used: 12.75 GiB (2.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:7
ID-5: /var/tmp raw-size: 476.54 GiB size: 476.54 GiB (100.00%)
used: 12.75 GiB (2.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.83 GiB used: 77 MiB (0.5%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
System Temperatures: cpu: 92.2 C mobo: 44.0 C gpu: amdgpu temp: 69.0 C
Fan Speeds (rpm): N/A
Processes: 467 Uptime: 59m wakeups: 0 Memory: total: 16 GiB note: est.
available: 14.83 GiB used: 4.21 GiB (28.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1349 libs: 430 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-26
Last full system update: 2023-11-26 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

The second time I installed Garuda, I followed step 4 of this guide since I’m on an Asus laptop.

Still no luck.

Additional info:

  • unfortunately I still need Windows so I have dualboot;
  • I’m downloading a game atm just to check if nvidia drivers work fine;
  • I only have linux-mainline and linux-zen as available (and installed) kernels.

I have no clue about dual GPU but try

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ nvidia-drm.modeset=1 "/g' -i /etc/default/grub && sudo update-grub

for the nvidia card.

1 Like

You have a reboot pending. Very important to do on a fresh install after an update.

1 Like

No luck!
This is the output:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-mainline
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-mainline.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-mainline-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-11-26 22:53:13 | @/.snapshots/10/snapshot | post | optimus-manager-qt                    |
Found snapshot: 2023-11-26 22:53:12 | @/.snapshots/9/snapshot  | pre  | pacman -S optimus-manager-qt          |
Found snapshot: 2023-11-26 22:53:00 | @/.snapshots/8/snapshot  | post | optimus-manager                       |
Found snapshot: 2023-11-26 22:53:00 | @/.snapshots/7/snapshot  | pre  | pacman -S optimus-manager             |
Found snapshot: 2023-11-26 22:51:57 | @/.snapshots/6/snapshot  | post | dkms egl-wayland eglexternalplatform nvidia-dkms nvidia-utils            |
Found snapshot: 2023-11-26 22:50:24 | @/.snapshots/5/snapshot  | pre  | /usr/bin/pacman -S --noconfirm extra/nvidia-dkms                         |
Found snapshot: 2023-11-26 22:43:38 | @/.snapshots/4/snapshot  | post | aribb24 chromium discord ffmpeg4.4 glibmm-2.68 hunspell jsoncpp libdispa |
Found snapshot: 2023-11-26 22:43:22 | @/.snapshots/3/snapshot  | pre  | pacman -S --needed chromium discord linux-mainline linux-mainline-header |
Found snapshot: 2023-11-26 22:39:23 | @/.snapshots/2/snapshot  | post | alsa-card-profiles amd-ucode android-udev aom appstream appstream-qt app |
Found snapshot: 2023-11-26 22:38:55 | @/.snapshots/1/snapshot  | pre  | pacman -Su                            |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.05CrdFJyHF .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Did you reboot?

1 Like

Actually I tried after my third installation (without dualboot) cuz I wanted to try first another distro just to understand if I had same problems or not (I don’t know if I’m allowed to talk more about that).

What is this, fight club? :joy:

Did you set it to “Nvidia only mode” like that guide suggests? I’m not sure, but it looks like it requires additional configuration:

1 Like

I was referring to Nobara. I had pretty munch an out of box experience so nvidia drivers were working fine.

Yeah I had “Nvidia only mode” on but it doesn’t look like it is working correctly.
I followed that guide but I had no luck. I then tried some stuff but I ended up running a snapshot dated before me following the guide.

I’m not an expert but I think we should focus more on the nvidia drivers not properly working instead of the optimus stuff.

“Everyone” with this problem`s has one thing in common:

GeForce RTX 4XXX **Max-Q** / Mobile

I think that they are not recognized correctly (mhwd id`s).

Edit: typo

Well I guess Linux is not ready yet for normal people with a little bit of knowledge.
You have all my support and I’m hoping to see major improvement next year.

GNU/Linux and Open Source is ready for everyone, no matter their level of knowledge.
The main problem lies with companies that do not offer cross-platform software and only support Windows - and with manufacturers that do not offer open source drivers for their hardware. As a kernel hacker, try to implement this proprietary nvidia shit cleanly… and even if you do, the next nvidia driver update will cause problems with the kernel modules again^^

Nobara goes his own (and more complicated) way. They patch their kernel themselves to offer the best possible gaming experience - e.g. nvidia-patches and asus-linux-patches ← especially for “your” Asus laptop :slight_smile:

If Nobara runs without problems for you, then use it.

Nobara gave me no problem with graphic drivers but still couldn’t make my built in speakers work.
I tried to launch 2 platinum games and only one of them worked. Why is that? You might tell me to do a bunch of tricks etc. but then why would it be defined as “platinum” on protonDB?
Platinum in my world should mean plug and play and still I couldn’t find a solution to make it work.
So by saying “Linux is not ready yet” I mean every aspect of it.

We know it boots.
Maybe you would prefer me saying “is not ready yet to replace the ease of use of Windows”.

Some hardware is designed for slapping Windows on the mobo and shoving it out the door, nothing more. If manufacturers are sloppy with the spec or proprietary blobs are needed for hardware enablement, it will be more difficult to get Linux running on it.

So you bought hardware with bad Linux support, but it’s Linux at fault? :thinking: You wouldn’t expect Windows to run on a Macbook, but Linux is somehow supposed to support every possible laptop iteration without any configuration needed?

This is like showing up with a screwdriver to put 100 nails in the wall, then saying “These nails suck, I can’t believe you guys think these nails are actually good.”

Most of us have exactly the out-of-box experience you are describing. The kernel alone supports most hardware. Hardware with bad Linux support can typically still be made to work, but will require additional configuration effort. It’s up to you if you want to get Linux working on that laptop or not.

By the way, Nvidia drivers are in a bad spot in general since about 6.6. It’s not just you having problems with Nvidia right now. Take a look at the other posts in the forum; it is mostly Nvidia issues recently.


I deliberately didn’t answer because with this statement he confirmed that he didn’t understand anything at all. And as long as people believe that Windows is the default, they can’t get out of that mindset. They don’t know anything else and are unable to learn anything new because they live in a bubble. Linux ist not Windows.
And motherboard manufacturers who get into bed with Microsoft to add “security features” to a bloated “operating system” that has more bugs than lines of code…and then nvidia…I’ll leave it. I haven’t bought nvidia for a long time, regardless of the operating system, and now I ignore topics with nvidia problems.

And if anyone thinks that I find this Microsoft monoculture, the lack of commercial software for GNU/Linux and the low distribution of Linux bad: NO.

My greatest interest is that it stays that way.

(so it’s not completely OT: the OP’s display server doesn’t load an nvidia module…what a surprise^^)


For sure it’s not my fault if the hardware is not compatible yet. I watched a video showing how beautiful Linux is, I installed it, it is not properly working. That’s it.

I don’t know why is it that hard to understand what I meant. I genuinely wish that some day I’ll woke up knowing Linux is dominating Windows.

5 years go I had an Hackintosh in dual boot with windows perfectly working and I’ve been testing custom Roms for android for years until my device broke so I’m definitely not living in a bubble.
I’m glad you have time to mess up and learn new things, I only have one computer to work with and because of that I cannot spend more time fixing stuff than actually using my pc. Also, because there’s apperantly not a solution for my case, I don’t see why I need to stuck with Linux.
With that said you still complain about my statement.
Linux is working for y’all? Good, it’s not on my end.
Can I say Linux is not ready for cases like mine and many others (considering also what I said with ProtonDB)?
Is it Linux fault? Not really.
Even if it is not it’s fault, is it ready for everyone, every component and every game/software? No, it will be.

I’ll repeat again. I’m keeping an eye on Linux world hoping to wake up some day reading “Linux is the main OS”. I may have faced many issues with Linux, but I extremely enjoyed everything I could use. Garuda’s developers did a great job over the years and I’m looking foward to try out this distro again in the near future (hopefully).


That sounds a little bit different, so I assume we misunderstood you.

I don’t know of any Max-Q owners who can use the card under Linux without problems, only reports of unresolved problems with it.
Nobara runs without any problems, except the internal speakers. The sound should be output via the nvidia card, which first indicates that there are problems with the nvidia driver. But it could also be a problem with the sound server. Have you asked about the problem in the Nobara forum?

As for Garuda: Windows dual boot is not the problem. The fact that you are trying the mainline kernel is actually a good thing in your case, as it contains code for the latest hardware.
The problem with you is that the nvidia kernel driver is installed but the display server does not recognize the card. X11 doesn’t even try to load the nvidia module. What is also noticeable: with the AMD-IGPU, the amdgpu module should actually be loaded and not modesetting. Can you disable iGPU in UEFI?

  1. Go to /var/log/ and open the Xorg.0.log with an editor. Copy the entire content to and post the generated link here.

  2. Switch to wayland to test (you can select it on the login screen) and post the output of this wayland session from

inxi -G

I guess so, most likely it’s because of my English. Sorry about that.

Actually for my understanding it may be something related to realtek audio drivers not properly being set up. This issue happened either in Garuda and Nobara.
I found this guide that would hopefully help next time I’ll have a chance to install Linux again.

No, I installed Nobara just to see what worked and what not.

Can confirm that

Actually there’s an option in UEFI about iGPU but it doesn’t really seem to disable it. Check this, it looks quite similar to what I have in bios.

For the rest, I’m really sorry but as of right know I returned to Windows. I have work to do and also I’ll be requested to use Adobe software (I read online that people runs it with wine and similar, don’t know if it is actually true).
I should be able to try again in dual boot during the holidays. I also have a cousin that have been using Linux for over a year now so maybe we can manage to work it out.
Thank y’all for the help tho. We keep in contact.

1 Like

Switching off the iGPU (which is possible on some laptops) was only intended for troubleshooting.

Personally, I think that arch and arch-based distributions are not suitable for most beginners and those switching, simply because of rolling release. You need some knowledge to understand and solve problems. And if these are not available, the willingness to embark on a steep learning curve (and yes, that is also a question of time). If the 3 points are not present, then a “normal” Linux distribution is much more suitable. I don’t mean this personally against you but in general (don’t misunderstand me :slight_smile: ).

I would recommend that you continue with Nobara for now and solve the audio issue, that shouldn’t be a problem.

Good luck and sorry for misunderstanding.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.