Help me system not upgrade or remove packages

All issues related to Garuda Linux and its assistance

Mirrors are not configured
Run the following command to configure it

sudo reflector --sort age --save /etc/pacman.d/mirrorlist
5 Likes

not done please help

Type

fixpacman

Or

sudo rm -rf /var/lib/pacman/db.lck

2 Likes
[🔴] × upd
[sudo] password for vicky:
[2021-07-26 23:08:54] WARNING: failed to rate http(s) download (https://america.mirror.pkgbuild.com/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:09:01] WARNING: failed to rate http(s) download (https://asia.mirror.pkgbuild.com/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:09:08] WARNING: failed to rate http(s) download (https://archlinux.thaller.ws/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:09:15] WARNING: failed to rate http(s) download (https://arch.mirror.square-r00t.net/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:09:23] WARNING: failed to rate http(s) download (https://ftp.halifax.rwth-aachen.de/archlinux/community/os/x86_64/community.db): Download timed out after 5 second(s).
File: /etc/pacman.d/mirrorlist
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacm
an.d/mirrorlist
# When:       2021-07-26 17:39:23 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2021-07-26 17:38:48 UTC
# Last Check: 2021-07-26 17:31:14 UTC

Server = https://america.mirror.pkgbuild.com/$repo/os/$arch
Server = https://asia.mirror.pkgbuild.com/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://arch.mirror.square-r00t.net/$repo/os/$arch
Server = https://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/$arch
:: Synchronizing package databases...
 core is up to date
 extra                          1567.1 KiB   104 KiB/s 00:15 [################################] 100%
 community                         5.6 MiB   151 KiB/s 00:38 [################################] 100%
 chaotic-aur is up to date
 multilib                        149.9 KiB  48.9 KiB/s 00:03 [################################] 100%
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (130) 0ad-a24.b-7  alsa-card-profiles-1:0.3.32-1  ananicy-git-2.2.1.r49.g549fa41-1
               android-tools-31.0.2-1  aom-3.1.2-1  aqbanking-6.3.0-2  beautyline-20210718-1
               bitwarden-1.27.1-2  btrfs-progs-5.13-1  celt-0.11.3-4  ceph-libs-15.2.13-2
               cfitsio-1:4.0.0-1  chaotic-mirrorlist-20210716-1  ctemplate-2.4-2  curl-7.78.0-1
               ethtool-1:5.13-1  extremetuxracer-0.8.1-1  f2fs-tools-1.14.0-2  firefox-90.0.2-1
               firefox-i18n-en-us-90.0.2-1  flameshot-git-r1382.4e406ec8-1  fmt-8.0.1-1
               garuda-common-settings-1.4.5-1  garuda-dr460nized-1.5.5-1
               garuda-fish-config-1.3.6-1  garuda-setup-assistant-1.1.0-1
               garuda-system-maintenance-1.1.3-1  gdk-pixbuf2-2.42.6-2  gnome-desktop-1:40.3-1
               gnupg-2.2.29-1  go-2:1.16.6-1  google-chrome-92.0.4515.107-1  gparted-1.3.1-1
               graphviz-2.48.0-1  gst-plugin-pipewire-1:0.3.32-1  handbrake-1.4.0-1  hwloc-2.5.0-1
               imagemagick-7.1.0.4-1  imath-3.1.1-1  intel-gmmlib-21.2.1-1
               intel-media-driver-21.2.3-1  inxi-3.3.06.1-1  jack-0.125.0-9 [removal]
               jack2-1.9.19-2  jemalloc-1:5.2.1-3  jre-openjdk-16.0.2.u7-1
               jre-openjdk-headless-16.0.2.u7-1  kvantum-qt5-0.20.1-1
               latte-dock-git-0.9.91.r143.g47702a59-1  ldb-1:2.4.0-1  lib32-curl-7.78.0-1
               lib32-libva-mesa-driver-21.1.5-1  lib32-libxfixes-6.0.0-1  lib32-mesa-21.1.5-1
               lib32-mesa-vdpau-21.1.5-1  lib32-opencl-mesa-21.1.5-1  lib32-util-linux-2.37.1-1
               lib32-vulkan-icd-loader-1.2.184-1  lib32-vulkan-intel-21.1.5-1
               lib32-vulkan-mesa-layers-21.1.5-1  lib32-vulkan-radeon-21.1.5-1
               libadwaita-1.0.0alpha.2-1  libbytesize-2.6-1  libgdm-40.1-1  libidn-1.38-1
               libjcat-0.1.8-1  libmm-glib-1.16.8-1  libmwaw-0.3.20-1  libnm-1.32.4-1
               libreoffice-fresh-7.1.5-1  libuv-1.42.0-1  libva-mesa-driver-21.1.5-1
               libva-utils-2.12.0-1  libxmlb-0.3.2-1  libxnvctrl-470.57.02-1
               linux-firmware-20210716.b7c134f-1  linux-lts-5.10.53-1  linux-lts-headers-5.10.53-1
               linux-zen-5.13.5.zen1-1  linux-zen-headers-5.13.5.zen1-1  lollypop-1.4.22-1
               mesa-21.1.5-1  mesa-vdpau-21.1.5-1  mhwd-db-garuda-git-r54.c233ab1-1
               modemmanager-1.16.8-1  mtools-1:4.0.34-1  networkmanager-1.32.4-1
               networkmanager-strongswan-1.5.2-2  nm-cloud-setup-1.32.4-1  opencl-mesa-21.1.5-1
               openfortivpn-1.17.0-1  pacman-mirrorlist-20210718-1  perl-5.34.0-2
               perl-http-message-6.33-1  pipewire-1:0.3.32-1  pipewire-media-session-1:0.3.32-1
               plasma5-applets-window-appmenu-0.7.1-1  poppler-21.07.0-3  poppler-glib-21.07.0-3
               poppler-qt5-21.07.0-3  python-more-itertools-8.8.0-1  python-pep517-0.11.0-1
               python-requests-2.26.0-1  python-setuptools-1:57.4.0-1  python-tomli-1.1.0-1
               rpcbind-1.2.6-1  skypeforlinux-stable-bin-8.74.0.152-1  starship-0.56.0-1
               strongswan-5.9.3-1  systemd-249.2-1  systemd-libs-249.2-1
               systemd-sysvcompat-249.2-1  talloc-2.3.3-1  tdb-1.4.5-1  tealdeer-1.4.1-6
               telegram-desktop-2.8.11-2  tevent-1:0.11.0-1  util-linux-2.37.1-1
               util-linux-libs-2.37.1-1  vpnc-1:0.5.3.r496.r153-2  vulkan-headers-1:1.2.185-1
               vulkan-icd-loader-1.2.185-1  vulkan-intel-21.1.5-1  vulkan-mesa-layers-21.1.5-1
               vulkan-radeon-21.1.5-1  vulkan-swrast-21.1.5-1  vulkan-tools-1.2.184-1
               webkit2gtk-2.32.3-1  zimg-3.0.2-1  zoom-5.7.4-1

Total Download Size:   1299.23 MiB
Total Installed Size:  4532.55 MiB
Net Upgrade Size:        69.43 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 aqbanking-6.3.0-2-x86_64 is up to date
 beautyline-20210718-1-any is up to date
 celt-0.11.3-4-x86_64             73.7 KiB  43.8 KiB/s 00:02 [################################] 100%
 chaotic-mirrorlist-2021071...     2.9 KiB  1495   B/s 00:02 [################################] 100%
 jack2-1.9.19-2-x86_64           588.0 KiB  66.3 KiB/s 00:09 [################################] 100%
 cfitsio-1:4.0.0-1-x86_64        553.7 KiB  67.6 KiB/s 00:08 [################################] 100%
 ctemplate-2.4-2-x86_64          220.9 KiB  45.7 KiB/s 00:05 [################################] 100%
 ethtool-1:5.13-1-x86_64         186.1 KiB  6.08 KiB/s 00:31 [################################] 100%
 ceph-libs-15.2.13-2-x86_64       12.4 MiB   164 KiB/s 01:18 [################################] 100%
 Total (  9/109)                1299.2 MiB  16.7 MiB/s 01:18 [################################] 100%
error: failed retrieving file 'jack2-1.9.19-2-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'cfitsio-1:4.0.0-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'ctemplate-2.4-2-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: too many errors from america.mirror.pkgbuild.com, skipping for the remainder of this transaction
error: failed retrieving file 'ethtool-1:5.13-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

 ╭─[email protected] in ~ took 3m14s
[🔴] ×

 ╭─[email protected] in ~ took 3m14s
[🔴] × sudo reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist && cat /etc/pacman.d/mirrorlist && sudo pacman -Syu && fish_update_completions && sudo
 updatedb
[sudo] password for vicky:
[2021-07-26 23:15:05] WARNING: failed to rate http(s) download (https://america.mirror.pkgbuild.com/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:15:12] WARNING: failed to rate http(s) download (https://asia.mirror.pkgbuild.com/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:15:18] WARNING: failed to rate http(s) download (https://archlinux.thaller.ws/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:15:25] WARNING: failed to rate http(s) download (https://arch.mirror.square-r00t.net/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2021-07-26 23:15:32] WARNING: failed to rate http(s) download (https://ftp.halifax.rwth-aachen.de/archlinux/community/os/x86_64/community.db): Download timed out after 5 second(s).
File: /etc/pacman.d/mirrorlist
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacm
an.d/mirrorlist
# When:       2021-07-26 17:45:32 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2021-07-26 17:44:58 UTC
# Last Check: 2021-07-26 17:31:14 UTC

Server = https://america.mirror.pkgbuild.com/$repo/os/$arch
Server = https://asia.mirror.pkgbuild.com/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://arch.mirror.square-r00t.net/$repo/os/$arch
Server = https://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/$arch
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                         5.6 MiB   109 KiB/s 00:53 [################################] 100%
 chaotic-aur is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (130) 0ad-a24.b-7  alsa-card-profiles-1:0.3.32-1  ananicy-git-2.2.1.r49.g549fa41-1
               android-tools-31.0.2-1  aom-3.1.2-1  aqbanking-6.3.0-2  beautyline-20210718-1
               bitwarden-1.27.1-2  btrfs-progs-5.13-1  celt-0.11.3-4  ceph-libs-15.2.13-2
               cfitsio-1:4.0.0-1  chaotic-mirrorlist-20210716-1  ctemplate-2.4-2  curl-7.78.0-1
               ethtool-1:5.13-1  extremetuxracer-0.8.1-1  f2fs-tools-1.14.0-2  firefox-90.0.2-1
               firefox-i18n-en-us-90.0.2-1  flameshot-git-r1382.4e406ec8-1  fmt-8.0.1-1
               garuda-common-settings-1.4.5-1  garuda-dr460nized-1.5.5-1
               garuda-fish-config-1.3.6-1  garuda-setup-assistant-1.1.0-1
               garuda-system-maintenance-1.1.3-1  gdk-pixbuf2-2.42.6-2  gnome-desktop-1:40.3-1
               gnupg-2.2.29-1  go-2:1.16.6-1  google-chrome-92.0.4515.107-1  gparted-1.3.1-1
               graphviz-2.48.0-1  gst-plugin-pipewire-1:0.3.32-1  handbrake-1.4.0-1  hwloc-2.5.0-1
               imagemagick-7.1.0.4-1  imath-3.1.1-1  intel-gmmlib-21.2.1-1
               intel-media-driver-21.2.3-1  inxi-3.3.06.1-1  jack-0.125.0-9 [removal]
               jack2-1.9.19-2  jemalloc-1:5.2.1-3  jre-openjdk-16.0.2.u7-1
               jre-openjdk-headless-16.0.2.u7-1  kvantum-qt5-0.20.1-1
               latte-dock-git-0.9.91.r143.g47702a59-1  ldb-1:2.4.0-1  lib32-curl-7.78.0-1
               lib32-libva-mesa-driver-21.1.5-1  lib32-libxfixes-6.0.0-1  lib32-mesa-21.1.5-1
               lib32-mesa-vdpau-21.1.5-1  lib32-opencl-mesa-21.1.5-1  lib32-util-linux-2.37.1-1
               lib32-vulkan-icd-loader-1.2.184-1  lib32-vulkan-intel-21.1.5-1
               lib32-vulkan-mesa-layers-21.1.5-1  lib32-vulkan-radeon-21.1.5-1
               libadwaita-1.0.0alpha.2-1  libbytesize-2.6-1  libgdm-40.1-1  libidn-1.38-1
               libjcat-0.1.8-1  libmm-glib-1.16.8-1  libmwaw-0.3.20-1  libnm-1.32.4-1
               libreoffice-fresh-7.1.5-1  libuv-1.42.0-1  libva-mesa-driver-21.1.5-1
               libva-utils-2.12.0-1  libxmlb-0.3.2-1  libxnvctrl-470.57.02-1
               linux-firmware-20210716.b7c134f-1  linux-lts-5.10.53-1  linux-lts-headers-5.10.53-1
               linux-zen-5.13.5.zen1-1  linux-zen-headers-5.13.5.zen1-1  lollypop-1.4.22-1
               mesa-21.1.5-1  mesa-vdpau-21.1.5-1  mhwd-db-garuda-git-r54.c233ab1-1
               modemmanager-1.16.8-1  mtools-1:4.0.34-1  networkmanager-1.32.4-1
               networkmanager-strongswan-1.5.2-2  nm-cloud-setup-1.32.4-1  opencl-mesa-21.1.5-1
               openfortivpn-1.17.0-1  pacman-mirrorlist-20210718-1  perl-5.34.0-2
               perl-http-message-6.33-1  pipewire-1:0.3.32-1  pipewire-media-session-1:0.3.32-1
               plasma5-applets-window-appmenu-0.7.1-1  poppler-21.07.0-3  poppler-glib-21.07.0-3
               poppler-qt5-21.07.0-3  python-more-itertools-8.8.0-1  python-pep517-0.11.0-1
               python-requests-2.26.0-1  python-setuptools-1:57.4.0-1  python-tomli-1.1.0-1
               rpcbind-1.2.6-1  skypeforlinux-stable-bin-8.74.0.152-1  starship-0.56.0-1
               strongswan-5.9.3-1  systemd-249.2-1  systemd-libs-249.2-1
               systemd-sysvcompat-249.2-1  talloc-2.3.3-1  tdb-1.4.5-1  tealdeer-1.4.1-6
               telegram-desktop-2.8.11-2  tevent-1:0.11.0-1  util-linux-2.37.1-1
               util-linux-libs-2.37.1-1  vpnc-1:0.5.3.r496.r153-2  vulkan-headers-1:1.2.185-1
               vulkan-icd-loader-1.2.185-1  vulkan-intel-21.1.5-1  vulkan-mesa-layers-21.1.5-1
               vulkan-radeon-21.1.5-1  vulkan-swrast-21.1.5-1  vulkan-tools-1.2.184-1
               webkit2gtk-2.32.3-1  zimg-3.0.2-1  zoom-5.7.4-1

Total Download Size:   1285.20 MiB
Total Installed Size:  4532.55 MiB
Net Upgrade Size:        69.43 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 jack2-1.9.19-2-x86_64 is up to date
 cfitsio-1:4.0.0-1-x86_64 is up to date
 ctemplate-2.4-2-x86_64 is up to date
 ethtool-1:5.13-1-x86_64 is up to date
 extremetuxracer-0.8.1-1-x86_64   21.2 MiB   134 KiB/s 02:42 [################################] 100%
 Total (  5/104)                1285.2 MiB  3.61 MiB/s 05:56 [################################] 100%
error: failed retrieving file 'jack2-1.9.19-2-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'cfitsio-1:4.0.0-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'ctemplate-2.4-2-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: too many errors from america.mirror.pkgbuild.com, skipping for the remainder of this transaction
error: failed retrieving file 'ethtool-1:5.13-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extremetuxracer-0.8.1-1-x86_64.pkg.tar.zst' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

 ╭─[email protected] in ~ took 7m41s
[🔴] × fixpacman
[sudo] password for vicky:
rm: cannot remove '/var/lib/pacman/db.lck': No such file or directory

SORRY.... Posted all the errors that i get after trying all suggestions from various posts in the forum. Am a noob but love Garuda and want to keep using it as my daily driver. So please help.

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Use forum search and do not post in topics after such a long time.

BTW, try

update
3 Likes