Help installing Nvidia hybrid drivers (auto install feature tried already )

Garuda noob here, coming from Ubuntu.

Fresh install just fine. Problem arises after attempting to auto install proprietary drivers for my GPU(s). It's a hybrid setup as detailed below. Would greatly appreciate any advice as to how this can be done. I must say this sticking point has derailed an otherwise great OS.

System:    Kernel: 5.13.4-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=bc0b687e-5e39-45ac-bcfd-cb16cc7c756c rw 
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=13966a07-dceb-435a-a097-312cfea0e209 loglevel=3 
Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Mini-pc System: Intel Client Systems product: NUC11PHi7 v: M26149-402 serial: <filter> 
Chassis: Intel Corporation type: 35 v: 2.0 serial: <filter> 
Mobo: Intel model: NUC11PHBi7 v: M26151-402 serial: <filter> UEFI: Intel 
v: PHTGL579.0062.2021.0430.1451 date: 04/30/2021 
CPU:       Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP arch: Tiger Lake family: 6 
model-id: 8C (140) stepping: 1 microcode: 88 cache: L2: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44851 
Speed: 846 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 846 2: 2285 3: 3678 4: 3619 5: 3599 6: 4163 
7: 4244 8: 3008 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:9a49 class-ID: 0300 
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Intel driver: nouveau v: kernel 
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300 
Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: intel,modesetting,nouveau 
alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: HDMI-1 res: 1920x1080 dpi: 77 size: 632x360mm (24.9x14.2") diag: 727mm (28.6") 
OpenGL: renderer: NV166 v: 4.3 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel v: kernel 
alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403 
Device-2: NVIDIA TU106 High Definition Audio vendor: Intel driver: snd_hda_intel v: kernel 
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403 
Sound Server-1: ALSA v: k5.13.4-zen2-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: no 
Sound Server-4: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 4000 bus-ID: 00:14.3 chip-ID: 8086:a0f0 
class-ID: 0280 
IF: wlp0s20f3 state: down mac: <filter> 
Device-2: Intel Ethernet I225-LM driver: igc v: kernel port: 3000 bus-ID: 59:00.0 chip-ID: 8086:15f2 
class-ID: 0200 
IF: enp89s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:4 chip-ID: 8087:0026 
class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 9.6 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 43.9 C scheme: GPT
Partition: ID-1: / raw-size: 431.37 GiB size: 431.37 GiB (100.00%) used: 9.6 GiB (2.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 431.37 GiB size: 431.37 GiB (100.00%) used: 9.6 GiB (2.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 431.37 GiB size: 431.37 GiB (100.00%) used: 9.6 GiB (2.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 431.37 GiB size: 431.37 GiB (100.00%) used: 9.6 GiB (2.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.13 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 31.03 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 38.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 271 Uptime: 24m wakeups: 0 Memory: 31.03 GiB used: 3.56 GiB (11.5%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1126 lib: 289 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I really hope to get this sorted and fully experience Garuda! Thanks in advance.

Can you share the specifics of the problem? What did you try and what was the result? If you receive an error message, please share the exact message you received.

1 Like

Sorry! I meant to include that too.

After "auto install" I reboot.

Then I get stuck at the very beginning of Garuda trying to boot :frowning:

Restore your previous snapshot and manually install the drivers.

I hope you understand what "proprietary" means.

1 Like

Already restored to get back into Garuda again. How does one manually install drivers exactly?

I understand it as it's usually defined. Is there something else you think I should know?

bump

still no further :frowning:

Check to see if you have fast boot enabled in bios and if it is then disable.
Then try to install auto install drivers and check for erorrs in log when installing.

1 Like

fastboot was not enabled.

I'm not comfortable using the "auto install" as it has not worked one single time so far.

I came across this post however

It's pretty much exactly what I was searching for, as it deals with hybrid graphics setups.

I was able to install nvidia drivers with

sudo pacman -S nvidia-dkms nvidia-lts nvidia-prime nvidia-utils

and lsmod | grep nvidia now shows

nvidia_modeset       1200128  32 nvidia_drm
nvidia              35328000  1947 nvidia_modeset
i2c_nvidia_gpu         16384  0
drm_kms_helper        319488  2 nvidia_drm,i915
drm                   630784  17 drm_kms_helper,nvidia,nvidia_drm,i915

I had to add "nvidia" to MODULES in /etc/mkinitcpio.conf before it would boot successfully though.

So this looks good so far yes?

Until I try installing optimus-manager, I reboot and it fails again at Loading initial ramdisk

Getting somewhere but really starting to give up on arch based setup.

I'm mean this PC is new this year, I'm kinda shocked that it is SO difficult just to get graphics sorted.

Hardware config still looks like this.

So what error do you get when you install it?

Do you have secure boot disabled?

1 Like

There is no error - it installs just fine. But it fails to boot again after restarting - just stuck at "Loading initial ramdisk"

Secure boot is not enabled.

optimus-manager should be pre-installed already if you are using a recent iso since it was included into all editions from Garuda Linux "Spotted Eagle" (210507) onwards.

What does your boot log say when it fails

1 Like

How do I check that?

look in /var/log/boot log and at which one that failed might give you a clue

1 Like

right but how do I check that if I can't boot into the OS first?

it doesn't appear to be installed on my system, less than one week old

if you are booting into it now your old logs will be there?
if not boot live usb and mount the drive to see logs.

Did you have problems with the live usb when using the nvidia drivers boot option?

1 Like

I had to boot into a timeshift backup in order to get back in.

Yes I had problems with the live usb nvidia - it wouldn't boot, so had to use open source drivers option.

I don't think I have the patience to stick with this much longer tbh. I just want the drivers installed so I can play a few games, nothing special.

And for such a highly praised distro to have basic driver problems like this isn't great really.

In Ubuntu this was done in a few clicks.

Ok?
You have your setting wrong in your bois that is what is wrong.
Check you have uefi boot enabled.
check fastboot is off
check secure boot is off and delete keys.

Then try live usb with nvidia drivers.
If it boots ok in live mode then your setting are ok?

1 Like

OK I'll try it again.