Headset not recognized in KDE

Hello,

I'm having trouble with getting my razer kraken headset recognized in Garuda after reinstalling. My previous install was Garuda Gnome, which worked perfectly. After reinstalling with KDE, I installed the openrazer meta packages (which are up to date on AUR and definitely support my headset), and the audio device shows up fine in openrazer front-end. However, the device wasn't showing up in KDE's Audio menu.

I also noticed that Pulseaudio wasn't installed. Is this package no included by default and something else is used? After installing Pulseaudio and restarting, I'm still not seeing the headset in my sinks list for pulse audio:

pacmd list-sinks | egrep -i 'index:|name:'

  • index: 0
    name: <alsa_output.pci-0000_00_1f.3.analog-stereo>

The headset DOES appear in lspci, and in openrazer, but for whatever reason, KDE / Pulseaudio aren't seeing it as an audio sink.

Is there anything I need to install beyond just the pulseaudio package?

Hi there, welcome to the community.

Which iso did you install? I mean what is it's full name?
Also see

And include the output of inxi -Faz as text.

2 Likes

it was Garuda-KDE-Dragonized, but I am traveling and don't have the exact version number. The USB drive was made about 3 weeks ago or so. Was there a bug in an ISO in the past, or something like that?

Interestingly, I've noticed that now my headset is flashing on the screen every couple minutes or so for about a second, and then flashes away and is replaced but a notification that Built-in Audio is connected.

edit: also, thank you for the warm welcome :slight_smile:

Hm, I tried following the instructions in that thread, but no luck.

From what I can tell, I DO have pipewire-media-session installed, I do have pulseaudio (manually installed, was that wrong?), and I do NOT have wireplumber installed.

Sorry for bumping but I'm still needing some help here.

Just on the off chance the kernel is a factor, I would suggest installing and testing the LTS kernel.