HDA-NVIDIA-sound-HDMI-laptops-mhwd-nvidia

Show your Garuda Desktop

Hello, install garuda gamers and although it starts it in live mode with proprietary nvidia drivers, it does not start with the nvidia drivers, I tried repeatedly but it did not start the nvidia drivers, it was probre with the variant
(garuda-dr460nized-blackarch-linux-zen-210225)
to this if the nvidia drivers worked but still I wanted the gamers to install and then install the nvidia drivers of course after solving the python-xdg conflict
reboot and everything worked except the audio

Installed drivers = video-nvidia-prime-render-offload

I require = HDA Nvidia
sound

Read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

and
:slight_smile:

1 Like
System:    Kernel: 5.11.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=fb2d727f-e05f-4b98-9cc6-0321d5263984  
rw [email protected] quiet
cryptdevice=UUID=c326af56-4403-4c40-8987-b5d399f16003:luks-c326af56-4403-4c40-8987-b5d399f16003
root=/dev/mapper/luks-c326af56-4403-4c40-8987-b5d399f16003 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=46c2ecdb-af02-44be-ad87-e6667cd2a512 loglevel=3
Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: ASUSTeK product: ROG Strix G531GT_G531GT v: 1.0 serial: <filter>  
Mobo: ASUSTeK model: G531GT v: 1.0 serial: <filter> UEFI: American Megatrends v: G531GT.307  
date: 04/28/2020  
Battery:   ID-1: BAT0 charge: 16.1 Wh (39.3%) condition: 41.0/50.5 Wh (81.2%) volts: 12.5 min: 12.5  
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging  
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 9E (158) stepping: A (10) microcode: DE cache: L2: 12 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399  
Speed: 4391 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4391 2: 4278 3: 4402 4: 4352  
5: 4400 6: 4307 7: 4340 8: 4350 9: 4350 10: 4372 11: 4302 12: 4305  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:3e9b class-ID: 0300  
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia  
v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0300  
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nvidia  
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")  
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes  
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel  
alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403  
Sound Server-1: ALSA v: k5.11.9-zen1-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.24 running: no  
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000  
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280  
IF: wlo1 state: up mac: <filter>  
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169  
v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: eno2 state: down mac: <filter>  
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8  
bus-ID: 1-14:3 chip-ID: 8087:0aaa class-ID: e001  
Report: ID: hci0 state: up address: <filter>  
Drives:    Local Storage: total: 1.04 TiB used: 37.49 GiB (3.5%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB  
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD  
serial: <filter> rev: 002C temp: 40.9 C scheme: GPT  
ID-2: /dev/sda maj-min: 8:0 vendor: A-Data model: SU800 size: 119.24 GiB block-size:  
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 7ANR  
scheme: GPT  
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB  
block-size: physical: 512 B logical: 512 B serial: <filter> scheme: MBR  
Partition: ID-1: / raw-size: 460.17 GiB size: 460.17 GiB (100.00%) used: 37.49 GiB (8.1%) fs: btrfs  
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-c326af56-4403-4c40-8987-b5d399f16003  
ID-2: /boot/efi raw-size: 785 MiB size: 783.5 MiB (99.80%) used: 700 KiB (0.1%) fs: vfat  
dev: /dev/nvme0n1p1 maj-min: 259:1  
ID-3: /home raw-size: 460.17 GiB size: 460.17 GiB (100.00%) used: 37.49 GiB (8.1%) fs: btrfs  
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-c326af56-4403-4c40-8987-b5d399f16003
ID-4: /var/log raw-size: 460.17 GiB size: 460.17 GiB (100.00%) used: 37.49 GiB (8.1%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-c326af56-4403-4c40-8987-b5d399f16003
ID-5: /var/tmp raw-size: 460.17 GiB size: 460.17 GiB (100.00%) used: 37.49 GiB (8.1%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-c326af56-4403-4c40-8987-b5d399f16003
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
ID-10: swap-10 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8
ID-11: swap-11 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9
ID-12: swap-12 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10
ID-13: swap-13 type: zram size: 650.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4300
Info:      Processes: 328 Uptime: N/A wakeups: 1 Memory: 7.62 GiB used: 1.92 GiB (25.2%) Init: systemd
v: 247 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1968 lib: 543
Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.03

You don't read.
greetings SGS

What exactly is not working?

Install and check the settings within pavucontrol as that tends to work reliably.

2 Likes

Before using mhwd to install the nvidia driver, note HDA Nvidia appeared in the plasma kde audio configuration, but after installing the drivers through mhwd, this option disappeared along with the audio through HDMI, although it gives an image through HDMI and I can open Nvidia x Server but audio was lost when in LIVE mode
garuda-dr460nized-blackarch-linux-zen-210225

everything worked together with HDMI image as sound

I notice it is caused by mhwd the GUI automatic driver installer located in system config

since before using it the audio appears although it did not give an image through HDMI

some help ?
please

So, the "HDA Nvidia" is apparently set to "Off" which leads to the obvious question: have you tried turning it "On" ?

2 Likes

At the moment I took the screenshot, the HDMI cable was disconnected, although I just connected it, it turns on automatically as the sound passes from the laptop to the external screen.


I have realized that the installer (mhwd-GUI graphical interface) used by both garuda and manjaro linux, only with different installation scripts for Nvidia is in this case the problem since when I recently installed (garudo-Linux) on my laptop it did not It recognizes any drivers as installed but really if there is a driver installed (open-source nouveau drivers) and this one if the HDMI works both image and audio although it is very bad for video games, very little FPS

But if I install the proprietary Nvidia driver (video-nvidia-prime-render-offload) it doesn't give me sound on my asus laptop through HDMI with the graphics card (geforce gtx 1650 max-q) Intel processor
and installed pavucontrol - it does not work, see HDMI sound 7.1 among others but none works

==============================================================================
En el instante en el que tome la captura de pantalla el cable HDMI estaba desconectado aunque apenas lo conecto este se enciende en automatico al igual que el sonido pasa del portatil a la pantalla externa
en el instante en el que tome la captura de pantalla el cable HDMI estaba desconectado aunque apenas lo conecto este se enciende en automatico al igual que el sonido pasa del portatil a la pantalla externa.

Me he dado cuenta de que el instalador (interfaz gráfica mhwd-GUI) utilizado tanto por garuda como por manjaro linux, solo con diferentes scripts de instalación para Nvidia es en este caso el problema ya que cuando instalé (garudo-Linux) en mi laptop no Reconoce cualquier controlador como instalado pero realmente si hay un controlador instalado (controladores nouveau de código abierto) y este si el HDMI funciona tanto en imagen como en audio aunque es muy malo para vídeo juegos, muy poco FPS

Pero si instalo el controlador propietario de Nvidia (video-nvidia-prime-render-offload), no me da sonido en mi computadora portátil asus a través de HDMI con la tarjeta gráfica (geforce gtx 1650 max-q) procesador Intel
e instalado pavucontrol - no funciona, veo sonido HDMI 7.1 entre otros pero ninguno funciona

Did you see this page on the Arch wiki?

https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#No_audio_over_HDMI

2 Likes

Lang_en

Thanks to Garuda for his assistance I could not with this error I liked garuda linux but this error does not let me use my laptop 100%

This error is also in manjaro but it is solved by putting a # in a command line in mhwd

open /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and put # in front of this line:

ACTION == "add", SUBSYSTEM == "pci", ATTR {vendor} == "0x10de", ATTR {class} == "0x040300", ATTR {remove} = "1"

resulting


#ACTION == "add", SUBSYSTEM == "pci", ATTR {vendor} == "0x10de", ATTR {class} == "0x040300", ATTR {remove} = "1"

save

Restart and with this the sound works through nvidia HDMI on my laptop

I leave this in case it helps the garuda group to correct this error but in its MHWD

-This is already in a personal way, I don't know what happens with the WINE 6.5 package that garuda uses

Try running games from an .EXE such as
battlefield V
Monster Energy Supercross 2
Sekiro: Shadows Die Twice
....

Without any execution it failed

on the contrary in manjaro with WINE 6.4 All works by clicking on the executable .EXE

  • On the other hand I liked all btfrs and sub volumes, the backup copies although this leaves pacman blocked once it is restored but it is only to delete db.lock although for someone new this can be a big problem

  • I like the integration of MANGOHUD with WINE

  • What I liked the most, new KDE PLASMA packages have taken into account

  • I liked the idea Install and use I even dare to say in LIVE mode it can be used as a hurry or I know.
    ================================================================================

Lang_es

Gracias a Garuda por su ayuda no pude con este error me gustó garuda linux pero este error no me deja usar mi laptop al 100%

Este error también está en manjaro pero se soluciona poniendo un # en una línea de comando en mhwd

abra /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules y ponga # delante de esta línea:

ACCI√ďN == "agregar", SUBSYSTEM == "pci", ATTR {proveedor} == "0x10de", ATTR {class} == "0x040300", ATTR {eliminar} = "1"

resultante


#ACCI√ďN == "agregar", SUBSYSTEM == "pci", ATTR {proveedor} == "0x10de", ATTR {class} == "0x040300", ATTR {eliminar} = "1"

salvar

Reinicie y con esto el sonido funciona a través de nvidia HDMI en mi computadora portátil

Dejo esto por si ayuda al grupo garuda a corregir este error pero en su MHWD

-Esto ya es personal, no se que pasa con el paquete WINE 6.5 que usa garuda

Intente ejecutar juegos desde un .EXE como
campo de batalla V
Monster Energy Supercross 2
Sekiro: Shadows Die Twice
....

Sin ninguna ejecución falló

al contrario en manjaro con WINE 6.4 Todo funciona haciendo clic en el ejecutable .EXE

  • Por otro lado me gustaron todos los btfrs y subvol√ļmenes, las copias de seguridad aunque esto deja a pacman bloqueado una vez que se restaure pero es solo para borrar db.lock aunque para alguien nuevo esto puede ser un gran problema

  • Me gusta la integraci√≥n de MANGOHUD con WINE

  • Lo que m√°s me gust√≥, los nuevos paquetes KDE PLASMA lo han tenido en cuenta

  • Me gust√≥ la idea de Instalar y usar, incluso me atrevo a decir que en modo LIVE se puede usar de prisa o yo que s√©.

1 Like