Hardware error while trying to boot Garuda from USB

I am getting hardware errors right after I select the boot with the open-source driver option. I burned the ISO onto the USB with etcher and I also tried Rufus but I am getting the same results. I would really appreciate it if someone could help me out.
Machine: Dell Inspiron 7567 (gaming laptop)
garuda edition: KDE dragonized edition.
I have some images to show the errors but it says new users cannot upload attachments.

Then try try nvidia drivers.

And welcome to community.


Do you mean errors about your screwdrivers? :upside_down_face:


I suspect you have Nvidia GPU yes? I also suspect you booted trying Nvidia drivers, yes?

Boot from free drivers, then install Nvidia drivers.

Search the forum, you will find this easily.


Thanks for trying to help me out, I have the issues well documented with images but I can't attach them. Here is a list of the steps I did. I created the bootable USB drive with garuda iso on it (tried Rufus too), restart from my windows 10 operating system, and then booted from the USB. The installer fires up as usual but then the only options I am getting are what is displayed in this image:

I tried both options before but I always get about 5 seconds of the loading screen with the eagle then this :

Ignore my first sentence, at first it wouldn't let me attach the images.

Yes I do, I will try to search for your solution and see if that will fix it.

Boot using open source/free drivers, then

sudo pacman -Syu



sudo dkms autoinstall

reboot and test if working nicely.

How do I get to the terminal if the hardware error is showing?

reboot and follow my last post.

alright will do

So I tried to carry out your instructions with little success. After selecting Boot with open-source drivers, there is no way to type the commands because the computer becomes unresponsive. None of the keys on my keyboard works.


and post

inxi -Fxxxza

as text!


1 Like

Seems CPU is having microcode errors. You may try googling this on Dell forums, to see if others have this problem. It seems BIOS related.

Others may know more on this.

Try a google (or other) search with

linux Dell Inspiron 7567 "mce: hardware error"

This produced quite a few hits. Some suggest that those errors are just noise, others suggest cleaning the fan/heatsink/air-vents or to try some additional boot parameters.

I saw this link from someone installing Arch - there may be some clues there. That user was using LUKS instead of btrfs, so be careful if adapting any of those suggestions for Garuda.

It will take some research/detective work on your part to solve this, unless someone here has the same device and had the same issue. It does appear that this Dell should work with linux. My Dell Inspiron 7378 (intel only graphics) happily ran linux. Good Luck.


An alternative.


pacman -Q whoogle-git
whoogle-git 0.3.1_r247.ge912b8f-4

I am taking the time to review the posting guidelines. I will start my detective work and all of your suggestions as soon as I can.

1 Like

Solution that worked for me

INTENTION: To dual boot windows 10 with garuda Linux.

System specs
  • PC: Dell Inspiron 7567
  • CPU: Intel Core i5-7300HQ
  • GPU: NVIDIA GeForce GTX 1050 Ti (4GB GDDR5)
  • DISPLAY: 15.6”, Full HD (1920 x 1080), TN
  • STORAGE: 1 TB HDD 7200rpm
  • RAM: 8GB DDR4, 2400MHz


After booting from the live USB, I was presented with two options in the boot menu.
 1.   Boot with open-source drivers
 2.   Boot allowing proprietary drivers

Choosing any of the two options above would usually present the loading 
screen for about 5 seconds and then show a black screen listed 
with `mce hardware errors`(see images in this thread). There was no way 
to select anything and the computer became unresponsive.


Somewhere throughout the process, I must have messed 
up my 8GB USB because as I was trying to research the problem,
I noticed my file explorer kept popping up as if you had just 
inserted the USB. I figured it might have gone bad so I immediately
got a 64GB from office depot and quickly burn the ISO again. I was
back to the same hardware error screen but this time I was presented 
with a mouse and after some time the installation proceeded. 


The `mce hardware errors` are still present, in fact, 
I can see them whenever I boot or shutdown the machine
 but I read somewhere that this fix is just probably passing 
kernel parameters to disable the errors. ( not a recommendation 
just stating the possible options I have seen.)

final notes:

I want to thank the authors of garuda Linux for their amazing work. I was in awe of the default appearance of the desktop. No customizations needed graphically.


So, to summarize, it was a bad USB flash drive.


Thanks, dude - another lesson learned.