Grub Rescue not working after Windows 11 update

I unfortunately have Windows 11 dual booted with Garuda Linux on my machine. Sorry for the problem with Windows but no other option is there. Many softwares doesn't support Linux and winehq is also not properly working so that's why I had to keep Windows

After updating Windows 11 recently, Garuda EFI boot option got deleted and even if I try to open from EFI file, then it enters grub rescue mode. I have tried changing prefix and root in grub rescue but I am not able to solve the problem. Please help me as early as possible.

If it would not be fixed then I will have to reinstall Garuda which will consume much time and my setup will also be lost!

Here are my GPT partitions :

Please help me to get my setup back

that's typical for windows. It likes to do a lot of random crap when it comes to the bootloader. Install it to random partitions, delete other bootloaders, etc.

Please boot the live ISO, and try to chroot into the system.

Once you have done that, try sudo grub-install /dev/<boot partition identifier> . You can find the boot partition via lsblk


Which update?
No problems here :wink:

Windows 11 22H2 from 21H1

I use Windows rarely for some softwares only. So today I used it for my work and it automatically downloaded and installed the update. Microsoft does everything without user permission which is the biggest problem of Windows hate. I hadn't turned off updates permanently that's why

Done btw! Thanks for the solution. It was so simple using Garuda Boot Repair. Got it working back!

1 Like

Try chroot from garuda-welcome or How to chroot Garuda Linux
and not forget


After reboot you must maybe change the /etc/default/grub file.

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.