Grub related help

  • Plymouth is not showing for Fedora when booting from Garuda, but not the same for Fedora grub, while booting from fedora grub, plymouth shows up

  • Garuda grub boots into rescue kernel for Fedora by default, and I have to go to its subfolder and select the kernel. Is there any other graphical method to edit the grub menu in Garuda? It seems that grub-customizer is not compatible with Garuda?

There are dozens of posts (and a statement on the Wiki) related to troubles caused by Grub-customizer, don't use it!
If you already used it, and this was done recently, I suggest you try to restore the most recent snapshot...

The reference is:
https://wiki.archlinux.org/title/GRUB
As you'll see and probably know, /boot/grub/grub.cfg is generated automatically by a variety of options in /etc/default/grub and scripts in /etc/grub.d/.
You could easily solve the problem correcting /boot/grub/grub.cfg, but problably the issue will re-appear next time you update the grub.
Checking options in /etc/default/grub and scripts in /etc/grub.d/ could be quite complex, but you can try.

3 Likes

No No :sweat_smile: I haven't used it, but I am telling you from my experience from the previous install. But it seems to work on Ubuntu and OpenSuSE and not with Fedora :thinking:

The problem with Grub-customizer is with btrfs, i.e. with Garuda and Fedora (and others of course) :slight_smile:

1 Like

But if the problem was caused by Grub-customizer used in Fedora, I really don't know how to help...

3 Likes

No, Fedora Grub is working as usual. But when I boot from Garuda grub to fedora its plymouth disappears :thinking:

You should check kernel parameters for Fedora's entry in Garuda's GRUB (by pressing E). Make sure there is splash.

I don't know 'bout GUI, but I think you can edit UUID in the boot parameters for Fedora

2 Likes

Yeah, you were right, I entered the parameters rhgb quiet quiet splash to the Fedora grub-entry by pressing E during boot and tried to add them as it was in the Garuda Linux grub-entry. And the Plymouth showed up.

But these are temporary? How will I make the edit permanent?

Are you asking how to edit the Fedora GRUB configuration?

A link to GRUB documentation has already been posted - please read it.

4 Likes

Try to give a look at the scripts in scripts in /etc/grub.d/.
Or directly into /boot/grub/grub.cfg (where it should be easier to spot the menu entries), but in this case I don't know if this will be overwritten the next time the grub will be updated.

1 Like

But it works out of the box with openSUSE, which is too btrfs

I think you can add the same in /etc/default/grub?

You may want to pardon me, but the Arch Wiki is a better source than How-To-Geek :relaxed: :wink:

4 Likes

I tried to add the parameters quiet splash rhgb to GRUB_CMDLINE_LINUX_DEFAULT
still no luck

Just adding doesn't change GRUB. You should also sudo mkinitcpio -P && sudo update-grub after that to apply changes.

1 Like

I suspect you are misunderstanding.

This is a Fedora configuration issue. You can't repair it from Garuda.
When grub os-prober discovers parallel linux installations, uses their grub command-line parameters.
You may compare:

sudo grep "linux */" /boot/grub/grub.cfg

It is declared and I assure you, it is not fully compatible with Garuda.
Because some users did not face problems yet, they may say it works.
It needs good knowledge of how grub and grub-customizer and archlinux and garuda work, to be safe to use it IMHO.

6 Likes

But plymouth shows while booting from fedora grub and fedora's /boot/grub2/grub.cfg has those parameters
Here is /etc/default/grub from fedora:

GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=Fedora
GRUB_DEFAULT=0
#GRUB_SAVEDEFAULT="true"
#GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT=console
GRUB_CMDLINE_LINUX="rhgb quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="rhgb quiet splash"
GRUB_DISABLE_RECOVERY=true
GRUB_ENABLE_BLSCFG=true
#GRUB_BACKGROUND= /usr/share/grub/backgrounds/background.png
export GRUB_COLOR_NORMAL=light-gray/black
export GRUB_COLOR_HIGHLIGHT=blue/black

Pardon me if I am wrong somewhere

1 Like

The settings in this file are common, and I don't think this could work.
My idea was rather to edit /boot/grub/grub.cfg search your Fedora menu entry and add splash in the relevant linux line.

4 Likes

Yeah that works, but the next time the grub updates, I would have to re-enter those lines.