Grub FDE Slot 0 Opened but nothing happens

Hello everyone,

I've been using garuda for about a year now and im really happy with it. I always use FDE (Full Disk Encryption) and had issues before with LUKS on Manjaro. After some update LUKS couldn't decrypt the drive for no apparent reason. It looked like it was a problem with my graphics cards driver. I distro hopped to garuda without fixing the problem. Now one year without any GRUB FDE issues i ran in to a problem. My system boots as normal prompting me to enter the password for GPT2. After I correctly entere the password, opened slot 0 appears as usual. Now at this point the text should disappear it should ask me what I want to boot into (Troubleshooting mode and stuff). This does not happen. It just gets stuck on Opened slot 0 and nothing happens afterwards.
I also run dual boot windows on a different drive (not encrypted). Since I cannot boot up my distro I can't really give you any command outputs. I keep my system up to date. I last update on the 26th or 27th of august. Any advice on how to save my distro? I have no clue how to live boot into my system and decrypting the drive.
Thanks for any advice :slight_smile:

These are my computer specs

Seems to be the upstream grub bug.
Search in forum. There are many posts about. :frowning:


I fixed it!
Well not really. It fixed itself.
I did not change anything for 10 days and now it just works and I'll take it.
Was about to do the steps from the other post but decided to try it once more and it just worked.
Now I updated garuda and hope it won't happen again.

Solved by magic or @TNE :slightly_smiling_face:

I remove your :white_check_mark: as solution.

This is not the way we handle this here and only frustrates people who search the internet for a solution, land here at your "solution" and think:

What kind of juice store is this?