Grub efi_wrap_1 not found, stuck in grub rescue

garuda-inxi:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: PCSpecialist product: Atlas Elite v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: PRIME B660-PLUS D4 v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 2212
date: 12/13/2022
CPU:
Info: model: 13th Gen Intel Core i5-13600KF bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
microcode: 0x10E
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 20 MiB desc: 6x2 MiB, 2x4 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 3839 high: 5100 min/max: 800/3841:3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 5100 2: 3500 3: 3500
4: 3500 5: 5100 6: 3500 7: 5100 8: 3500 9: 3500 10: 3500 11: 5100
12: 3500 13: 3897 14: 3500 15: 3500 16: 3500 17: 3500 18: 3500 19: 3500
20: 3500 bogomips: 139776
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2488 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 106 s-size: 824x342mm (32.44x13.46")
s-diag: 892mm (35.12")
Monitor-1: DP-2 res: 3440x1440 hz: 100 dpi: 107
size: 820x346mm (32.28x13.62") diag: 890mm (35.04") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: Intel Alder Lake-S HD Audio vendor: ASUSTeK driver: snd_hda_intel
bus-ID: 1-10.1:7 v: kernel alternate: snd_sof_pci_intel_tgl
chip-ID: 046d:0aba bus-ID: 00:1f.3 class-ID: 0300 chip-ID: 8086:7ad0
class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: Logitech PRO X Wireless Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-11:6 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Drives:
Local Storage: total: 945.83 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus
1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Blade
size: 14.32 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.43 GiB used: 1.76 GiB (11.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 46 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 353 Uptime: 10m wakeups: 0 Memory: 15.44 GiB used: 5.19 GiB
(33.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1194 libs: 295
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
System install date:     2023-07-04
Last full system update: 2023-07-04 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service

I'm stuck at grub rescue with the error efi_wrap_1 not found after a system update failed and rollback to snapshot.

I found Grub fails after update - #3 by librewish which looks like it might be the solution, but it fails:

mkdir: cannot create directory ‘/mnt’: File exists

mount: /mnt: special device /dev/sdxy does not exist. -> sda sda1 sda2 exist, but not sdxy

Anyone point me in the right direction? Have I identified this ttps://forum.garudalinux.org/t/grub-fails-after-update/78/3 is the solution correctly?

This thread (and a few others with the same error message) might help:

Use lsblk -f to determine your btrfs system partition and substitute that in place of /dev/nvme0n1p2 in this tutorial, which is more structured than the post you linked.
This applies also to determining your ESP later on.
By-the-way, you could also try the tools provided by the live USB, instead of that manual procedure.

2 Likes

Yeah, I basically winged my way through How to chroot Garuda Linux and that appears to have worked - I'm back into my system now. Have created a snapshot and going to backup some core files, then reboot and check it's all good.

garuda-update is going to re-do that failed upgrade which includes grub, so that's basically going to break again right? How do I get past this?

Hi there. I am doing the same thing right now, please look at:

I have seen this. Waiting for it to conclude, because I'm still not seeing how doing the full upgrade isn't going to brick grub again

1 Like

If after garuda-update you’re stuck, consider removing splash from your boot parameters as descrived here.

Alternatively, you can install plymouth, which will replace plymouth-git and regenerate the intramfs as described in that thread.
Most likely (we don’t have the garuda-inxi of your installed system), you should have mkinitcpio, since you’re an “old” user :slight_smile:.

2 Likes

I've installed Plymouth, and removed the splash parameter. I'll try an update but I expect it'll still cause a crash?

No, it shouldn't

1 Like
--> A problem with the NVIDIA drivers has been detected

---> Building NVIDIA DKMS module for kernel 6.4.1-arch1-1
Module nvidia 535.54.03 is not installed for kernel 6.4.1-arch1-1 (x86_64). Skipping...
Module nvidia 535.54.03 is not built for kernel 6.4.1-arch1-1 (x86_64). Skipping...
Error! Your kernel headers for kernel 6.4.1-arch1-1 cannot be found at /usr/lib/modules/6.4.1-arch1-1/build or/usr/lib/modules/6.4.1-arch1-1/source.
Please install the linux-headers-6.4.1-arch1-1 package or use the --kernelsourcedir option to tell DKMS where it's located.
---> Failed to build NVIDIA DKMS module for kernel 6.4.1-arch1-1

System updated! 🐧
Update notices:
The GRUB bootloader at /EFI/Garuda has been updated/reinstalled using 'grub-install'. If this looks correct, no further action has to be taken.

So, this is a different problem.
In my opinion, you could try installing the lts kernel for a while (and boot selecting it in the grub menu, advanced options):

sudo pacman -S linux-lts linux-lts-headers

I’ve seen similar issues lately also solved by moving to the mainline kernel, but I’d start with the LTS.
You could also start as suggested by the error message:

sudo pacman -S linux-headers

but i’m skeptical… you should already have that package.

2 Likes

I’ve done this but it’s not clear at the grub menu what to select. There’s now two Garuda Linux options, one has on nvme0np2 and the other doesn’t. I selected the first option as usual and my system is booting fine, no updates pending on pacman -Syu, just the following:

error: failed retrieving file 'core.db' from lysakermoen.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'extra.db' from lysakermoen.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'multilib.db' from lysakermoen.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds

Checked GreenWithEnvy, NVIDIA drivers are detected (535.54.03) and card is working fine, not sure what that previous error was.

The double grub entry is due to the snapshot you manually created earlier (or maybe to the snapshot which is created when you restore a previous snapshot).
When everything will be hopefully fixed, you will be able to get rid of those additional snapshots and the double grub entry.
The listed "errors" are only warnings: normally the system has selected a mirror other than the failed lysakermoen.com and proceeded. This could be a temporary mirror issue, or an update of the mirrorlists with garuda-update should fix this.
The lts kernel should be in a grub sub-menu called Advanced Options.

2 Likes

As filo says once you are done fixing your other problems you can fix this as well following this post.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.