Grub doesn't open to anything

Garuda's grub stops at grub_ and _ just blinks. Doesn't take keyboard input. I can still boot into garuda using manjaro's grub. So I can fix it from inside garuda.

from garuda boot

do this

sudo grub-install
sudo update-grub

Cannot find efi directory

you seems to have installed multiple systems in both uefi and bios mode
so either reinstall all in uefi or in legacy bios

1 Like

It was working before normally. maybe a command to set directory of boot manually. It's /boot

test -d /sys/firmware/efi && echo UEFI || echo BIOS
efibootmgr
efibootmgr -v
1 Like
itest -d /sys/firmware/efi && echo UEFI || echo BIOS                                            ─╯
UEFI

efibootmgr                                                                                     ─╯
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0003,0000,0004,0005
Boot0000* Windows Boot Manager
Boot0001* Manjaro
Boot0003* WDC WD10EZEX-08WN4A0 
Boot0004* CT500P1SSD8
Boot0005* Seagate Expansion 0708
efibootmgr -v                                                                                  ─╯
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0003,0000,0004,0005
Boot0000* Windows Boot Manager	HD(2,GPT,a7457394-c4c5-48cc-89cf- 51db6e891a0d,0xe1800,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* Manjaro	HD(2,GPT,a7457394-c4c5-48cc-89cf-51db6e891a0d,0xe1800,0x31800)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0003* WDC WD10EZEX-08WN4A0	BBS(HD,,0x0)..BO
Boot0004* CT500P1SSD8	BBS(HD,,0x0)..BO
Boot0005* Seagate Expansion 0708	BBS(HD,,0x0)..BO

Change boot order with

efibootmgr - manipulate the UEFI Boot Manager

man efibootmgr

but no Garuda in your list, use Manjaro then. :slight_smile:

I think 3rd one is garuda. But when I use garudas grub. The issue is that it just stays at grub_ and blinks there.

Like librewish wrote.
"you seems to have installed multiple systems in both uefi and bios mode
so either reinstall all in uefi or in legacy bios"
Install garuda in uefi.

1 Like

ok. i will do that when even manjaro's grub doesnt boot into garuda. for now ill let it be how it is.

1 Like

What is the difference between then and now? What changes have you made to your system?

(Things don't just "stop working" for no reason.)

2 Likes

It happened maybe after a grub or kernel upgrade. Definitely happened after a big update.

We should checkout whether this is a bug in packaging or other.
Please provide more info, booted your Garuda:

findmnt  --real -A
grep "/" /etc/fstab
lsblk -f
grep -E "grub|btrfs| filesystem " /var/log/pacman.log | tail
pacman -Qs "grub|btrfs" | grep ^local
pacman -Q filesystem
3 Likes

findmnt --real -A ─╯
TARGET SOURCE FSTYPE OPTIONS
/ /dev/nvme0n1p5 ext4 rw,noatime
β”œβ”€/run/user/1000/doc portal fuse.port rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
β”œβ”€/run/media/pupperemeritus/Seagate Expansion Drive
β”‚ /dev/sdb1 fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,defau
β”œβ”€/snap/core18/1932 /dev/loop1 squashfs ro,nodev,relatime
β”œβ”€/snap/orchis-themes/1 /dev/loop2 squashfs ro,nodev,relatime
β”œβ”€/snap/snapd/9721 /dev/loop0 squashfs ro,nodev,relatime
└─/snap/core20/634 /dev/loop3 squashfs ro,nodev,relatime

/etc/fstab: static file system information.
UUID=4f6fdcfa-53f2-4eaa-b404-0bd0bfa378cb / ext4 defaults,noatime 0 1

AME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
loop0 squash 4.0 0 100% /snap/snap
loop1 squash 4.0 0 100% /snap/core
loop2 squash 4.0 0 100% /snap/orch
loop3 squash 4.0 0 100% /snap/core
sda
β”œβ”€sda1
β”‚ ntfs 8C4A26974A267DD8
β”œβ”€sda2
β”‚ vfat FAT32 5C3E-EB55
β”œβ”€sda3
β”‚
β”œβ”€sda4
β”‚ ntfs 90A04131A0411EDA
β”œβ”€sda5
β”‚ ntfs Games 3E8A82A78A825AF3
β”œβ”€sda6
β”‚ ntfs Media 88A4A1CEA4A1BF56
└─sda7
ntfs Games 2 2E3AA7313AA6F54D
sdb
└─sdb1
ntfs Seagate Expansion Drive
B674C4EA74C4AF05 303.9G 84% /run/media
zram0 [SWAP]
zram1 [SWAP]
zram2 [SWAP]
zram3 [SWAP]
zram4 [SWAP]
zram5 [SWAP]
zram6 [SWAP]
zram7 [SWAP]
zram8 [SWAP]
zram9 [SWAP]
zram10
[SWAP]
zram11
[SWAP]
nvme0n1
β”‚
β”œβ”€nvme0n1p1
β”‚
β”œβ”€nvme0n1p2
β”‚ ntfs New Volume 3A60BA9F60BA6175
β”œβ”€nvme0n1p3
β”‚ ext4 1.0 8f19169f-5841-4226-8eba-328ba3b01b83
β”œβ”€nvme0n1p4
β”‚ swap 1 ca128974-163e-48d5-869a-fde2f887a0bd [SWAP]
└─nvme0n1p5
ext4 1.0 4f6fdcfa-53f2-4eaa-b404-0bd0bfa378cb 87.4G 47% /

2020-11-24T11:56:02+0530] [ALPM-SCRIPTLET] If you think an error has occurred , please file a bug report at " https://github.com/Antynea/grub-btrfs "
[2020-11-24T11:56:03+0530] [ALPM-SCRIPTLET] /usr/bin/grub-probe: warning: unknown device type nvme0n1.
[2020-11-24T11:56:04+0530] [ALPM-SCRIPTLET] /etc/default/grub-btrfs/config.pacnew
[2020-11-24T11:56:49+0530] [ALPM-SCRIPTLET] /etc/default/grub-btrfs/config.pacnew
[2020-11-24T13:30:13+0530] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2020-11-24T13:30:31+0530] [ALPM-SCRIPTLET] Root partition isn't a btrfs filesystem.
[2020-11-24T13:30:31+0530] [ALPM-SCRIPTLET] This script only supports snapshots of the btrfs filesystem.
[2020-11-24T13:30:31+0530] [ALPM-SCRIPTLET] If you think an error has occurred , please file a bug report at " https://github.com/Antynea/grub-btrfs "
[2020-11-24T13:30:31+0530] [ALPM-SCRIPTLET] /usr/bin/grub-probe: warning: unknown device type nvme0n1.
[2020-11-24T13:30:33+0530] [ALPM-SCRIPTLET] /etc/default/grub-btrfs/config.pacnew

local/btrfs-progs 5.9-1
local/garuda-boot-repair-git r19.582fff3-1 (garuda-git)
local/grub 2:2.04-8
local/grub-btrfs 4.7.1-1
local/grub-garuda 2.04-11
local/grub-theme-garuda r16.2df2516-1
local/python-markdown 3.3.3-1
local/update-grub 0.0.1-7

filesystem 2020.09.03-1

It seems you have not a btrfs partition scheme. Can Garuda tools do this? If so, I am amazed, although ... it fails :rofl:

Have you done a custom installation of Garuda? How?
If you had installed normally with Garuda ISO, I have to ask Garuda devs to checkout this case.

Maybe some issue with btrfs?

Anyway, post

cat /etc/fstab
2 Likes

Ha ha, you don't miss a thing @petsam . Nice to have you helping out again my friend.

This would appear to be one of those cases where "you broke it, you bought it" applies. :rofl:

2 Likes

Just as a side note - one of my Garuda setups is running on ext4 - and was installed that way from the then current Garuda ISO. My current one is btrfs - and I fixed the propblem that caused me to switch to ext4 by instead disabling grub's os-prober...

i wasnt able to install bootloader when installing using btrfs. weird as it is but yeah. i had to change to ext4


UUID=4f6fdcfa-53f2-4eaa-b404-0bd0bfa378cb / ext4 defaults,noatime 0 1
UUID=ca128974-163e-48d5-869a-fde2f887a0bd swap swap defaults,noatime 0 0