Grub doesn't boot into last selected OS

I have the necessary lines in my /etc/default/grub:

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved
GRUB_DISABLE_OS_PROBER=false

I am using garuda sway. My hardware should be fine because I could get this to work on another arch based distro before.

After making the changes in /etc/default/grub, run:

sudo update-grub
1 Like

yeah i forgot to mention. I did that too. but didnt work : ( Is there something else that could be overwriting my grub script?

EDIT: I checked the arch wiki GRUB/Tips and tricks - ArchWiki

They said that it wont work if /boot is btfrs. I know garuda is btrfs out of the box. Is there a way to either disable btfrs or get this default grub thing to work with btrfs? I will keep hunting for solutions in the meantime while I wait for a response here.

Unfortunately, it is a well-known and long-standing issue, and unfortunately a distro cannot take charge, in my opinion, of changes to a complex and critical package such as grub...

2 Likes

Okay understood. Thank you.

1 Like

But if grub does not work as expected, you have to tell the grub developers.

4 Likes

true. And thanks for the link

1 Like