GRUB Completely Damaged

I can not go into even get GRUB at all. GRUB Does NOT even show after selecting to boot. If I choose it to boot manually also it restarts and I end up at MSI BIOS page. It is shown in my MSI BIOS as Garuda like usual No change. It is the primary bootloader. The think happened after some major update around 27 August 2022.

I run dual boot with Win 10 on same disk. But the thing is I have not even started Windows 10 AT ALL for atleast 30 days. I didn't update BIOS also before the problem or anything that can remotely affect it. Turned off my pc as regular and now even GRUB gone. So it definitely has to do with some Grub update or some update or gaurda-update.

I can boot into live USB drive and try all the GRUB boot repairs from GUI of Boot repairs but nothing seems to repair the GRUB. also detecting the EFI bootloader at initial GRUB Page from USB does detect it but choosing it again causes restart it into BIOS.

Older garuda-inxi(can not boot now obviously)
Please help my entire system is broken!!!!!!!
Thank you to everyone for reading and helping!!

System:
Kernel: 5.18.11-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
v: 12.1.0 parameters: pti=on page_alloc.shuffle=1
BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=10b3e5d1-0274-4dc2-aaa2-ae6daa1710d0 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 amdgpu.dc=0
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH (MS-7A38) v: 4.0
serial: <filter> UEFI: American Megatrends v: M.C0 
CPU:
Info: model: AMD Ryzen 5 1600 socket: AM4 bits: 64 type: MT MCP arch: Zen
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3343 high: 3400 min/max: N/A base/boost: 3400/3700
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3400 2: 3400 3: 3400 4: 3400
5: 3400 6: 3400 7: 2721 8: 3400 9: 3400 10: 3400 11: 3400 12: 3400
bogomips: 81626
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire driver: amdgpu v: kernel arch: GCN 4 process: GF 14nm
built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2 bus-ID: 29:00.0
chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung S22E360
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.46 5.18.11-hardened1-1-hardened)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.18.11-hardened1-1-hardened running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-9:2 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.36 TiB used: 56.25 GiB (4.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P1SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P3CR010
temp: 44.9 C scheme: GPT
SMART: yes health: PASSED on: 316d 2h cycles: 3,357
read-units: 46,447,210 [23.7 TB] written-units: 40,472,303 [20.7 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00MFCA0 family: Blue size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: 1A01 temp: 30 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 322d 21h cycles: 3406
Partition:
ID-1: / raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.5 MiB (26.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/log raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 45.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1682
Info:
Processes: 331 Uptime: 1m wakeups: 0 Memory: 15.58 GiB
used: 2.08 GiB (13.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1721
lib: 430 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-05-25
Last full system update: 2022-07-18
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:            dev-binderfs.mount anbox-container-manager.service

I've got the same problem on a lenovo yoga 20c0003smd and a dell optiplex 7010. I've tried booting into Garuda KDE live, used the repair boot software (not working) then chroot grub-config and grub-install (not-working) :frowning:

For other user it works.

???

grub-install, update-grub, garuda-update work here for me.

Maybe try the EnOS repair guide.

1 Like

Please, open new thread, if needed and do not cross post your problem.

I finally got my laptop to boot into Garuda. I downloaded the Garuda Xfce iso instead of Garuda KDE Dr460nized iso and usb live booted into Garuda. Used the same procedure by starting the Garuda Grub Repair tool, then selecting the uefi partition and second selecting the root partition and then install. Now i'm able to boot, but grub is now extremely slow loading the uefi boot menu (Dr460nized theme) - but it boots :slight_smile: .
I'll try the same procedure on my Dell workstation, and post the results.

For me, none of the solutions worked until i downloaded the latest garuda dragonized build (i think 8.22) and flashed it onto my usb drive, and then perfomed a garuda-update inside the live environment before doing the chroot.

I cannot comprehend why this worked, or why none of the other solutions worked since i was doing the same exact thing, but it worked with the update.

1 Like

I will try it. Thanks

So you didn't lose any of your data or configuration or installed packages?
Then I will definitely try this
Thanks for help

not booting and being utterly obliterated are two completely different things :wink:

Linux doesn't self-destruct when grub breaks!

1 Like

But if I can't recover all my data and configs and package if I can't boot into the environment. It is NOT full disk encryption

I'm gonna start recommending rEFInd to everybody unless @SGS or some other garuda team member wants to stop me

1 Like

Thank You everyone. I tried the chroot method and repair for GUI boot repair options from a new version and it works.

(Please mark this topic as solved if you think it is)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.