GRUB bootloader overrided by Windows Bootloader in Dual Boot System

I installed Garuda Linux KDE Dragonized in a Dual boot system with my windows (pre-installed). But ever since the windows update the windows bootloader has overridden the GRUB boot loader and it automatically boots into windows every time I open my laptop.
How do I repair the bootloader so that it once again opens the grub screen first.
(PS: I have tried changing the boot order in the BIOS as well as updating GRUB bootloader but these methods didnt work)

Hi there, welcome.
Try to chroot from a live USB and reinstall the grub

4 Likes

Hi there

Check your BIOS settings if the secure boot option has been enabled after windows update.
Disable secure boot if enabled and reboot. :

Then either your BIOS is faulty, or Secure Boot is re-enabled.

You didn't say clearly that you booted in the installed system. How did you do it?
You should be able to boot to the installed Garuda, using BIOS Quick Boot menu (read user manual to find the key you need to press on boot).
When you get into garuda, use efibootmgr to change boot order, or fix entries. (man efibootmgr).

3 Likes

That's exactly why dualbooting is not supported.

4 Likes