Grub boot menu gone

Hello all, Currently I have an issue where i cannot boot into my Grub menu.
Its simply gone.

Currently I am running the live USB to trouble shoot an bring it back up.

CH root fix did not help.

I tried the garuda boot options and garuda boot repair and it didnt help

The drop down menus show nothing and give no options to be selected.

CHroot trough terminal is inaccessible at the sudo mount commmand it says its already mounter
and when i run the fix it simply fails

running the ch root from the assistant menu i ran all through to grub install target command and it gives me efi boot manager failed tto register boot entry.

UEFI shows no bootable options for linux.

Live usb though shows the installation is still there

The windows boot manager is present. just not the GRUb menu

System:
Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 coexit lang=en_US11.1.0
keytable=us tz=UTC misobasedir=garudax86_64
misolabel=GARUDA_GNOME_WHITETAILEDEAGLE quiet systemd.show_status=1
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: MSI model: X370 GAMING PLUS (MS-7A33) v: 3.0
serial: UEFI-[Legacy]: American Megatrends v: 5.JP
date: 11/19/2019
CPU:
Info: model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen
family: 0x17 (23) model-id: 1 stepping: 1 microcode: 0x8001138
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 1760 high: 3200 min/max: 1550/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2048 2: 1345
3: 1361 4: 1336 5: 1277 6: 1276 7: 2552 8: 3156 9: 1508 10: 1349 11: 1310
12: 1329 13: 1280 14: 1278 15: 2563 16: 3200 bogomips: 95985
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus-ID: 2e:00.0
chip-ID: 1002:67df class-ID: 0300
Device-2: Oculus VR Rift CV1 Sensor type: USB driver: uvcvideo
bus-ID: 1-12:4 chip-ID: 2833:0211 class-ID: ef00 serial:
Device-3: Oculus VR Rift CV1 Sensor type: USB driver: uvcvideo
bus-ID: 4-2:2 chip-ID: 2833:0211 class-ID: ef00 serial:
Display: x11 server: [X.Org](http://X.Org) 1.21.1.2 compositor: gnome-shell driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2")
s-diag: 1055mm (41.5")
Monitor-1: DisplayPort-1 res: 1920x1080 hz: 60 dpi: 90
size: 544x303mm (21.4x11.9") diag: 623mm (24.5")
Monitor-2: HDMI-A-1 res: 1920x1080 hz: 60 dpi: 85
size: 575x323mm (22.6x12.7") diag: 660mm (26")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus-ID: 2e:00.1
chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 30:00.3 chip-ID: 1022:1457
class-ID: 0403
Device-3: Oculus VR Rift CV1 Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-13.2:8
chip-ID: 2833:0330 class-ID: 0300 serial:
Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 29:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp41s0 state: down mac:
Device-2: TP-Link TL-WN722N v2/v3 [Realtek RTL8188EUS] type: USB
driver: r8188eu bus-ID: 1-1:9 chip-ID: 2357:010c class-ID: 0000
serial:
IF: wlp3s0f0u1 state: up mac:
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Drives:
Local Storage: total: 951.88 GiB used: 13.85 GiB (1.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37960G
size: 894.25 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 62B3 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 57.62 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.63 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 38.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1823
Info:
Processes: 395 Uptime: 6h 21m wakeups: 8 Memory: 15.63 GiB
used: 3.91 GiB (25.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1108 lib: 298 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.11
McFly: Importing shell history for the first time. This may take a minute or two...done.

@Lancer669 Please read

In this post, reinstalling grub via chroot is described as a solution:

Edit: sorry, I re-read your post and I see you already mentioned you tried that.

Have you tried turning off legacy boot in the BIOS?

1 Like

I have, before i came ti the live usb, i checked the complete uefi settings. Tried uefi +legacy checked uefi checked secure boot boot sequence.
:smiling_face_with_tear:
I would really like to save this install. But if nothing can be done...

Could you please chroot again and provide the outputs of:
cat /etc/fstab
lsblk -f
to check if everything is OK with your EFI system partition.


Unfortunately I am unable to copy it from the terminal.

The ESP seems to be OK to me... but there is still something unclear from the initial post on what is failing and how, when you try to chroot.
Please execute the following steps from a terminal without trying to chroot with the button (that might be a reason why the mount was failing):

lsblk -f

Careful, -f not /f, then check what is your btrfs partition, e.g. /dev/sda2 in the following. Same for the efi system partition, e.g. /dev/sda1 in the following. Adjust as needed.

sudo mkdir -p /mnt/broken
sudo mount /dev/sda5 /mnt/broken
sudo garuda-chroot /mnt/broken/@
mount /dev/sda1 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub

Please provide all input and outputs as text. The live USB should normally have a internet connection, so you can enter the forum from there, copy and paste.

PS: Check also in the BIOS that also fast boot is disabled, not only secure boot.

3 Likes

Thank you for your time here is the lsblk output

< [email protected] in ~ as 🧙 took 46ms
 λ lsblk -f
NAME FSTYPE FSVER LABEL                  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
     squash 4.0                                                                     0   100% /run/miso/sfs/livefs
loop1
     squash 4.0                                                                     0   100% /run/miso/sfs/mhwdfs
loop2
     squash 4.0                                                                     0   100% /run/miso/sfs/desktopfs
loop3
     squash 4.0                                                                     0   100% /run/miso/sfs/rootfs
sda                                                                                          
├─sda1
│    vfat   FAT32                        BACE-E359                              58.2M    39% /mnt/boot/efi
├─sda2
│                                                                                            
├─sda3
│    ntfs                                56C6D3B2C6D3909B                                    
├─sda4
│    ntfs         New Volume             3050652D5064FACC                                    
├─sda5
│    btrfs                               adfb05d6-a810-45dc-a149-7f1b4d033ab2  108.6G    11% /mnt/mnt
│                                                                                            /mnt/var/tmp
│                                                                                            /mnt/var/log
│                                                                                            /mnt/var/cache
│                                                                                            /mnt/srv
│                                                                                            /mnt/root
│                                                                                            /mnt/home
│                                                                                            /mnt
└─sda6
     ntfs                                98A41A95A41A764A                                    
sdb  iso966 Jolie GARUDA_GNOME_WHITETAILEDEAGLE
│                                        2022-01-01-19-15-23-00                     0   100% /run/miso/bootmnt
├─sdb1
│    iso966 Jolie GARUDA_GNOME_WHITETAILEDEAGLE
│                                        2022-01-01-19-15-23-00                              
└─sdb2
     vfat   FAT12 MISO_EFI               5266-0FB3                                           
zram0
                                                                                             [SWAP]

>

And the following

< [email protected] in ~ as 🧙 took 11ms
 λ sudo mkdir -p /mnt/broken
   sudo mount /dev/sda2 /mnt/broken
   sudo garuda-chroot /mnt/broken/@
   mount /dev/sda1 /boot/efi
   grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
   update-grub
mount: /mnt/broken: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error.
==> ERROR: Can't create chroot on non-directory /mnt/broken/@
mount: /boot/efi: mount point does not exist.
Installing for x86_64-efi platform.
grub-install: error: failed to get canonical path of `/boot/grub'.
grub-mkconfig: You must run this as root

Im an idiot i need to adjust the commands first, and identify the correct sda

You should use /dev/sda5 instead of /dev/sda2

1 Like

Yea i just noticed as I posted XD apologies

sh-5.1# ^[[200~ sudo mkdir -p /mnt/broken
sh: $'\E[200~': command not found
sh-5.1#        sudo mount /dev/sda2 /mnt/broken
mount: /mnt/broken: mount point does not exist.
sh-5.1#        sudo garuda-chroot /mnt/broken/@
sudo: garuda-chroot: command not found
sh-5.1#        mount /dev/sda1 /boot/efi
sh-5.1#        grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.

EFI variables are not supported on this system.
EFI variables are not supported on this system.
grub-install: error: efibootmgr failed to register the boot entry: No such file or directory.
sh-5.1#        update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
Detecting snapshots ...
Found snapshot: 2022-01-20 14:34:26 | @/.snapshots/30/snapshot | post | botan fakeroot garuda-update libnma power-profiles-daemon qt5-base qt5-w |
Found snapshot: 2022-01-20 14:34:21 | @/.snapshots/29/snapshot | pre  | /usr/bin/pamac-daemon                                                    |
Found snapshot: 2022-01-19 19:44:02 | @/.snapshots/28/snapshot | post | alsa-card-profiles archlinux-keyring gnome-control-center gnome-settings |
Found snapshot: 2022-01-19 19:43:46 | @/.snapshots/27/snapshot | pre  | pacman -Syu                                                              |
Found snapshot: 2022-01-18 19:32:25 | @/.snapshots/26/snapshot | post | nextcloud-client qt5-graphicaleffects qt5-location qt5-quickcontrols2 qt |
Found snapshot: 2022-01-18 19:32:23 | @/.snapshots/25/snapshot | pre  | /usr/bin/pamac-daemon                                                    |
Found snapshot: 2022-01-18 19:28:03 | @/.snapshots/24/snapshot | post | c-ares code electron13 ripgrep                                           |
Found snapshot: 2022-01-18 19:28:00 | @/.snapshots/23/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-01-18 19:27:34 | @/.snapshots/22/snapshot | post | godot libwslay mbedtls miniupnpc                                         |
Found snapshot: 2022-01-18 19:27:32 | @/.snapshots/21/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.k6eCeiMe8x .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
sh-5.1# ~
sh: /root: Is a directory 

I hope this is correct now

No, please, the text above must be executed from a "normal" terminal session in the live USB, not after chrooting.
Exit from chroot screen and reboot from the live ISO, then re-execute the steps from a terminal (do not chroot, that step is done with those steps).

1 Like

mount: /mnt/broken: /dev/sda5 already mounted on /mnt.
sh-5.1#
This is the only thing that prints out after inserting

sudo mkdir -p /mnt/broken
sudo mount /dev/sda5 /mnt/broken
sudo garuda-chroot /mnt/broken/@
mount /dev/sda1 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub

Time to read again

It's getting more and more confusing. :slight_smile:
If you're still in chroot type exit, to return to the normal USB terminal, then
sudo umount /dev/sda5
Then try to repeat, starting from sudo mount /dev/sda5 /mnt/broken ( /mnt/broken should already exist) providing input and outputs line by line (not all together).

1 Like

I swear im not in ch root.

Im in the base Terminal. I also restarted the live usb, in and started only the terminal.

ok, no prob, I was mislead by sh-5.1#, which is normally displayed in chroot.

1 Like

That would be a remnant of an edit.
My monitors are inverted so i mightve dragged it trying to go between monitors

I just noticed this:

Even more, I'd try again to sudo umount /dev/sda5 and repeat from sudo mount /dev/sda5 /mnt/broken (if /mnt/broken already exists), line by line (to get any possible error message).
The terminal prompt should be initially something like [email protected], e.g.:

[email protected] in ~ took NNms
 ╰─λ sudo mkdir -p /mnt/broken

 ╭─[email protected] in ~ took NNms
 ╰─λ sudo mount /dev/sda5 /mnt/broken

 ╭─[email protected] in ~ took NNms
 ╰─λ sudo garuda-chroot /mnt/broken/@

sh-5.1#

i.e. sh-5.1# only after garuda-chroot.

 [email protected] in ~ as 🧙 took 19ms
[🔴] × sudo umount /dev/sda5
umount: /mnt/broken: target is busy.

 [email protected] in ~ as 🧙 took 15ms
[🔴] × 

At this point, I am willing to stop taking up your time. Either I am not doing it right, being a fresh user and simply reinstall. if that would be a better option ?