GPU Timeout on vulkan

I have 3 installs on my pc, namely garuda xfce4. Arch with xfc4 and windows. garuda and arch don't work with war thunder

System:
  Kernel: 5.15.6-225-tkg-pds x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: intel_pstate=passive BOOT_IMAGE=/boot/vmlinuz-linux515-tkg-pds
  root=/dev/mapper/vg-root rw
  cryptkey=rootfs:/root/secrets/crypto_keyfile.bin
  cryptdevice=UUID=ec878cd1-986a-4eaf-9f56-ea411b2aea49:cryptlvm
  root=/dev/vg/root quiet splash vt.global_cursor_default=0 loglevel=3
  cryptkey=rootfs:/root/secrets/crypto_keyfile.bin
  cryptdevice=UUID=ec878cd1-986a-4eaf-9f56-ea411b2aea49:cryptlvm
  root=/dev/vg/root radeon.si_support=0 amdgpu.si_support=1
  radeon.cik_support=0 amdgpu.cik_support=1
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
  vt: 2 dm: GDM 41.0 Distro: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 80TJ v: Lenovo ideapad 110-15ACL
  serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 110-15ACL
  serial: <superuser required>
  Mobo: LENOVO model: Nano 5A8 v: SDK0J40679 WIN
  serial: <superuser required> UEFI: Lenovo v: 1QCN32WW date: 08/18/2016
Battery:
  ID-1: BATT charge: 1.3 Wh (100.0%) condition: 1.3/23.8 Wh (5.4%)
  volts: 12.2 min: 10.8 model: LENOVO LCFC type: Unknown serial: <filter>
  status: Full
CPU:
  Info: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics
  bits: 64 type: MCP arch: Puma family: 16 (22) model-id: 30 (48)
  stepping: 1 microcode: 7030105 cache: L1: 256 KiB L2: 8 MiB
  flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 17568
  Speed: 1224 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz):
  1: 2000 2: 1586 3: 1523 4: 1860
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo
  driver: amdgpu v: kernel alternate: radeon bus-ID: 00:01.0
  chip-ID: 1002:9851 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 /
  Radeon 520 Mobile]
  vendor: Lenovo driver: amdgpu v: kernel alternate: radeon bus-ID: 01:00.0
  chip-ID: 1002:6660 class-ID: 0380
  Device-3: Azurewave EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.2:4
  chip-ID: 13d3:a745 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.1 compositor: picom v: git-dac85 driver:
  loaded: modesetting unloaded: vesa alternate: ati,fbdev display-ID: :0.0
  screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  OpenGL: renderer: AMD KABINI (DRM 3.42.0 5.15.6-225-tkg-pds LLVM 13.0.0)
  v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel
  bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Sound Server-1: ALSA v: k5.15.6-225-tkg-pds running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  vendor: Lenovo driver: ath10k_pci v: kernel bus-ID: 02:00.0
  chip-ID: 168c:0042 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
  driver: r8169 v: kernel port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8136
  class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: N/A type: USB driver: btusb v: 0.8 bus-ID: 2-1.1:3
  chip-ID: 0cf3:e360 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: disabled
  rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 223.58 GiB used: 32.28 GiB (14.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
  model: WDS240G2G0A-00JH30 size: 223.58 GiB block-size: physical: 512 B
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
  scheme: GPT
Partition:
  ID-1: / raw-size: 71.65 GiB size: 69.97 GiB (97.66%)
  used: 32.28 GiB (46.1%) fs: ext4 dev: /dev/dm-2 maj-min: 254:2
  mapped: vg-root
Swap:
  Kernel: swappiness: 20 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/dm-1 maj-min: 254:1 mapped: vg-swap
Sensors:
  System Temperatures: cpu: 69.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 50.0 C device: amdgpu temp: 69.0 C
Info:
  Processes: 259 Uptime: 1h 28m wakeups: 1 Memory: 6.69 GiB
  used: 4.2 GiB (62.8%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 824 pacman: 820 lib: 267 flatpak: 4
  Shell: fish v: 3.3.1 running-in: alacritty inxi: 3.3.09

I can't start war thunder from my laptop whenever i try the game starts up and instant freeze i need to reboot my pc to use it again. I have a supported vulkan card on GCN 1.0 and war thunder runs well on my dualboot os(windows,......sorry if i disappoint someone)

ls /usr/share/vulkan/icd.d/
radeon_icd.x86_64.json

running vulkaninfo doesnt give any error and posts normal output

THe error i receive is

Vulkan error: GPU timeout

Your sys info shows hybrid GPU's. I'm guessing you are not launching on the discrete GPU that actually supports Vulkan. I'd be more detailed but I've never touched AMD hybrids and so I don't know what tools are used to switch between the low power and high power. However that would be your research point, how to switch/choose your GPU on AMD hybrids.

1 Like

Umm thats a intersting think because i am not sure if its a hybrid my specs were a amd a8-7410 with the R5 apu and what i think my discrete gpu is a R5 M430 so i feel like they are the same?

Nope look at your output.

Graphics:
Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo
driver: amdgpu v: kernel alternate: radeon bus-ID: 00:01.0
chip-ID: 1002:9851 class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 /
Radeon 520 Mobile]

Sure they're both AMD where most hyrids are say Intel/AMD or Intel/nVidia but it's still a hybrid.

I got curious about this and tried to do some digging but didn't find much (great I know... :frowning: ). Few things saying it should be auto switching since one just passes the framebuffer so either I'm totally off the mark and you shouldn't have to do anything or the amdgpu driver doesn't support vulkan, though it should from what I read. Perhaps I'll just shut the hell up heh.

There seems to be a ton of other AMD mobile i.e. hybrid users on here so hopefully someone with more hands experience on can chime in.

1 Like
lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] (rev 45)

This is confusing

> glxinfo | grep "OpenGL renderer"
OpenGL renderer string: AMD KABINI (DRM 3.42.0, 5.15.6-225-tkg-pds, LLVM 13.0.0)
[21:09:29] [email protected] /home/arnav/WarThunder
> xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x52 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 2 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:00:01.0
Provider 1: id: 0x79 cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 0 outputs: 0 associated providers: 1 name:AMD Radeon R5 M330 @ pci:0000:01:00.0

It does.
It's the Radeon that doesn't ... which is why folks like me on early GCN prefer amdgpu over radeon usually (along with other reasons).

Yeah your --providers also shows the hybrid. Though this is another area where I'm kinda useless. I spent a lot of time trying to learn the very new --providers bit with xrandr when I found out all the DE's had broken multi XScreen/GPU support but the docs are VAGUE to say the least and the syntax was just added.

Like I said - it should ;p

#GCN1.0

anyways. LSPCI doesn't seem to detect my 2nd GPU but xrandr does, interesting

I was just clearing that up to avoid folks wasting research effort.
inb4.. turns out I'm wrong (which I'm not)

Heh...yeah I went and read to make sure because I had that do both or just one (radeon/amdgpu) support it. My AMD GPU stuff is a tad sketch since I bailed on them years ago.

I wonder if that's because (if what I read was right) one is just passing FB so it might be obscured in some cases behind the initial one passing le data. Or because the other one is completely shut off so it's hidden from probing. I skimmed a lot of things about it but it's all kinda vague in its own way about just how "completely powered off" the discrete GPU is once it's not used.

The important thing is we know it's there...it's just how do you switch to it and will that jive with that the vulkan bits want to use so your game will fire up and you can commit murder in a big steel bucket...flying bucket, floating bucket, treaded bucket :wink: SO MANY BUCKETS!

Totally off-topic and probably not as amusing to you yanks who've never had good comedy, but it's funny to me.

1 Like

First off I'm not a Yank nor is @regularCoder ;p
Second off I like British dry humor ;p
Thirdly what are you running? I've seen so many AMD E/A/Ryzen mobile users lately I'd have figured someone with some actual hands on should be around to chime in.

*my lord is he writing a novel?

Removed a joke that will be deemed as xenophobic by someone and probably supported by a Moderator.
Removed an obfuscation joke that was deemed to be "Misogynistic" by forum Moderator, verifying my belief that I wouldn't be welcome on this forum!

290X, with Radeon driver. I had a go switching to amdgpu the other day, but that coincided with some other changes I made which lost me some functionality that I falsely attributed to the GPU switch and so reverted (as I needed working system for online course this week).

I have the iGPU disabled in the bios. Further info can be found in my intro thread.

Lol why disable, use it to run other screens :slight_smile:

I said dry humor...but she's married so I can't go finding out about the other place she may or may not be dry. :wink:

I run the US flag because there are no hybrid country or state/prov flags ;p

@regularCoder Found a post about using vgaswitcheroo but it's very old...however systemd-vgaswitcheroo-units is in the AUR.

I am gonna pretend i understand

1 Like

I'd rather get you fragging fools than pretending :wink: I've just been poking around with how to switch non-prime hybrids which brought up vgaswitcheroo.

I actually spent like 7 or 8 hours yesterday fighting Vulkan...somehow some AMD vulkan bits got installed and broke everything.

Surely you do.
They ditched tea into a river to gain independence, you went without food for a while.
All one big happy club.

Here I thought he meant the vga bit...(or maybe he did...)