GoXLR not working

Hey Guys,

I'm new to Garuda and have an audio setup that I can't get running. My Question is is there a KDE image with Kernel 5.10?
The problem is if I want to downgrade I can't boot into Linux LTS Kernel and it just stops. And I don't really know which nvidia driver version I would need for it to run.

Hello. Welcome :slight_smile:

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

You can use live ISO for this. Which audio setup?

3 Likes

You can try downloading the kde-barebones iso, which ships with linux-lts instead of linux-zen.
Also welcome to the forum :slight_smile:

2 Likes
╭─[email protected] in ~  
╰─λ inxi -Faz
System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0627dd89-db07-42a0-99c7-f9d76f1012f9
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X370 Taichi serial: <superuser required>
UEFI: American Megatrends v: P5.50 date: 04/18/2019
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23)
model-id: 1 stepping: 1 microcode: 8001137 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 91193
Speed: 2548 MHz min/max: 1550/3800 MHz boost: enabled Core speeds (MHz): 1: 2548 2: 1510
3: 1495 4: 2178 5: 1380 6: 1498 7: 1478 8: 3178 9: 1928 10: 1467 11: 1466 12: 1519
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 22:00.0 chip-ID: 10de:1c03 class-ID: 0300
Device-2: Cubeternet USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 1e4e:0110
class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.7x11.9") s-diag: 1102mm (43.4")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24")
Monitor-2: DP-4 res: 1920x1080 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
bus-ID: 22:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 24:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: TC Electronic GoXLRMini type: USB driver: snd-usb-audio bus-ID: 1-2:2
chip-ID: 1220:8fe4 class-ID: 0102
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel
bus-ID: 1c:00.0 chip-ID: 8086:24fb class-ID: 0280
IF: wlp28s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: d000
bus-ID: 1e:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp30s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:5
chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 2.8 TiB used: 92.65 GiB (3.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3B2QGXA7 temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3320418AS size: 298.09 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC44
scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A750
scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 vendor: A-Data model: SU800 size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8BS scheme: MBR
ID-5: /dev/sdd maj-min: 8:48 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 17.88 GiB (1.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 580 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 17.88 GiB (1.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 17.88 GiB (1.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 17.88 GiB (1.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.34 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 358 Uptime: 1m wakeups: 0 Memory: 31.34 GiB used: 2.5 GiB (8.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1511 lib: 356
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.09

╭─[email protected] in ~ took 1s
╰─λ

I'm using the GoXLR Mini

You don't need to downgrade, just install linux-lts and linux-lts-headers in addition to the current kernel and use it.
I can see at least one user in the forum providing inxi with linux-lts and your same GPU and driver version.
Additionally, I think that you could use also the nvidia-lts package (which is also at 495.44), but I'd leave a confirmation to Nvidia users (I never had a Nvidia GPU).

3 Likes

I tried this as well using Garuda Settingsmanager to install Linux-LTS. But when I boot into it I only get Initialize Ramdisk...

If you're trying to use the GitHub scripts you need at least 5.11 kernel.
Have you tried using kernel 5.15 sans zen?

1 Like

/me is curious about his audio setup and waits to pounce with the NUKE PIPE WIRE FTW ;0

1 Like

I did it like it is told in the GitHub but even after installation and rebooting it only said GoXLR Multichannel but I couldn't hear anything through my studio monitors nor my headset. Tried my XLR-Mic as well no input. I joined the discord and tried this:
curl -s https://cloud.6clones.net/s/R85rcwNx47gNPsC/download/alsa-goxlr.tar.gz | sudo tar -xzvC /usr/share/alsa/
But it doesn't show up after running it and rebooting. I can only see it in the settings as "off".
I don't know what you mean by Kernel 5.15 sans zen...is it just without zen?

linux & linux-headers

Yes, the none zen'd, latest arch kernel. It may be a zen conflict. The joy of using reverse engineered drivers, triple trouble.

Wish you'd Pipe-Down. Hater!!!!

1 Like

Btw got this out using GitHub script with 5.15 Zen:

Output Devices
No PulseAudio daemon running, or not running as session daemon.

Please type a number to pick a default output device (0 to skip):

So just sudo pacman -S linux right?

MAXXX Hate! :slight_smile:
@Zentriks Have you manually run Pulse? What does alsamixer say?

@anon26187667 maybe in a year or two I won't hate Pipewire but for as long as you STILL need alsa, pulse and or jack it's not living up to the hype and it's just more mess on the mess pile. :wink:

yes, but no, you want to have linux-headers as well and select it on reboot, by going to advanced in grub and selecting the none-zen option.

1 Like

Well, there's a hint for you, which is listed on the Github.

@anon92996653 have at it. :slight_smile:

What am I having at? Pizza? Cookies? I'd love to have at a coffee right now but it's bed time.

Coffee? Peasant!
If not tea, get in the river (that was the chant, wasn't it?!?)

1 Like

I TAKE THINE RIVER AND A STIFF BREW OF THE FINEST CHICKORY! (Sorry OP not trying to derail)

1 Like

I'm already dual-booting and my GoXLR Mini powered even when I shut my rig down. I don't see another hint...
When it comes to audio-settings I'm much of a noob especially in linux

Linux audio is a bit of a landmine and with things transitioning to a new but not 100% system (Pipewire) it can be harder to figure out where issues are stemming from.

One of my issues in general is when you are new to a distro you don't fully understand how they've set up certain things until you dig into the what why when where of it all. In some distributions this can mean your audio is 100% right from the first boot, others it might be a week of tinkering, reading and swearing.

I was actually reading something about that GoXLR interface not too long ago but don't remember what the hell it was about. However we'll help as best we can. Things might be mucky but I'm sure it's doable. I do audio in Linux fine.

1 Like