Gone a week, update hung, power cycled, now in emergency mode

Hi!

I did an update, it failed to finish (seemed to hang on joplin desktop if i am remembering right?). Power cycled and now get dropped into emergency mode. journalctl is not a known command.

Tried some snapshots but older ones fail to start the Light Display Manager and all fail to start the pacman files database update.

are there any good options or just reinstall garuda?

thx!! << q

You could try using a live USB, chroot from there into your installed system and re-execute a full update.

5 Likes

hi!

RAD! will try it, thx!

any thoughts on journalctl and systemctl not known commands in emergency mode?

If your root partition can't be mounted, you just won't have access to those files.

Boot up into a live session, press the chroot button in garuda welcome and once you have a root shell after a successful chroot, you can try a normal update or if that fails, try reinstalling all packages via update remote reinstall

3 Likes

If the update fails, you could try to btrfs check your partition or eg fsck other partitions.
If you have other partitions mounted, you could try to give a look at the /etc/fstab vs the uuids in blkid...

3 Likes

1st: both suggestions to use chroot were awesome! that is what worked!

i did have to mess around a bit of course but my system seems to be back!

i am getting a dbus-launch connection failure dialog but will research and the post if necessary there.

this was FANTASTIC help and i only wish i could mark TWO replies as solutions!!

thx soo much!

3 Likes

i will close this out after i do a couple reboots, updates, etc to verify it is robustly good! :stuck_out_tongue_winking_eye:

1 Like

created 2 different forum posts for problems AFTER using chroot from USB to update systems and get at least back logged in:

closing this! thx everyone!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.