Gnome File Manager Hangs when trying to Copy Items

When ever I try to copy files from one folder to other the whole system hangs!!! I cant even go to tty2. I need to forcefully power off the system and then start again

Read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

1 Like
System:
  Kernel: 5.12.1-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
  root=UUID=6753ac6a-648a-4f2a-a68e-a44fe215663b rw [email protected] quiet 
  splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: GNOME 40.1 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Garuda Linux base: Arch Linux 
Machine:
  Type: Portable System: Dell product: Vostro 1015 v: N/A serial: <filter> 
  Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: 047MWF serial: <filter> BIOS: Dell v: A06 
  date: 11/26/2010 
Battery:
  ID-1: BAT0 charge: 10.0 Wh (100.0%) condition: 10.0/48.8 Wh (20.5%) 
  volts: 12.4 min: 11.1 model: LG DELL PW8238 type: Li-ion serial: <filter> 
  status: Full 
CPU:
  Info: Dual Core model: Intel Core2 Duo T6570 bits: 64 type: MCP 
  arch: Penryn family: 6 model-id: 17 (23) stepping: A (10) microcode: A0B 
  cache: L2: 2 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 8379 
  Speed: 1980 MHz min/max: 1200/2101 MHz boost: enabled Core speeds (MHz): 
  1: 1980 2: 2011 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Dell 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:2a42 class-ID: 0300 
  Device-2: Acer Integrated_Webcam_2M type: USB driver: uvcvideo 
  bus-ID: 2-5:2 chip-ID: 5986:01a2 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :1 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) 
  v: 2.1 Mesa 21.0.3 direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.1-zen2-1-zen running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: no 
  Sound Server-4: PipeWire v: 0.3.27 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: ce00 bus-ID: 09:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp9s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
  v: kernel port: ce00 bus-ID: 0c:00.0 chip-ID: 168c:002b class-ID: 0280 
  IF: wlp12s0 state: up mac: <filter> 
Bluetooth:
  Device-1: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 4-1:3 chip-ID: 0cf3:3005 class-ID: e001 
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 8.05 GiB (0.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWL110 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0A scheme: MBR 
Partition:
  ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 7.66 GiB (7.7%) 
  fs: btrfs dev: /dev/sda1 maj-min: 8:1 
  ID-2: /home raw-size: 100 GiB size: 100 GiB (100.00%) 
  used: 7.66 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1 
  ID-3: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) 
  used: 7.66 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1 
  ID-4: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) 
  used: 7.66 GiB (7.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 1.9 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 1.9 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 48.5 C 
  Fan Speeds (RPM): cpu: 3175 
Info:
  Processes: 211 Uptime: 10m wakeups: 2 Memory: 3.8 GiB 
  used: 1.71 GiB (45.0%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1165 lib: 307 Shell: fish 
  v: 3.2.1 running-in: gnome-terminal inxi: 3.3.04 

You should not expect miracles with hardware that is over 10 years old. In addition, the GPU also eats away at the RAM.

Maybe try Xfce, LXQt ....

1 Like

KDE Works fine and ubuntu worked great as well. I know Its Old Thats Why I use Linux and not windows. Pls at least tell me how I can diagnose the problem

Open htop in terminal and look what happen, cpu, RAM etc.

Or use KDE, Ubuntu ... :slight_smile:

1 Like

I checked what you said but before htop refreshed the system hanged... Surprisingly the swap was not being used at all

Hi I just wanted to update you that i ran the command


nohang -m

It went till 1545mb remaing ram and 3980mb swap
but then It froze.
Is one of my 2gb memory stick failing due to which this error is being caused?
I will try manjaro gnome next sunday and will share you what I find.
Also how can I detect failing memory stick? and Know If It needs to be Replaced...?

As @SGS has already mentioned this is a rather old piece of hardware to run Garuda on. I have used a core 2 duo with Garuda, but I also pared back all the resource usage.

That core 2 duo model was very fussy about which I/O scheduler and kernel was being used. I would suggest testing different versions of both.

I would test some Windows managers or LXQT to see if the same issue exists.

Does your system freeze when you are using the terminal to copy files?

Does this happen in the live boot environment?

3 Likes

There is some memory module issue... The system hangs after 1500 mb of free memory is left.. even on xfce

Probabibly a failing ram stick

Can you test that please?

You might try to play with this:

https://wiki.archlinux.org/title/Sysctl#Virtual_memory

Also, as said, I strongly suggest you to swap to a lighter environment and to try the LTS kernel.

3 Likes

Thanks Stardust. I It happened whenever free ram left went below 35%. It even happend on live and terminal. I switched to Linux LTS Kernel and It worked Wonders For Me. My laptop was taking a lot of time during boot process where it said loading initramfs. Now It booted faster after switch to LTS. To test the issue i again ran

nohang -m

And It Worked. Thanks Evryone For Your Great Support.
Thanks Stardust For Your Suggestion.
You Guys are awesome :heart_eyes: :heart_eyes:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.