Gnome apps ui glitch/shrink

Hey Garuda. Gnome is great. Love it. I still need to test out minecraft. Mentioned in the Telegram that I had issue with movements in minecraft and chat issues as well minor for all gnomes in Pop Os,EdeavourOS, Fedora,Manjaro. Garuda was one I hadn't tried in a long bit but yea.

Here is my system info before I get started with the actual reason for this post.

Kernel: 5.14.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=7a01d5d4-0b3b-47a1-be62-d729448ce85d 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 resume=UUID=a73a7c73-9f05-4278-8cc8-5cd041c7d3a8 loglevel=3 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC 
           v: 0896100000304100000620100 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 2163 v: 29.42 serial: <filter> UEFI: Insyde v: F.72 
           date: 03/09/2018 
Battery:   ID-1: BAT0 charge: 21.3 Wh (100.0%) condition: 21.3/21.3 Wh (100.0%) volts: 16.8 min: 14.8 
           model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell family: 6 
           model-id: 45 (69) stepping: 1 microcode: 26 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13568 
           Speed: 1596 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1596 4: 1598 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
           Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus-ID: 2-3:3 chip-ID: 064e:e264 
           class-ID: 0e02 serial: <filter> 
           Display: wayland server: X.Org 1.21.1.2 compositor: gnome-shell driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: XWAYLAND0 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
           diag: 389mm (15.3") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 21.2.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403 
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.6-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.35 running: yes 
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8188ee 
           v: kernel port: 4000 bus-ID: 08:00.0 chip-ID: 10ec:8179 class-ID: 0280 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 3000 bus-ID: 09:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 698.64 GiB used: 18.84 GiB (2.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD7500BPVX-60JC3T0 size: 698.64 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 
           serial: <filter> rev: 1A01 scheme: GPT 
Partition: ID-1: / raw-size: 681.26 GiB size: 681.26 GiB (100.00%) used: 18.84 GiB (2.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 681.26 GiB size: 681.26 GiB (100.00%) used: 18.84 GiB (2.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 681.26 GiB size: 681.26 GiB (100.00%) used: 18.84 GiB (2.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw-size: 681.26 GiB size: 681.26 GiB (100.00%) used: 18.84 GiB (2.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 17.12 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
           maj-min: 8:3 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 241 Uptime: 9m wakeups: 1 Memory: 15.56 GiB used: 2.49 GiB (16.0%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1452 lib: 355 
           Shell: fish v: 3.3.1 running-in: gnome-terminal inxi: 3.3.06 

Anyways back to the main glitch/shrink Ui issue.

when I go to view all apps! The workpace switcher is glitched over the apps. This happens in both Xorg and wayland.

Here is an example.

This may help you.

3 Likes

Wow and that's cause I searched to see if there was a similar problem. Weird that this one didn't show up. But if it already got covered that's great.

Disregard this or I guess it can stay as examples as well since the other one has a shrunked workspace switcher and this one is huge overlapping the apps.

Thanks for replying about this :blush:

I can confirm it's the Native Window Placement Extension. Disabled it and it fixed the issue

Here in the forum you mark the solution not the implementation.
That's why I'm changing that :slight_smile: