Gnome Workspace's view looking weird fix!

( This is my first post so please don't mind me if I had done something wrong :smiley: )
So first of all I love Garuda Linux i just love it. Its the best distro i have used ( yes i am a distro hopper and have tried many distros ) and now i have settled on garuda for a while.
I love the Gnome Version of Garuda. When I first tried it, I faced this weird problem of the Gnome's Workspace View. Here's a picture of that.

I'm a new user so can't upload images so this is imgur website's post (made by me only).
So in 1st screenshot you can see they are very small and in 2nd one also they are bugged and are very close to each other. Sometimes it is so big that it covers applications as well.

So I myself found that this is caused due to an extension named "Native Window Placement", it is enabled by default and disabling it fixes this issue.

And FYI I can reproduce this issue by enabling it again so probably it is making this problem.

I Hope this post fixed your issue with the weird view.

Sorry if i posted this in the wrong section.
Also my english is not good so bear with me.

Thanks for reading!

EDIT : I know this is the problem of that extension but i just made this post so the people can fix it. Please tell me if this post is in the wrong section, I guess this one lies in something like "Helping Community".


Hi there, I moved it to gnome section.
I'm not a Gnome user, but I thought all extensions were disabled according to this:

Maybe something changed afterwards though...



I told in the post, it is enabled by default :smiley:
I mean in the live iso as well as in the fresh installation.


Are you using wayland that could be the reason for problems


Nope. I am not using Wayland.

As I said, it exists in default iso boot as well as default installation and wayland is not enabled by default :wink:

Garuda does not make the extensions they come from Gnome extensions and maintained by gnome users.
If it does not work remove it Garuda does not support them meaning its up to the user to fix them.
I do have it on mine but it does nothing as i use gnome40 improvements extension.
Wayland should be default unless you are using nvidia.
This is what they should look like, remember to reload the desktop, also i can't find that extension on but i did not look that far mind you. perhaps it was left by mistake it was not running on my Garuda install when i tried it it made no difference anyway.

1 Like

This is in fact a GNOME native Extension rather than a third party one, will disable it too :eyes:


no its not
The extension completely broke basic animations like going in and out of activities, and made the activities overview not resize windows, instead making them small and hard to see. I thought these problems were because of another extension not uninstalling properly and it's been bothering me so much.
July 1, 2021


No way :sweat_smile: time to get rid of them then, I guess :eyes:
That link is leading to weird websites btw


sorry missed the gnome bit
Native Window Placement - GNOME Shell Extensions

I only use extensions from this site its the official Gnome site never ever from a distribution

1 Like

Thanks for replying guys

You are absolutely right, same is written in archwiki but it is not my case.
As i have fresh installed Garuda Gnome 2 times, i wasn't using wayland so I thought it is not the default. I found this :
This might be my issue.
Secondly i checked garuda assistant and the option "Enable GDM Wayland" was unchecked. And,


returns "x11"

I just wanted to make this post so people can fix this.

Can you guys reproduce this issue as well like without using wayland and fresh install?
I was thinking to check this extension in a vanilla arch gnome but i can't have a VM because of my potato PC. :sweat_smile:

I saw that comment in the extension's website but i don't think it is caused because of another extension instead it is the problem of this extension and disabling it might fix the issue.


I'm sorry I think you are now just beating about the bush .
You found the faulty extension you disabled it you got the desired result that's it.
No need to go any further.
The extension has nothing to do with Gnome, it has nothing to do with Garuda as its a 3rd party extension, its already reported on the git site.
Please also note Wayland breaks many features In Gnome its nearly their but not quite, everything works in x11 well almost
IF you have Nvidia you can't use Wayland as wayland nvidia are not compatible unless you use the free drivers.
From my perspective wayland is not viable at this time only for testing.

1 Like

I am just replying to the messages, and I don't think I'm doing anything wrong.
And I said that I'm not using wayland.

Ikr but as i said i just made this post so people can fix it as i also didn't got a solution when i faced this problem.

I'm just to the point and telling this thing exists. And I also wanted that developers may disable it by default so other people don't face problem and don't make unnecessary posts.
And I'm glad to know that dr460nf1r3 got to know about it and he might disable it by default.

As it was just me telling about this thing(which I already told), I should close this post.
I told ya this is my first post so I don't know much about this forum.

And this post was for the people who faced the problem. And this post is titled with "fix".
If you haven't faced this problem then you should just not come ( my point of view ).
If community is using a certain thing they have right to give a feedback about it and how that product can improve.
I also said at the beginning that I don't have any hate towards Garuda.
And yes I don't think you or someone else need to reply now as I told the thing which i wanted to.

Sorry if I seem to be rude.


1 Like

X11 is default in GNOME for some time now, I might change that though :eyes:

1 Like

Hey There.
Could you please close the post or how can I do it? :smiley:

1 Like