Gnome 45 , wayland session

Hello ,
i updated to gnome 45 .
i can’t login to the wayland session , only Xorg works .
Gdm takes me back to the password prompt after i type the password when i try to login to the wayland session.

Nvidia GPU I presume.

Let’s see your garuda-inxi.

 garuda-inxi                                                                                β–‘β–’β–“ βœ” β–“β–’β–‘
  Kernel: 6.5.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a26b3703-6f2c-40cf-90cb-553a9ee31322 rw rootflags=subvol=@
    lsm=landlock,lockdown,yama,integrity,apparmor,bpf quiet quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0loglevel=3
    btusb.enable_autosuspend=n mitigations=off ibt=off
  Desktop: GNOME v: 45.0 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X540LA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X540LA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X540LA.303 date: 08/31/2018
  ID-1: BAT0 charge: 15.7 Wh (53.6%) condition: 29.3/33.2 Wh (88.3%)
    power: 8.6 W volts: 10.8 min: 10.8 model: ASUSTeK ASUS Battery type: Li-ion
    serial: N/A status: discharging cycles: 618
  Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1897 high: 1900 min/max: 500/1900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1900 2: 1900 3: 1896
    4: 1895 bogomips: 15962
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: DP-1
    off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616
    class-ID: 0300
  Device-2: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:4 chip-ID: 13d3:5a11
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: DP-1 pos: primary model: Samsung SyncMaster serial: <filter>
    built: 2009 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
    size: 443x249mm (17.44x9.8") diag: 508mm (20") ratio: 16:9 modes:
    max: 1600x900 min: 720x400
  Monitor-2: eDP-1 note: disabled model: ChiMei InnoLux 0x15dc built: 2015
    res: 1600x900 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  API: ALSA v: k6.5.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
    bus-ID: 02:00.2 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0f2 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On
    driver: rtl8723be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:3 chip-ID: 0bda:b721
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> status:
    discoverable: no active: no pairing: yes class-ID: 7c010c
  Local Storage: total: 704.24 GiB used: 383.4 GiB (54.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: TeamGroup model: T253256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 227N scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD5000LPCX-80VHAT1 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A02 scheme: GPT
  ID-1: / raw-size: 34.7 GiB size: 34.7 GiB (100.00%) used: 14.41 GiB (41.5%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 528 MiB size: 526.9 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 203.26 GiB size: 203.26 GiB (100.00%)
    used: 163.71 GiB (80.5%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 34.7 GiB size: 34.7 GiB (100.00%)
    used: 14.41 GiB (41.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 34.7 GiB size: 34.7 GiB (100.00%)
    used: 14.41 GiB (41.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.65 GiB used: 1.8 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 55.0 C pch: 50.5 C mobo: N/A
  Fan Speeds (rpm): cpu: 2300
  Processes: 258 Uptime: 5h 10m wakeups: 128 Memory: total: 8 GiB
  available: 7.65 GiB used: 3.5 GiB (45.7%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1318 pm: pacman pkgs: 1294 libs: 362 tools: paru,yay pm: flatpak
  pkgs: 24 Shell: fish v: 3.6.1 running-in: gnome-terminal inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-04-03
  Last full system update: 2023-10-13 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            smb.service

no i have an intel cpu with integrated graphics

Oh wow, that’s weird. :thinking:

Can you show what you have in /etc/gdm/custom.conf?

1 Like
# GDM configuration storage






# Uncomment the line below to turn on debugging

Let’s try enabling early KMS.

sudo micro /etc/dracut.conf.d/early_kms.conf

You can name the file anything you want as long as it ends in .conf.

Add this to the file:

force_drivers+=" i915 "

Make sure you keep the β€œpadding” spaces (between the quotes and i915). Save and exit out of the file.

Rebuild the initramfs.

sudo dracut-rebuild

Reboot, then test again if you can get Wayland in GDM.


sudo dracut-rebuild
β–‘β–’β–“ ✘ 1 β–“β–’β–‘
sudo: dracut-rebuild: command not found
i get this

My mistake, it looks like you are still on mkinitcpio. You don’t need the config file I mentioned, that is for dracut only.

Instead, you need to add i915 in the modules array in /etc/mkinitcpio.conf. It should look like this:


Then regenerate the initramfs:

sudo mkinitcpio -P
1 Like

i just did the dracut thing ,and rebooted it didn’t fix it sadly

You don’t have dracut set up, you will have to do the mkinitcpio thing instead.

Can you post your /etc/mkinitcpio.conf into the thread so we can take a look?

1 Like

i installed it and it didn’t give me the error after i did ```
sudo dracut-rebuild

To switch from mkinitcpio to dracut, install the garuda-dracut-support package:

sudo pacman -S garuda-dracut-support

There will be a few prompts asking to remove mkinitcpio packages; go ahead and confirm them for removal.

Then rebuild the initramfs.

sudo dracut-rebuild

yeah i did that

Let’s double-check early KMS has been set up. Please post the input and output of these commands:

pacman -Q | grep -E "dracut|mkinitcpio"
cat /etc/dracut.conf.d/early_kms.conf
sudo dracut-rebuild

If you named your dracut config something besides β€œearly_kms.conf” then obviously cat against that.

We may as well comment out this line:

sudo micro /etc/gdm/custom.conf

Put a β€œ#” in front of that line, so it looks like this:

# DefaultSession=gnome-xorg.desktop

When you reboot, confirm you have a cog wheel on the GDM login screen for changing the session like this:

If you do not, try switching to a TTY (press Ctrl+Alt+F3), log in, and restart the GDM service.

sudo systemctl restart gdm.service

Then switch back to GDM (Ctrl+Alt+F1 or F2, whichever it is on) and see if you have a cog wheel for changing the session.

1 Like

β–‘β–’β–“ ~ β–“β–’β–‘ pacman -Q | grep -E β€œdracut|mkinitcpio” β–‘β–’β–“ :heavy_check_mark: β–“β–’β–‘
dracut 059-3
garuda-dracut-support 1.0.1-1
mkinitcpio-firmware 1.4.0-1
mkinitcpio-nfs-utils 0.3-8
β–‘β–’β–“ ~ β–“β–’β–‘ cat /etc/dracut.conf.d/early_kms.conf β–‘β–’β–“ :heavy_check_mark: β–“β–’β–‘
force_drivers+=" i915 "
β–‘β–’β–“ ~ β–“β–’β–‘ β–‘β–’β–“ :heavy_check_mark: β–“β–’β–‘

i tried that . it’s not fixed sadly

You are missing the rebuild output.

Did you add the comment to /etc/gdm/custom.conf?

Do you have the cog wheel in GDM?

Did you switch to a TTY and log in?

You tried what?

Please be more specific about what you are doing. You are the only one here who can see what is happening on your computer.


yes i have the cog wheel , i picked the wayland session (Gnome) and the same thing happened

~ β–“β–’β–‘ sudo dracut-rebuild β–‘β–’β–“ :heavy_check_mark: β–“β–’β–‘
[sudo] password for houssem:
:: Building initramfs for linux-zen (6.5.7-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.5.7-zen1-1-zen)

and yes i uncommented the # DefaultSession=gnome-xorg.desktop