Garuda stuck on boot - Issues reinstalling grub from live USB

Hi.

I'm running Garuda KDe Dr460nized on my Laptop. I am dual-booting Windows.
For months now I've had an issue where, when booting the system, it would get stuck on the following text:

Loading Linux linux-zen ...
Loading initial ramdisk ...

When this happened, a few reboots would get the system to eventually start normally, or I was able to load a snapshot for it to work, so I didn't bother. However, that is not the case anymore. I'm writing this on a live USB.

So far, i've tried to run these commands to reinstall grub and see if it works. However, when running sudo mount /dev/sdxy /mnt/, I get the following error:

mount: /mnt: special device /dev/sdxy does not exist.
dmesg(1) may have more information after failed mount system call.

this is is lsblk:

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
loop0         7:0    0  15.6M  1 loop /run/miso/sfs/livefs
loop1         7:1    0 429.4M  1 loop /run/miso/sfs/mhwdfs
loop2         7:2    0   1.1G  1 loop /run/miso/sfs/desktopfs
loop3         7:3    0   680M  1 loop /run/miso/sfs/rootfs
sda           8:0    1  14.5G  0 disk /mnt
│                                     /run/miso/bootmnt
├─sda1        8:1    1   2.4G  0 part
└─sda2        8:2    1     4M  0 part
zram0       253:0    0   7.6G  0 disk [SWAP]
nvme0n1     259:0    0 476.9G  0 disk
├─nvme0n1p1 259:1    0   260M  0 part
├─nvme0n1p2 259:2    0    16M  0 part
├─nvme0n1p3 259:3    0  59.2G  0 part
├─nvme0n1p4 259:4    0  1000M  0 part
├─nvme0n1p5 259:5    0   200M  0 part
└─nvme0n1p6 259:6    0 394.3G  0 part

I've then tried to run sudo mount /dev/sda2 /mnt because sda2 is 4MB, but I get this error instead

mount: /mnt: /dev/sda2 already mounted or mount point busy.
dmesg(1) may have more information after failed mount system call.

I've also tried sudo mount /dev/sda /mnt

mount: /mnt: WARNING: source write-protected, mounted read-only.

running sudo chroot /mnt/@ after that gives me:

chroot: cannot change root directory to '/mnt/@': No such file or directory

i'm guessing that the @ stands for something, but there are three folders in /mnt, and rather than playing with fire and potentially destroy the bootloader with commands I don't understand, i've decided that i've reached a dead end.

Here is garuda-inxi:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=fr tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506LH_TUF566LH
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX506LH v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: FX506LH.310 date: 11/26/2021
Battery:
ID-1: BAT1 charge: 39.1 Wh (99.0%) condition: 39.5/48.1 Wh (82.2%)
volts: 12.8 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
status: charging
CPU:
Info: model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm
family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1437 high: 2500 min/max: 800/4500 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 2500 3: 800
4: 2500 5: 800 6: 800 7: 2500 8: 800 bogomips: 39999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117M vendor: ASUSTeK driver: nvidia v: 520.56.06
alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
2022-10) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.0
chip-ID: 10de:1f99 class-ID: 0300
Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-7:3 chip-ID: 322e:202c class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Najing CEC Panda 0x004d built: 2019
res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.2.1
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 491.4 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2210 MTFDHBA512QFD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 30.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB model: USB DISK 2.0 size: 14.46 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 1.88 GiB (24.8%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 60.0 C pch: 50.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 233 Uptime: 5m wakeups: 1 Memory: 7.6 GiB used: 3.73 GiB (49.1%)
Init: systemd v: 251 default: graphical tool: systemctl Compilers:
gcc: 12.2.0 Packages: pm: pacman pkgs: 1220 libs: 308 tools: octopi,paru
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
System install date:     2023-01-02
Last full system update: 2023-01-02 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

I'm not sure if it's related, but before garuda broke today, I was trying to follow the Arch Wiki to create a permanent configuration for my graphics tablet. I had created a file in /etc/X11/xorg.conf.d/72-wacom-options.conf following the wiki's instructions. Following this, I restarted my PC, and that's when it stopped working.
That's about all of the information I have on hand.

To chroot from the live USB into your installed system, you can try with the relevant tool in the Garuda Welcome of the live USB.
If not working, there is also a manual procedure here.
You should mount the "broken" btrfs system partition not the UEFI system partition.

sudo mkdir -p /mnt/broken
sudo mount /dev/nvme0n1p6 /mnt/broken
sudo garuda-chroot /mnt/broken/@

Change nvme0n1p6 with your system partition, if I did not pick up the right one.
When inside the chroot your have to mount the esp, which could be:

mount /dev/nvme0n1p1 /boot/efi

And proceed with the tutorial.
In general, do not use /dev/sda or /dev/sdax in the manual procedure. These are your USB key and relevant partitions.

2 Likes

Please reboot.

1 Like

Hello again,

Somehow along the way, the live USB was freezing at boot on "Terminating Plymouth Boot Screen", so I re-flashed the ISO on the USB stick.

Thank you for the help, I was able to follow the instructions without issue. Unfortunately this didn't fix my issue, as I'm still getting the same screen when booting.
Now, I ran out of things (I know) to try. Are there any recommended steps to take here?

This is the reference tutorial when you cannot boot.
Try to start switching or booting to a tty, or also with a chroot.
Try a garuda-update and some of the suggestions in the tutorial.
Take a chance also to provide your real system info, from within the chroot or if from tty use

garuda-inxi | tb

You can also try deleting that xorg file you mentioned.

1 Like
  1. Why would grub be related to this issue?
  2. You're trying to chroot, but what are you trying to do in the chroot?
  3. What happens if you just boot in recovery mode? With silent in your boot parameters it should be obvious you don't see any logs..

If recovery mode works, send your garuda-inxi. There's no point in any further analysis and tapping around in the dark trying random things until we can get that info.

1 Like

I was looking around at similar issues, and I found out that reinstalling grub worked for someone. I figured I might try something before blindly asking for help.

My first message states the following:

After trying recovery mode, I've managed to log in as root on the shown terminal. I've then tried to run exit to "boot into default mode", but the command gets stuck on the following

Reloading system manager configuration
Starting default.target

The system is then unresponsive. I can press ctrl+alt+f2 to log in to tty, but I have no clue where to go from here.
I will try following the aforementioned guide from the tty when I have time to.

I've included a garuda-inxi in my first message, but it's done from the live USB as I do not have access to the desktop.

After following the guide, none of the commands haven't resulted in an error.
I've "connected" to my phone's internet through USB to inconclusive results.

startx

sudo dkms autoinstall and sudo reflector -a6 -f5 --save /etc/pacman.d/mirrorlist

Running garuda-update outputs a bunch of errors. Here is a sample

I'm "connected" to my android phone sharing my 4G through an USB cable. The computer doesn't seem to be connected.
ip link

Hello,
I've figured out how to garuda-inxi from chroot

12System:
12Kernel 6.0.2-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 12.2.0
12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=fr tz=UTC misobasedir=garuda
misolabel=GARUDA_DR460NIZED_TALON quiet systemd.show_status=1 ibt=off driver=free
nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
12Console N/A 12wm kwin_x11 12Distro Garuda Linux 12base Arch Linux
12Machine:
12Type Laptop 12System ASUSTeK 12product ASUS TUF Gaming F15 FX506LH_TUF566LH 12v 1.0 12serial <filter>
12Mobo ASUSTeK 12model FX506LH 12v 1.0 12serial <filter> 12UEFI American Megatrends 12v FX506LH.310
12date 11/26/2021
12Battery:
12ID-1 BAT1 12charge 40.2 Wh (98.0%) 12condition 41.0/48.1 Wh (85.2%) 12volts 11.3 12min 11.7
12model ASUS A32-K55 12type Li-ion 12serial N/A 12status discharging
12CPU:
12Info 12model Intel Core i5-10300H 12socket U3E1 12bits 64 12type MT MCP 12arch Comet Lake 12gen core 10
12level v3 12note check 12built 2020 12process Intel 14nm 12family 6 12model-id 0xA5 (165) 12stepping 2
12microcode 0xF0
12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 256 KiB
12desc d-4x32 KiB; i-4x32 KiB 12L2 1024 KiB 12desc 4x256 KiB 12L3 8 MiB 12desc 1x8 MiB
12Speed (MHz) 12avg 1383 12high 2812 12min/max 800/4500 12base/boost 2376/8300 12scaling
12driver intel_pstate 12governor powersave 12volts 0.8 V 12ext-clock 100 MHz 12cores 121 800 122 800 123 2812
124 2176 125 801 126 800 127 1249 128 1631 12bogomips 39999
12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
12Vulnerabilities
12Type itlb_multihit 12status KVM: VMX disabled
12Type l1tf 12status Not affected
12Type mds 12status Not affected
12Type meltdown 12status Not affected
12Type mmio_stale_data 12mitigation Clear CPU buffers; SMT vulnerable
12Type retbleed 12mitigation Enhanced IBRS
12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl
12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
12Type spectre_v2 12mitigation Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
sequence
12Type srbds 12mitigation Microcode
12Type tsx_async_abort 12status Not affected
12Graphics:
12Device-1 Intel CometLake-H GT2 [UHD Graphics] 12vendor ASUSTeK 12driver i915 12v kernel 12arch Gen-9.5
12process Intel 14nm 12built 2016-20 12ports 12active eDP-1 12empty none 12bus-ID 00:02.0 12chip-ID 8086:9bc4
12class-ID 0300
12Device-2 NVIDIA TU117M 12vendor ASUSTeK 12driver nouveau 12v kernel 12non-free 525.xx+
12status current (as of 2022-12) 12arch Turing 12code TUxxx 12process TSMC 12nm FF 12built 2018-22 12pcie
12gen 3 12speed 8 GT/s 12lanes 16 12ports 12active none 12empty DP-1,HDMI-A-1 12bus-ID 01:00.0
12chip-ID 10de:1f99 12class-ID 0300 12temp 27.0 C
12Device-3 Sonix USB2.0 HD UVC WebCam 12type USB 12driver uvcvideo 12bus-ID 1-7:3 12chip-ID 322e:202c
12class-ID 0e02
12Display 12server X.org 12v 1.21.1.6 12with Xwayland 12v 22.1.7 12compositor kwin_x11 12driver 12gpu i915
12note X driver n/a 12display-ID :0
12Monitor-1 eDP-1 12model Najing CEC Panda 0x004d 12built 2019 12res 1920x1080 12dpi 142 12gamma 1.2
12size 344x194mm (13.54x7.64") 12diag 395mm (15.5") 12ratio 16:9 12modes 1920x1080
12API OpenGL 12Message GL data unavailable for root.
12Audio:
12Device-1 Intel Comet Lake PCH cAVS 12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 12bus-ID 00:1f.3
12chip-ID 8086:06c8 12class-ID 0403
12Device-2 NVIDIA 12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 12pcie 12gen 3 12speed 8 GT/s 12lanes 16
12bus-ID 01:00.1 12chip-ID 10de:10fa 12class-ID 0403
12Sound API ALSA 12v k6.0.2-zen1-1-zen 12running yes
12Sound Interface sndio 12v N/A 12running no
12Sound Server-1 PulseAudio 12v 16.1 12running no
12Sound Server-2 PipeWire 12v 0.3.63 12running yes
12Network:
12Device-1 MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter 12vendor AzureWave
12driver mt7921e 12v kernel 12pcie 12gen 2 12speed 5 GT/s 12lanes 1 12bus-ID 03:00.0 12chip-ID 14c3:7961
12class-ID 0280
12IF wlp3s0 12state down 12mac <filter>
12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASUSTeK 12driver r8169
12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1 12port 3000 12bus-ID 04:00.0 12chip-ID 10ec:8168
12class-ID 0200
12IF enp4s0 12state down 12mac <filter>
12IF-ID-1 enp0s20f0u1 12state unknown 12speed -1 12duplex half 12mac <filter>
12Bluetooth:
12Device-1 OPPO CPH1951 12type USB 12driver rndis_host 12v kernel 12bus-ID 1-1:8 12chip-ID 22d9:276a
12class-ID 0a00 12serial <filter>
12Report bt-adapter 12ID hci0 12rfk-id 0 12state up 12address N/A
12Device-2 IMC Networks Wireless_Device 12type USB 12driver btusb 12v 0.8 12bus-ID 1-14:4
12chip-ID 13d3:3563 12class-ID e001 12serial <filter>
12Drives:
12Local Storage 12total 491.4 GiB 12used 309.98 GiB (63.1%)
12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Micron 12model 2210 MTFDHBA512QFD 12size 476.94 GiB
12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12type SSD 12serial <filter>
12rev P6MA001 12temp 27.9 C
12SMART yes 12health PASSED 12on 72d 15h 12cycles 1,329 12read-units 55,171,063 [28.2 TB]
12written-units 37,293,770 [19.0 TB]
12ID-2 /dev/sda 12maj-min 8:0 12type USB 12model USB DISK 2.0 12size 14.46 GiB 12block-size 12physical 512 B
12logical 512 B 12type N/A 12serial <filter> 12rev PMAP
12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12Partition:
12ID-1 / 12raw-size 394.3 GiB 12size 394.3 GiB (100.00%) 12used 309.98 GiB (78.6%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p6 12maj-min 259:6
12Swap:
12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default)
12ID-1 swap-1 12type zram 12size 7.6 GiB 12used 296.8 MiB (3.8%) 12priority 100 12dev /dev/zram0
12Sensors:
12System Temperatures 12cpu 41.0 C 12pch 43.0 C 12mobo N/A 12gpu nouveau 12temp 28.0 C
12Fan Speeds (RPM) 12cpu 0
12Info:
12Processes 249 12Uptime 2m 12wakeups 1 12Memory 7.6 GiB 12used 1.85 GiB (24.3%) 12Init systemd 12v 252
12default graphical 12tool systemctl 12Compilers 12gcc 12.2.0 12clang 14.0.6 12Packages 12pm pacman 12pkgs 2036
12libs 558 12tools octopi,paru,pikaur 12Client Unknown Client: rcu_gp 12inxi 3.3.24
Garuda (2.6.12-1):
System install date:     2023-01-03
Last full system update: 2023-01-01
Is partially upgraded:   No
Relevant software:       NetworkManager connman
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Running in chroot, ignoring command 'list-units'
Failed units:

i don't know why it spams "12" over and over.
this is about as far as my knowledge of Linux can get me. I will probably have to reinstall my OS because nothing seems to be working and everything is just broken

Nothing is broken beyond repair. This is probably just something stupid but without Xorg logs or garuda-inxi there's no point in doing any diagnostics. Again, without garuda-inxi from inside the Recovery session there is next to no point in trying to fix anything. That's all I'm asking for. Otherwise all we can do is guess.

Connect to an internet connection either via Ethernet or via nmtui if you want to use garuda-update. (Please do this AFTER the diagnostic checks. We actually want to find the root cause of this problem.)

1 Like

Recovery mode doesn't work. I can't copy the garuda-inxi from inside the recovery session because it won't let me do anything. I don't know why. I certainly would like to. But I'm stuck with an unuseable laptop until I can do something about it.

If you know of some commands I can use to do literally anything, or if you'd like any info I could gather to look deeper into the issue yourself, I'd love to help.
I appreciate the help and the time taken by everyone to look into this issue. But, due to my limited knowledge of Linux and the many issues I've encountered this far, it'd probably be easier for me to either back down from using an Arch based distro or simply go back to a more reliable Windows 10.

Do you have an internet connection in the recovery session? If not, use nmtui to make a connection.

hi,

I've managed to connect and update with nmtui but it didn't work.
No need to bother anymore, i've given up.

Thanks for the help and good luck.

Why would you give up?

If you want, I'd be willing to personally remote into your machine so I can run the diagnostics and fix your machine so this can be prevented in the future. Unfortunately, none of the people that seem to have issues like this have enough knowledge to run any kind of basic diagostics.

Once we know what the diagnostics tell us, we can automate them to auto-fix the problem. I've made attempts at doing that in the current garuda-update, but without actually being able to know what's up it's basically impossible to make any conclusions about the success rate of those.

2 Likes