Garuda no longer boots after trying to install nvidia drivers

Hello, I have a problem :laughing:. I reinstalled Garuda because I wanted to start fresh after a mainboard change. So all other parts have run successfully under Garuda before. Unfortunately fixed, I have already had some errors during the reinstallation. Which I have now in painful work, I am unfortunately not an experienced Linux user and only recently changed from windows. Now I wanted to install the proprietary Nvidia drivers. Unfortunately, then the PC no longer boots and hangs when creating the ramdisk. Now I have selected a snapshot before the driver update and I am back on the desktop. But as soon as I reboot it hangs again at the ramdisk. So I assume that I have to restore the old snapshot somewhere? I also found the Garuda Boot repair tool. Unfortunately I have no idea how to use it, couldn't find anything in the wiki. Can someone maybe guide me so that I can properly boot.

Kernel: 5.16.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/.snapshots/24/snapshot/boot/vmlinuz-linux-zen
root=UUID=aa28c94d-c77f-4890-8293-143f145d4a73 quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
rootflags=defaults,noatime,autodefrag,compress=zstd,discard=async,ssd,[email protected]/.snapshots/24/snapshot
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: BIOSTAR model: Z690GTA serial: <superuser required>
UEFI: American Megatrends LLC. v: 5.24 date: 03/10/2022
CPU:
Info: model: 12th Gen Intel Core i7-12700KF bits: 64 type: MST AMCP
arch: Alder Lake family: 6 model-id: 0x97 (151) stepping: 2 microcode: 0x1A
Topology: cpus: 1x cores: 12 mt: 8 tpc: 2 st: 4 threads: 20 smt: enabled
cache: L1: 1024 KiB desc: d-4x32 KiB, 8x48 KiB; i-8x32 KiB, 4x64 KiB
L2: 12 MiB desc: 8x1.2 MiB, 1x2 MiB L3: 25 MiB desc: 1x25 MiB
Speed (MHz): avg: 3117 high: 4700 min/max: 800/10800:8500 scaling:
driver: intel_pstate governor: performance cores: 1: 3881 2: 800 3: 4368
4: 1093 5: 801 6: 4291 7: 4513 8: 4700 9: 4599 10: 4578 11: 4469 12: 4574
13: 4489 14: 2021 15: 800 16: 801 17: 968 18: 3449 19: 3588 20: 3576
bogomips: 144383
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: Palit Microsystems
driver: nouveau v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2482
class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: DP-3 model: VG259QM serial: <filter> built: 2021
res: 1920x1080 hz: 144 dpi: 90 gamma: 1.2 size: 544x303mm (21.4x11.9")
diag: 623mm (24.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
OpenGL: renderer: llvmpipe (LLVM 13.0.1 256 bits) v: 4.5 Mesa 21.3.7
direct render: Yes
Audio:
Device-1: Intel Alder Lake-S HD Audio vendor: Biostar Microtech Intl Corp
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: Palit Microsystems
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 8086:2725 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Biostar Microtech Intl Corp
driver: r8169 v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000
bus-ID: 05:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0032 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 15.97 GiB (3.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS500G1X0E-00AFY0 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614600WD temp: 42.9 C scheme: GPT
Partition:
ID-1: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 15.97 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 15.97 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 15.97 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.65 GiB used: 3 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 408 Uptime: 27m wakeups: 0 Memory: 62.65 GiB
used: 4.16 GiB (6.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1566 lib: 466 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-24
Last full system update: 2022-03-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            snapper-cleanup.service

It looks like you're still using the nouveau drivers. Did you boot the live boot environment with 'Boot with proprietary drivers' it should install the proprietary drivers during installation instead of needing to install afterwards..

In relation to the snapshot, you must actually tell the system to restore the snapshot after you boot into the snapshot. If you just boot into the snapshot but then reboot, it'll go back to the current filesystem.

3 Likes

Ok that was easy, thx :grin:.

But the problem with the Nvidia drives still exists.When I click on hardware configuration via the settings manager and install the proprietary driver from there, the pc hangs on a restart when creating the ramdisc.

Did you try following NVIDIA - ArchWiki for installing the proprietary driver? Should basically be among the line of:

  1. Remove nouveau
  2. Install nvidia-dkms,nvidia-utils,nvidia-settings
  3. Optional: Modify /etc/mkinitcpio.conf and add nvidia-drm.modeset=1 to grub if you want early loading

EDIT: I believe you could try just using the Garuda Settings Manager -> Hardware Configuration tool and try using the Auto Install Proprietary Driver option, as well..

2 Likes

As this is a new motherboard did you disable fast boot and secure boot in the bios

1 Like

Yes i checked before installation, both were disabled by default.

Updated my previous comment to include another easier option to try. Garuda includes a utility for managing the graphics drivers.

1 Like

i have tried the second variant, then the error occurs. however, i do not receive an error message or anything like that. The installation completes, but as soon as I restart I get stuck when creating the ramdisc.

The initramfs should be created before a reboot. It's used as a launching off point. What does your /etc/mkinitcpio.conf and grub entry look like before/after installing the proprietary driver?

1 Like

Unfortunately I couldn't tell you. In the meantime I have tried the procedure again. Now it seems the pc is not even able so load a old snapshot (which worked before). Since 15 minutes the pc is now loading the snapshot :face_with_diagonal_mouth:.

Edit: Not able to load any of the snapshots. I am now back on the reinstallion.

Still have with this new installation problems to get the nvidia drivers. Now the installation of the drivers fail due to a conflict between python-pyxdg and python-xdg. Do I need to keep them both?

python-xdg can be replaced by python-pyxdg if you're given this option.
If not, install the latter and you should be offered to remove the former.

2 Likes

OK, done. Now I'm back to the problem I had before. :face_exhaling:

maybe I am already one step further...

during the installation of the drivers the firmware of module bfa, qed, qla1280, qla2xxx, wd719x, xhci_pci could not be found. Also molule nvidia, nvidia_modeset, nvidia_uvm and nvidia_dm was not found.

I'm not an hw expert nor a desktop user, anyway I'd be inclined to say you could recheck the wiring on the new motherboard?

1 Like

I can check this, but I do not think that is the reason. I had yesterday after I already had the problems briefly installed windows 11. Here the hardware ran without problems. I formatted the hard drive afterwards of course, so I'm not trying a dual boot currently.

1 Like

When writing, I hadn't read this. This looks like part of the problem, so I think you can disregard my previous message.
Maybe it would help to see the exact input and output text of what you are trying

1 Like

Maybe you could try this tutorial.

If nothing helps, maybe you could try with the linux-lts kernel.

i am unfortunately back to an old snapshot. After deleting the python-pyxdg I tried again to switch to the nvidia drivers. I rebooted and was back to the ramdisc problem. I took 2 bad quality pictures of the messages with my phone to see if I could download the firmware. In the software center I could also find qed-git, aic94xx and wd719x, which were also not installed. The others I have not found yet.

Are you restoring the snapshot?

This is not a problem - it is explicitly listed as a warning, not an error.

This means the NVIDIA driver modules did not build correctly. This would need to be diagnosed prior to you rebooting the system and being unable to reach a graphical interface.

6 Likes